wikimedia-ui-base (main)

sourcepatches
$ date
Tue Jan 25 09:17:06 UTC 2022

$ git clone file:///srv/git/wikimedia-ui-base.git repo --depth=1 -b master
Cloning into 'repo'...

$ git config user.name libraryupgrader

$ git config user.email tools.libraryupgrader@tools.wmflabs.org

$ git submodule update --init

$ grr init
Installed commit-msg hook.

$ git show-ref refs/heads/master
7fe2c9f36a8134a812afdd8e6f36182898121d50 refs/heads/master

Attempting to npm audit fix
$ npm audit fix --only=dev
added 315 packages from 220 contributors in 6.412s

62 packages are looking for funding
  run `npm fund` for details

fixed 2 of 4 vulnerabilities in 315 scanned packages
  2 vulnerabilities required manual review and could not be updated

$ npm audit fix --only=dev
updated 1 package in 2.907s

62 packages are looking for funding
  run `npm fund` for details

fixed 2 of 4 vulnerabilities in 315 scanned packages
  2 vulnerabilities required manual review and could not be updated

$ npm audit fix --only=dev
updated 1 package in 2.784s

62 packages are looking for funding
  run `npm fund` for details

fixed 2 of 4 vulnerabilities in 315 scanned packages
  2 vulnerabilities required manual review and could not be updated

$ package-lock-lint package-lock.json
Checking package-lock.json
nanoid@3.1.23: "resolved" is not a valid URL: "" (relative URL without a base)

Traceback (most recent call last):
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/__init__.py", line 1374, in main
    libup.run(args.repo, args.output, args.branch)
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/__init__.py", line 1318, in run
    self.npm_audit_fix(new_npm_audit)
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/__init__.py", line 211, in npm_audit_fix
    self.check_package_lock()
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/__init__.py", line 268, in check_package_lock
    self.check_call(['package-lock-lint', 'package-lock.json'])
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/shell2.py", line 40, in check_call
    res.check_returncode()
  File "/usr/lib/python3.7/subprocess.py", line 428, in check_returncode
    self.stderr)
subprocess.CalledProcessError: Command '['package-lock-lint', 'package-lock.json']' returned non-zero exit status 1.

npm dependencies

Development dependencies

Logs

Source code is licensed under the AGPL.