mediawiki/extensions/WikibaseQualityConstraints (main)

sourcepatches
$ date
Fri Jan 14 03:03:09 UTC 2022

$ git clone file:///srv/git/mediawiki-extensions-WikibaseQualityConstraints.git repo --depth=1 -b master
Cloning into 'repo'...

$ git config user.name libraryupgrader

$ git config user.email tools.libraryupgrader@tools.wmflabs.org

$ git submodule update --init

$ grr init
Installed commit-msg hook.

$ git show-ref refs/heads/master
7f75d8b11d36dc280e0e83f5124ff23e4aca1178 refs/heads/master

$ composer install
Loading composer repositories with package information
Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/
Updating dependencies (including require-dev)
Package operations: 43 installs, 0 updates, 0 removals
  - Installing squizlabs/php_codesniffer (3.6.1): Loading from cache
  - Installing composer/spdx-licenses (1.5.6): Loading from cache
  - Installing composer/semver (3.2.7): Loading from cache
  - Installing mediawiki/mediawiki-codesniffer (v38.0.0): Loading from cache
  - Installing tysonandre/var_representation_polyfill (0.1.1): Loading from cache
  - Installing symfony/polyfill-php80 (v1.24.0): Loading from cache
  - Installing symfony/polyfill-mbstring (v1.24.0): Loading from cache
  - Installing symfony/polyfill-intl-normalizer (v1.24.0): Loading from cache
  - Installing symfony/polyfill-intl-grapheme (v1.24.0): Loading from cache
  - Installing symfony/polyfill-ctype (v1.24.0): Loading from cache
  - Installing symfony/string (v5.4.2): Loading from cache
  - Installing symfony/deprecation-contracts (v2.5.0): Loading from cache
  - Installing psr/container (1.1.1): Loading from cache
  - Installing symfony/service-contracts (v2.5.0): Loading from cache
  - Installing symfony/polyfill-php73 (v1.24.0): Loading from cache
  - Installing symfony/console (v5.4.2): Loading from cache
  - Installing psr/log (1.1.4): Loading from cache
  - Installing sabre/event (5.1.4): Loading from cache
  - Installing netresearch/jsonmapper (v4.0.0): Loading from cache
  - Installing microsoft/tolerant-php-parser (v0.1.1): Loading from cache
  - Installing phpdocumentor/reflection-common (2.2.0): Loading from cache
  - Installing webmozart/assert (1.10.0): Loading from cache
  - Installing phpdocumentor/type-resolver (1.6.0): Loading from cache
  - Installing phpdocumentor/reflection-docblock (5.3.0): Loading from cache
  - Installing felixfbecker/advanced-json-rpc (v3.2.1): Loading from cache
  - Installing composer/pcre (1.0.0): Loading from cache
  - Installing composer/xdebug-handler (2.0.4): Loading from cache
  - Installing phan/phan (5.2.0): Loading from cache
  - Installing mediawiki/phan-taint-check-plugin (3.3.2): Loading from cache
  - Installing mediawiki/mediawiki-phan-config (0.11.0): Loading from cache
  - Installing mediawiki/minus-x (1.1.1): Loading from cache
  - Installing php-parallel-lint/php-console-color (v0.3): Loading from cache
  - Installing php-parallel-lint/php-console-highlighter (v0.5): Loading from cache
  - Installing php-parallel-lint/php-parallel-lint (v1.3.1): Loading from cache
  - Installing data-values/interfaces (0.2.5): Loading from cache
  - Installing data-values/data-values (2.3.0): Loading from cache
  - Installing data-values/geo (4.3.0): Loading from cache
  - Installing data-values/common (0.4.3): Loading from cache
  - Installing data-values/number (0.11.1): Loading from cache
  - Installing data-values/time (1.0.4): Loading from cache
  - Installing serialization/serialization (4.0.0): Loading from cache
  - Installing data-values/serialization (1.2.4): Loading from cache
  - Installing wikimedia/purtle (v1.0.8): Loading from cache
tysonandre/var_representation_polyfill suggests installing ext-var_representation (*)
symfony/service-contracts suggests installing symfony/service-implementation
symfony/console suggests installing symfony/event-dispatcher
symfony/console suggests installing symfony/lock
symfony/console suggests installing symfony/process
phan/phan suggests installing ext-ast (Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is needed, 1.0.14+ is recommended.)
phan/phan suggests installing ext-var_representation (Suggested for converting values to strings in issue messages)
Writing lock file
Generating autoload files
15 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

Upgrading c:mediawiki/mediawiki-phan-config from 0.11.0 -> 0.11.1
$ composer update
Loading composer repositories with package information
Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/
Updating dependencies (including require-dev)
Package operations: 0 installs, 1 update, 0 removals
  - Updating mediawiki/mediawiki-phan-config (0.11.0 => 0.11.1): Loading from cache
Writing lock file
Generating autoload files
15 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

$ composer install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Nothing to install or update
Generating autoload files
15 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

$ composer test
> composer validate --no-interaction
./composer.json is valid
> parallel-lint . --exclude vendor --exclude node_modules
PHP 7.3.29 | 10 parallel jobs
............................................................  60/222 (27 %)
............................................................ 120/222 (54 %)
............................................................ 180/222 (81 %)
..........................................                   222/222 (100 %)


Checked 222 files in 1.1 seconds
No syntax error found
> phpcs -sp --cache
............................................................  60 / 221 (27%)
............................................................ 120 / 221 (54%)
............................................................ 180 / 221 (81%)
.........................................                    221 / 221 (100%)


Time: 200ms; Memory: 18MB

> minus-x check .
MinusX
======
Processing /src/repo...
.............................................................
.............................................................
.............................................................
.............................................................
.............................................................
.............................................................
........................................................
All good!

Attempting to npm audit fix
$ npm audit fix --only=dev

> core-js@3.19.1 postinstall /src/repo/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library!

The project needs your help! Please consider supporting of core-js:
> https://opencollective.com/core-js 
> https://patreon.com/zloirock 
> https://paypal.me/zloirock 
> bitcoin: bc1qlea7544qtsmj2rayg0lthvza9fau63ux0fstcz 

Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -)

added 604 packages from 380 contributors in 11.392s

94 packages are looking for funding
  run `npm fund` for details

fixed 0 of 4 vulnerabilities in 604 scanned packages
  4 vulnerabilities required manual review and could not be updated

$ npm audit fix --only=dev
npm WARN eslint-plugin-compat@3.13.0 requires a peer of eslint@^4.0.0 || ^5.0.0 || ^6.0.0 || ^7.0.0 but none is installed. You must install peer dependencies yourself.

up to date in 2.921s

94 packages are looking for funding
  run `npm fund` for details

fixed 0 of 4 vulnerabilities in 604 scanned packages
  4 vulnerabilities required manual review and could not be updated

$ npm audit fix --only=dev
npm WARN eslint-plugin-compat@3.13.0 requires a peer of eslint@^4.0.0 || ^5.0.0 || ^6.0.0 || ^7.0.0 but none is installed. You must install peer dependencies yourself.

up to date in 3.347s

94 packages are looking for funding
  run `npm fund` for details

fixed 0 of 4 vulnerabilities in 604 scanned packages
  4 vulnerabilities required manual review and could not be updated

$ package-lock-lint package-lock.json
Checking package-lock.json

Verifying that tests still pass
$ npm ci
npm WARN prepare removing existing node_modules/ before installation

> core-js@3.19.1 postinstall /src/repo/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

added 604 packages in 8.594s

$ npm test

> @ test /src/repo
> grunt test

Loading "eslint.js" tasks...ERROR
>> TypeError: Module.createRequire is not a function
Warning: Task "eslint" not found. Use --force to continue.

Aborted due to warnings.
npm ERR! Test failed.  See above for more details.

Traceback (most recent call last):
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/__init__.py", line 1374, in main
    libup.run(args.repo, args.output, args.branch)
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/__init__.py", line 1318, in run
    self.npm_audit_fix(new_npm_audit)
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/__init__.py", line 216, in npm_audit_fix
    self.check_call(['npm', 'test'])
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/shell2.py", line 40, in check_call
    res.check_returncode()
  File "/usr/lib/python3.7/subprocess.py", line 428, in check_returncode
    self.stderr)
subprocess.CalledProcessError: Command '['npm', 'test']' returned non-zero exit status 1.

composer dependencies

Dependencies
Development dependencies

npm dependencies

Development dependencies

Logs

Source code is licensed under the AGPL.