mediawiki/extensions/CirrusSearch (main)

sourcepatches
$ date
Sat Jun 19 06:58:44 UTC 2021

$ git clone file:///srv/git/mediawiki-extensions-CirrusSearch.git repo --depth=1 -b master
Cloning into 'repo'...

$ git config user.name libraryupgrader

$ git config user.email tools.libraryupgrader@tools.wmflabs.org

$ git submodule update --init

$ grr init
Installed commit-msg hook.

$ git show-ref refs/heads/master
b0a77bf054e24006ad3b6ee621911e3e1d9196ce refs/heads/master

$ composer install
Loading composer repositories with package information
Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/
Updating dependencies (including require-dev)
Package operations: 36 installs, 0 updates, 0 removals
  - Installing wikimedia/textcat (1.3.0): Loading from cache
  - Installing wikimedia/lucene-explain-parser (1.0.0): Loading from cache
  - Installing squizlabs/php_codesniffer (3.6.0): Loading from cache
  - Installing composer/spdx-licenses (1.5.5): Loading from cache
  - Installing composer/semver (dev-main 31f3ea7): Cloning 31f3ea7257 from cache
  - Installing mediawiki/mediawiki-codesniffer (v36.0.0): Loading from cache
  - Installing symfony/polyfill-php80 (dev-main eca0bf4): Cloning eca0bf41ed from cache
  - Installing symfony/polyfill-mbstring (dev-main 9174a3d): Cloning 9174a3d802 from cache
  - Installing symfony/polyfill-intl-normalizer (dev-main 8590a5f): Cloning 8590a5f561 from cache
  - Installing symfony/polyfill-intl-grapheme (dev-main 16880ba): Cloning 16880ba9c5 from cache
  - Installing symfony/polyfill-ctype (dev-main 46cd957): Cloning 46cd95797e from cache
  - Installing symfony/string (5.4.x-dev 92855c7): Cloning 92855c727d from cache
  - Installing psr/container (1.1.x-dev 8622567): Cloning 8622567409 from cache
  - Installing symfony/service-contracts (v2.4.0): Loading from cache
  - Installing symfony/polyfill-php73 (dev-main fba8933): Cloning fba8933c38 from cache
  - Installing symfony/deprecation-contracts (dev-main 36b691b): Cloning 36b691b0bd from cache
  - Installing psr/log (dev-master d49695b): Cloning d49695b909 from cache
  - Installing symfony/console (5.4.x-dev 4411daa): Cloning 4411daa706 from cache
  - Installing sabre/event (5.1.2): Loading from cache
  - Installing netresearch/jsonmapper (v3.1.1): Loading from cache
  - Installing microsoft/tolerant-php-parser (v0.0.23): Loading from cache
  - Installing phpdocumentor/reflection-common (dev-master cf8df60): Cloning cf8df60735 from cache
  - Installing webmozart/assert (dev-master 8403a94): Cloning 8403a94103 from cache
  - Installing phpdocumentor/type-resolver (1.x-dev 6759f22): Cloning 6759f2268d from cache
  - Installing phpdocumentor/reflection-docblock (dev-master 8719cc1): Cloning 8719cc12e2 from cache
  - Installing felixfbecker/advanced-json-rpc (v3.2.1): Loading from cache
  - Installing composer/xdebug-handler (1.4.x-dev f27e06c): Cloning f27e06cd96 from cache
  - Installing phan/phan (3.2.6): Loading from cache
  - Installing mediawiki/phan-taint-check-plugin (3.2.1): Loading from cache
  - Installing mediawiki/mediawiki-phan-config (0.10.6): Loading from cache
  - Installing mediawiki/minus-x (1.1.1): Loading from cache
  - Installing php-parallel-lint/php-console-color (v0.3): Loading from cache
  - Installing php-parallel-lint/php-console-highlighter (v0.5): Loading from cache
  - Installing php-parallel-lint/php-parallel-lint (v1.3.0): Loading from cache
  - Installing justinrainbow/json-schema (5.x-dev 2ba9c8c): Cloning 2ba9c8c862 from cache
  - Installing symfony/yaml (5.0.x-dev 29b60e8): Cloning 29b60e88ff from cache
symfony/service-contracts suggests installing symfony/service-implementation
symfony/console suggests installing symfony/event-dispatcher
symfony/console suggests installing symfony/lock
symfony/console suggests installing symfony/process
phan/phan suggests installing ext-ast (Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is needed, 1.0.8+ is recommended.)
Writing lock file
Generating autoload files
14 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

Attempting to npm audit fix
$ npm audit fix --only=dev
npm WARN read-shrinkwrap This version of npm is compatible with lockfileVersion@1, but package-lock.json was generated for lockfileVersion@2. I'll try to do my best with it!

> fibers_node_v8@3.1.5 preinstall /src/repo/node_modules/fibers_node_v8
> node preinstall.js


> fibers@4.0.3 install /src/repo/node_modules/fibers
> node build.js || nodejs build.js

`linux-x64-64-glibc` exists; testing
Binary is fine; exiting

> fibers_node_v8@3.1.5 install /src/repo/node_modules/fibers_node_v8
> node build.js

ignore install

> dtrace-provider@0.8.8 install /src/repo/node_modules/dtrace-provider
> node-gyp rebuild || node suppress-error.js

make: Entering directory '/src/repo/node_modules/dtrace-provider/build'
  TOUCH Release/obj.target/DTraceProviderStub.stamp
make: Leaving directory '/src/repo/node_modules/dtrace-provider/build'

> core-js@2.6.12 postinstall /src/repo/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library!

The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 
> https://opencollective.com/core-js 
> https://www.patreon.com/zloirock 

Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -)


> core-js@3.14.0 postinstall /src/repo/node_modules/eslint-plugin-compat/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/mocha/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

added 930 packages from 792 contributors in 50.818s

107 packages are looking for funding
  run `npm fund` for details

fixed 7 of 11 vulnerabilities in 935 scanned packages
  4 vulnerabilities required manual review and could not be updated

$ npm audit fix --only=dev
npm WARN @wdio/cucumber-framework@5.23.0 requires a peer of @wdio/cli@^5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @wdio/dot-reporter@5.16.5 requires a peer of @wdio/cli@^5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @wdio/junit-reporter@5.22.4 requires a peer of @wdio/cli@^5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @wdio/local-runner@5.23.0 requires a peer of @wdio/cli@^5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @wdio/spec-reporter@5.23.0 requires a peer of @wdio/cli@^5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN grunt-stylelint@0.16.0 requires a peer of stylelint@^13.8.0 but none is installed. You must install peer dependencies yourself.
npm WARN grunt-webdriver@3.0.0 requires a peer of @wdio/cli@^5.1.0 but none is installed. You must install peer dependencies yourself.
npm WARN stylelint-no-unsupported-browser-features@4.1.4 requires a peer of stylelint@>=11.1.1 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/mocha/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

up to date in 4.759s

107 packages are looking for funding
  run `npm fund` for details

fixed 0 of 4 vulnerabilities in 935 scanned packages
  4 vulnerabilities required manual review and could not be updated

$ npm audit fix --only=dev
npm WARN @wdio/cucumber-framework@5.23.0 requires a peer of @wdio/cli@^5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @wdio/dot-reporter@5.16.5 requires a peer of @wdio/cli@^5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @wdio/junit-reporter@5.22.4 requires a peer of @wdio/cli@^5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @wdio/local-runner@5.23.0 requires a peer of @wdio/cli@^5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @wdio/spec-reporter@5.23.0 requires a peer of @wdio/cli@^5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN grunt-stylelint@0.16.0 requires a peer of stylelint@^13.8.0 but none is installed. You must install peer dependencies yourself.
npm WARN grunt-webdriver@3.0.0 requires a peer of @wdio/cli@^5.1.0 but none is installed. You must install peer dependencies yourself.
npm WARN stylelint-no-unsupported-browser-features@4.1.4 requires a peer of stylelint@>=11.1.1 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/mocha/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

up to date in 4.421s

107 packages are looking for funding
  run `npm fund` for details

fixed 0 of 4 vulnerabilities in 935 scanned packages
  4 vulnerabilities required manual review and could not be updated

$ package-lock-lint package-lock.json
0 issues found in: package-lock.json

Verifying that tests still pass
$ npm ci
npm WARN prepare removing existing node_modules/ before installation

> core-js@2.6.12 postinstall /src/repo/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> dtrace-provider@0.8.8 install /src/repo/node_modules/dtrace-provider
> node-gyp rebuild || node suppress-error.js

make: Entering directory '/src/repo/node_modules/dtrace-provider/build'
  TOUCH Release/obj.target/DTraceProviderStub.stamp
make: Leaving directory '/src/repo/node_modules/dtrace-provider/build'

> core-js@3.14.0 postinstall /src/repo/node_modules/eslint-plugin-compat/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> fibers@4.0.3 install /src/repo/node_modules/fibers
> node build.js || nodejs build.js

`linux-x64-64-glibc` exists; testing
Binary is fine; exiting

> fibers_node_v8@3.1.5 preinstall /src/repo/node_modules/fibers_node_v8
> node preinstall.js


> fibers_node_v8@3.1.5 install /src/repo/node_modules/fibers_node_v8
> node build.js

ignore install
added 931 packages in 15.908s

$ npm test

> cirrussearch@0.0.0 test /src/repo
> grunt test

Running "eslint:all" (eslint) task

/src/repo/tests/phpunit/fixtures/configDump/enwiki_crosslang_frwiki_config.json
  0:0  warning  File ignored because of a matching ignore pattern. Use "--no-ignore" to override

/src/repo/tests/phpunit/fixtures/configDump/enwiki_crosslang_frwiki_invalid_config.json
  0:0  warning  File ignored because of a matching ignore pattern. Use "--no-ignore" to override

/src/repo/tests/phpunit/fixtures/configDump/enwiki_sisterproject_configs.json
  0:0  warning  File ignored because of a matching ignore pattern. Use "--no-ignore" to override

/src/repo/tests/phpunit/fixtures/regexParser/ref_impl_fixtures.json
  0:0  warning  File ignored because of a matching ignore pattern. Use "--no-ignore" to override

✖ 4 problems (0 errors, 4 warnings)


Running "banana:all" (banana) task
>> 2 message directories checked.

Running "stylelint:all" (stylelint) task
Warning: Cannot find module 'stylelint' Use --force to continue.

Aborted due to warnings.
npm ERR! Test failed.  See above for more details.

Traceback (most recent call last):
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/__init__.py", line 1325, in main
    libup.run(args.repo, args.output, args.branch)
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/__init__.py", line 1270, in run
    self.npm_audit_fix(new_npm_audit)
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/__init__.py", line 216, in npm_audit_fix
    self.check_call(['npm', 'test'])
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/shell2.py", line 40, in check_call
    res.check_returncode()
  File "/usr/lib/python3.7/subprocess.py", line 428, in check_returncode
    self.stderr)
subprocess.CalledProcessError: Command '['npm', 'test']' returned non-zero exit status 1.

composer dependencies

Dependencies
Development dependencies

npm dependencies

Development dependencies

Logs

Source code is licensed under the AGPL.