mediawiki/services/function-schemata (main)

sourcepatches
$ date
Fri Jan 14 07:01:57 UTC 2022

$ git clone file:///srv/git/mediawiki-services-function-schemata.git repo --depth=1 -b master
Cloning into 'repo'...

$ git config user.name libraryupgrader

$ git config user.email tools.libraryupgrader@tools.wmflabs.org

$ git submodule update --init

$ grr init
Installed commit-msg hook.

$ git show-ref refs/heads/master
75f4a3c7a249e0d8dacfd283b749c1a6ff30616c refs/heads/master

Attempting to npm audit fix
$ npm audit fix --only=dev

> core-js@3.19.1 postinstall /src/repo/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library!

The project needs your help! Please consider supporting of core-js:
> https://opencollective.com/core-js 
> https://patreon.com/zloirock 
> https://paypal.me/zloirock 
> bitcoin: bc1qlea7544qtsmj2rayg0lthvza9fau63ux0fstcz 

Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -)

npm WARN function-schemata@ No repository field.

added 279 packages from 183 contributors in 13.173s

38 packages are looking for funding
  run `npm fund` for details

fixed 4 of 4 vulnerabilities in 286 scanned packages

$ npm audit fix --only=dev
npm WARN eslint-plugin-unicorn@37.0.1 requires a peer of eslint@>=7.32.0 but none is installed. You must install peer dependencies yourself.
npm WARN function-schemata@ No repository field.

up to date in 1.792s

38 packages are looking for funding
  run `npm fund` for details

fixed 0 of 0 vulnerabilities in 286 scanned packages

$ npm audit fix --only=dev
npm WARN eslint-plugin-unicorn@37.0.1 requires a peer of eslint@>=7.32.0 but none is installed. You must install peer dependencies yourself.
npm WARN function-schemata@ No repository field.

up to date in 1.92s

38 packages are looking for funding
  run `npm fund` for details

fixed 0 of 0 vulnerabilities in 286 scanned packages

$ package-lock-lint package-lock.json
Checking package-lock.json

Verifying that tests still pass
$ npm ci
npm WARN prepare removing existing node_modules/ before installation

> core-js@3.19.1 postinstall /src/repo/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

added 286 packages in 5.987s

$ npm test

> function-schemata@ test /src/repo
> npm run lint && qunit javascript/


> function-schemata@ lint /src/repo
> eslint --cache --max-warnings 0 --ext .js,.json .


Oops! Something went wrong! :(

ESLint: 7.25.0

TypeError: Failed to load plugin 'unicorn' declared in '.eslintrc.json » eslint-config-wikimedia/server » ./language/es2018 » ./rules-es2018': Object.fromEntries is not a function
    at Object.<anonymous> (/src/repo/node_modules/eslint-plugin-unicorn/configs/all.js:7:13)
    at Module._compile (/src/repo/node_modules/v8-compile-cache/v8-compile-cache.js:192:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
    at Module.load (internal/modules/cjs/loader.js:653:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
    at Function.Module._load (internal/modules/cjs/loader.js:585:3)
    at Module.require (internal/modules/cjs/loader.js:692:17)
    at require (/src/repo/node_modules/v8-compile-cache/v8-compile-cache.js:159:20)
    at Object.<anonymous> (/src/repo/node_modules/eslint-plugin-unicorn/index.js:5:13)
    at Module._compile (/src/repo/node_modules/v8-compile-cache/v8-compile-cache.js:192:30)
npm ERR! code ELIFECYCLE
npm ERR! errno 2
npm ERR! function-schemata@ lint: `eslint --cache --max-warnings 0 --ext .js,.json .`
npm ERR! Exit status 2
npm ERR! 
npm ERR! Failed at the function-schemata@ lint script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /cache/_logs/2022-01-14T07_02_35_073Z-debug.log
npm ERR! Test failed.  See above for more details.

Traceback (most recent call last):
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/__init__.py", line 1374, in main
    libup.run(args.repo, args.output, args.branch)
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/__init__.py", line 1318, in run
    self.npm_audit_fix(new_npm_audit)
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/__init__.py", line 216, in npm_audit_fix
    self.check_call(['npm', 'test'])
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/shell2.py", line 40, in check_call
    res.check_returncode()
  File "/usr/lib/python3.7/subprocess.py", line 428, in check_returncode
    self.stderr)
subprocess.CalledProcessError: Command '['npm', 'test']' returned non-zero exit status 1.

npm dependencies

Dependencies
Development dependencies

Logs

Source code is licensed under the AGPL.