mediawiki/libs/Equivset (master)

sourcepatches
From 6a98dbe4ebc38871d084685f49a6a731bdc8c485 Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Wed, 5 May 2021 11:04:42 +0000
Subject: [PATCH] build: Updating composer dependencies
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* mediawiki/mediawiki-codesniffer: 35.0.0 → 36.0.0
* php-parallel-lint/php-parallel-lint: 1.2.0 → 1.3.0

Change-Id: I3ec7d84a8722be968c7e25a35c4989ca898ad948
---
 composer.json | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/composer.json b/composer.json
index 5b87d0d..99453c5 100644
--- a/composer.json
+++ b/composer.json
@@ -28,12 +28,12 @@
 		"wikimedia/utfnormal": "^1.1.0 || ^2.0.0 || ^3.0.1"
 	},
 	"require-dev": {
-		"mediawiki/mediawiki-codesniffer": "35.0.0",
+		"mediawiki/mediawiki-codesniffer": "36.0.0",
 		"mediawiki/minus-x": "1.1.1",
 		"mikey179/vfsstream": "^1.6",
 		"ockcyp/covers-validator": "1.3.3",
 		"php-parallel-lint/php-console-highlighter": "0.5.0",
-		"php-parallel-lint/php-parallel-lint": "1.2.0",
+		"php-parallel-lint/php-parallel-lint": "1.3.0",
 		"phpunit/phpunit": "^8.5 || ^9.5",
 		"rregeer/phpunit-coverage-check": "~0.1.4",
 		"symfony/console": "^3.3 || ^4 || ^5",
-- 
2.20.1

$ date
Wed May  5 11:04:19 UTC 2021

$ git clone file:///srv/git/mediawiki-libs-Equivset.git repo --depth=1 -b master
Cloning into 'repo'...

$ git config user.name libraryupgrader

$ git config user.email tools.libraryupgrader@tools.wmflabs.org

$ git submodule update --init

$ grr init
Installed commit-msg hook.

$ git show-ref refs/heads/master
8a7b83c1278fb11aa1b8ebffdb967dfd641a01eb refs/heads/master

$ composer install
Loading composer repositories with package information
Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2
Updating dependencies (including require-dev)
Package operations: 56 installs, 0 updates, 0 removals
  - Installing squizlabs/php_codesniffer (3.5.8): Loading from cache
  - Installing composer/spdx-licenses (1.5.5): Loading from cache
  - Installing composer/semver (3.2.4): Loading from cache
  - Installing mediawiki/mediawiki-codesniffer (v35.0.0): Loading from cache
  - Installing symfony/polyfill-php80 (v1.22.1): Loading from cache
  - Installing symfony/polyfill-mbstring (v1.22.1): Loading from cache
  - Installing symfony/polyfill-intl-normalizer (v1.22.1): Loading from cache
  - Installing symfony/polyfill-intl-grapheme (v1.22.1): Loading from cache
  - Installing symfony/polyfill-ctype (v1.22.1): Loading from cache
  - Installing symfony/string (v5.2.6): Loading from cache
  - Installing psr/container (1.1.1): Loading from cache
  - Installing symfony/service-contracts (v2.4.0): Loading from cache
  - Installing symfony/polyfill-php73 (v1.22.1): Loading from cache
  - Installing symfony/console (v5.2.7): Loading from cache
  - Installing mediawiki/minus-x (1.1.1): Loading from cache
  - Installing sebastian/version (3.0.2): Loading from cache
  - Installing sebastian/type (2.3.1): Loading from cache
  - Installing sebastian/resource-operations (3.0.3): Loading from cache
  - Installing sebastian/recursion-context (4.0.4): Loading from cache
  - Installing sebastian/object-reflector (2.0.4): Loading from cache
  - Installing sebastian/object-enumerator (4.0.4): Loading from cache
  - Installing sebastian/global-state (5.0.2): Loading from cache
  - Installing sebastian/exporter (4.0.3): Loading from cache
  - Installing sebastian/environment (5.1.3): Loading from cache
  - Installing sebastian/diff (4.0.4): Loading from cache
  - Installing sebastian/comparator (4.0.6): Loading from cache
  - Installing sebastian/code-unit (1.0.8): Loading from cache
  - Installing sebastian/cli-parser (1.0.1): Loading from cache
  - Installing phpunit/php-timer (5.0.3): Loading from cache
  - Installing phpunit/php-text-template (2.0.4): Loading from cache
  - Installing phpunit/php-invoker (3.1.1): Loading from cache
  - Installing phpunit/php-file-iterator (3.0.5): Loading from cache
  - Installing theseer/tokenizer (1.2.0): Loading from cache
  - Installing nikic/php-parser (v4.10.5): Loading from cache
  - Installing sebastian/lines-of-code (1.0.3): Loading from cache
  - Installing sebastian/complexity (2.0.2): Loading from cache
  - Installing sebastian/code-unit-reverse-lookup (2.0.3): Loading from cache
  - Installing phpunit/php-code-coverage (9.2.6): Loading from cache
  - Installing doctrine/instantiator (1.4.0): Loading from cache
  - Installing phpdocumentor/reflection-common (2.2.0): Loading from cache
  - Installing webmozart/assert (1.10.0): Loading from cache
  - Installing phpdocumentor/type-resolver (1.4.0): Loading from cache
  - Installing phpdocumentor/reflection-docblock (5.2.2): Loading from cache
  - Installing phpspec/prophecy (1.13.0): Loading from cache
  - Installing phar-io/version (3.1.0): Loading from cache
  - Installing phar-io/manifest (2.0.1): Loading from cache
  - Installing myclabs/deep-copy (1.10.2): Loading from cache
  - Installing phpunit/phpunit (9.5.4): Loading from cache
  - Installing ockcyp/covers-validator (v1.3.3): Loading from cache
  - Installing php-parallel-lint/php-console-color (v0.3): Loading from cache
  - Installing php-parallel-lint/php-console-highlighter (v0.5): Loading from cache
  - Installing php-parallel-lint/php-parallel-lint (v1.2.0): Loading from cache
  - Installing wikimedia/utfnormal (3.0.2): Loading from cache
  - Installing mikey179/vfsstream (v1.6.8): Loading from cache
  - Installing rregeer/phpunit-coverage-check (0.1.6): Loading from cache
  - Installing symfony/var-dumper (v5.2.7): Loading from cache
symfony/service-contracts suggests installing symfony/service-implementation
symfony/console suggests installing symfony/event-dispatcher
symfony/console suggests installing symfony/lock
symfony/console suggests installing symfony/process
symfony/console suggests installing psr/log (For using the console logger)
sebastian/global-state suggests installing ext-uopz (*)
phpunit/php-code-coverage suggests installing ext-pcov (*)
phpunit/php-code-coverage suggests installing ext-xdebug (*)
phpunit/phpunit suggests installing ext-soap (*)
phpunit/phpunit suggests installing ext-xdebug (*)
Writing lock file
Generating autoload files
37 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

Upgrading c:mediawiki/mediawiki-codesniffer from 35.0.0 -> 36.0.0
Upgrading c:php-parallel-lint/php-parallel-lint from 1.2.0 -> 1.3.0
$ composer update
Loading composer repositories with package information
Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2
Updating dependencies (including require-dev)
Package operations: 0 installs, 3 updates, 0 removals
  - Updating squizlabs/php_codesniffer (3.5.8 => 3.6.0): Loading from cache
  - Updating mediawiki/mediawiki-codesniffer (v35.0.0 => v36.0.0): Loading from cache
  - Updating php-parallel-lint/php-parallel-lint (v1.2.0 => v1.3.0): Loading from cache
Writing lock file
Generating autoload files
37 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

{'MediaWiki.Commenting.MissingCovers.MissingCovers', 'MediaWiki.Commenting.FunctionComment.MissingReturn'}
Tests fail!
$ git checkout .phpcs.xml

$ composer install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Nothing to install or update
Generating autoload files
37 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

$ composer test
> parallel-lint . --exclude vendor
PHP 7.3.27 | 10 parallel jobs
......                                                       6/6 (100 %)


Checked 6 files in 0.1 seconds
No syntax error found
> php -d 'zend_extension=xdebug.so' -d 'xdebug.mode=coverage' vendor/bin/phpunit
PHPUnit 9.5.4 by Sebastian Bergmann and contributors.

  Warning - The configuration file did not pass validation!
  The following problems have been detected:

  Line 15:
  - Element 'log': This element is not expected.

  Line 17:
  - Element 'filter': This element is not expected.

  Test results may not be as expected.


..................................                                34 / 34 (100%)

Time: 00:03.660, Memory: 16.00 MB

OK (34 tests, 52 assertions)

Generating code coverage report in Clover XML format ... done [00:00.024]
> covers-validator
CoversValidator 1.3.3

Validation complete. All @covers tags are valid.
> coverage-check ./coverage/clover.xml 100
Total code coverage is 100.00% - OK!
> phpcs -sp
...... 6 / 6 (100%)


Time: 165ms; Memory: 10MB

> minus-x check .
MinusX
======
Processing /src/repo...
..........................
All good!

$ git add .

$ git commit -F /tmp/tmpgr89sbrr
[master 6a98dbe] build: Updating composer dependencies
 1 file changed, 2 insertions(+), 2 deletions(-)

$ git format-patch HEAD~1 --stdout
From 6a98dbe4ebc38871d084685f49a6a731bdc8c485 Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Wed, 5 May 2021 11:04:42 +0000
Subject: [PATCH] build: Updating composer dependencies
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* mediawiki/mediawiki-codesniffer: 35.0.0 → 36.0.0
* php-parallel-lint/php-parallel-lint: 1.2.0 → 1.3.0

Change-Id: I3ec7d84a8722be968c7e25a35c4989ca898ad948
---
 composer.json | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/composer.json b/composer.json
index 5b87d0d..99453c5 100644
--- a/composer.json
+++ b/composer.json
@@ -28,12 +28,12 @@
 		"wikimedia/utfnormal": "^1.1.0 || ^2.0.0 || ^3.0.1"
 	},
 	"require-dev": {
-		"mediawiki/mediawiki-codesniffer": "35.0.0",
+		"mediawiki/mediawiki-codesniffer": "36.0.0",
 		"mediawiki/minus-x": "1.1.1",
 		"mikey179/vfsstream": "^1.6",
 		"ockcyp/covers-validator": "1.3.3",
 		"php-parallel-lint/php-console-highlighter": "0.5.0",
-		"php-parallel-lint/php-parallel-lint": "1.2.0",
+		"php-parallel-lint/php-parallel-lint": "1.3.0",
 		"phpunit/phpunit": "^8.5 || ^9.5",
 		"rregeer/phpunit-coverage-check": "~0.1.4",
 		"symfony/console": "^3.3 || ^4 || ^5",
-- 
2.20.1

composer dependencies

Dependencies
Development dependencies

Logs

Source code is licensed under the AGPL.