mediawiki/extensions/WikibaseLexeme (REL1_35)

sourcepatches
$ date
Fri Nov  5 03:55:11 UTC 2021

$ git clone file:///srv/git/mediawiki-extensions-WikibaseLexeme.git repo --depth=1 -b REL1_35
Cloning into 'repo'...

$ git config user.name libraryupgrader

$ git config user.email tools.libraryupgrader@tools.wmflabs.org

$ git submodule update --init

$ grr init
Installed commit-msg hook.

$ git show-ref refs/heads/REL1_35
b27b2736ce69bac17d7bb20dad32142ad1bf311d refs/heads/REL1_35

$ composer install
Loading composer repositories with package information
                                                      Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/
Updating dependencies (including require-dev)
Package operations: 57 installs, 0 updates, 0 removals
  - Installing giorgiosironi/eris (0.10.0): Loading from cache
  - Installing patchwork/utf8 (v1.3.3): Loading from cache
  - Installing doctrine/lexer (1.2.1): Loading from cache
  - Installing psr/cache (1.0.1): Loading from cache
  - Installing doctrine/annotations (1.13.2): Loading from cache
  - Installing doctrine/reflection (1.2.2): Loading from cache
  - Installing doctrine/event-manager (1.1.1): Loading from cache
  - Installing doctrine/collections (1.6.8): Loading from cache
  - Installing doctrine/cache (1.12.1): Loading from cache
  - Installing doctrine/persistence (1.3.8): Loading from cache
  - Installing doctrine/inflector (1.4.4): Loading from cache
  - Installing doctrine/common (2.13.3): Loading from cache
  - Installing icomefromthenet/reverse-regex (v0.0.6.3): Loading from cache
  - Installing symfony/polyfill-mbstring (v1.23.1): Loading from cache
  - Installing symfony/polyfill-php80 (v1.23.1): Loading from cache
  - Installing symfony/polyfill-intl-normalizer (v1.23.0): Loading from cache
  - Installing symfony/polyfill-intl-grapheme (v1.23.1): Loading from cache
  - Installing symfony/polyfill-ctype (v1.23.0): Loading from cache
  - Installing symfony/string (v5.3.10): Loading from cache
  - Installing psr/container (1.1.1): Loading from cache
  - Installing symfony/service-contracts (v2.4.0): Loading from cache
  - Installing symfony/polyfill-php73 (v1.23.0): Loading from cache
  - Installing symfony/deprecation-contracts (v2.4.0): Loading from cache
  - Installing symfony/console (v5.3.10): Loading from cache
  - Installing psr/log (1.1.4): Loading from cache
  - Installing sabre/event (5.1.4): Loading from cache
  - Installing netresearch/jsonmapper (v2.1.0): Loading from cache
  - Installing microsoft/tolerant-php-parser (v0.0.20): Loading from cache
  - Installing phpdocumentor/reflection-common (2.2.0): Loading from cache
  - Installing webmozart/assert (1.10.0): Loading from cache
  - Installing phpdocumentor/type-resolver (1.5.1): Loading from cache
  - Installing phpdocumentor/reflection-docblock (5.3.0): Loading from cache
  - Installing felixfbecker/advanced-json-rpc (v3.2.1): Loading from cache
  - Installing composer/xdebug-handler (1.4.6): Loading from cache
  - Installing composer/semver (1.5.0): Loading from cache
  - Installing phan/phan (2.6.1): Loading from cache
  - Installing mediawiki/phan-taint-check-plugin (3.0.2): Loading from cache
  - Installing mediawiki/mediawiki-phan-config (0.10.2): Loading from cache
  - Installing mediawiki/minus-x (1.1.0): Loading from cache
  - Installing php-parallel-lint/php-console-color (v0.3): Loading from cache
  - Installing php-parallel-lint/php-console-highlighter (v0.5): Loading from cache
  - Installing php-parallel-lint/php-parallel-lint (v1.2.0): Loading from cache
  - Installing squizlabs/php_codesniffer (3.5.3): Loading from cache
  - Installing composer/spdx-licenses (1.5.2): Loading from cache
  - Installing mediawiki/mediawiki-codesniffer (v29.0.0): Loading from cache
  - Installing wikibase/wikibase-codesniffer (1.1.0): Loading from cache
  - Installing serialization/serialization (4.0.0): Loading from cache
  - Installing data-values/data-values (3.0.0): Loading from cache
  - Installing data-values/serialization (1.2.4): Loading from cache
  - Installing wikimedia/assert (v0.5.0): Loading from cache
  - Installing wikibase/data-model (9.6.1): Loading from cache
  - Installing wikibase/data-model-serialization (2.9.1): Loading from cache
  - Installing diff/diff (3.2.0): Loading from cache
  - Installing wikibase/data-model-services (5.4.0): Loading from cache
  - Installing wmde/php-vuejs-templating (1.0.3): Cloning f0c35ef087 from cache
  - Installing davidrjonas/composer-lock-diff (1.6.1): Loading from cache
  - Installing hamcrest/hamcrest-php (v2.0.1): Loading from cache
giorgiosironi/eris suggests installing phpunit/phpunit (Standard way to run generated test cases)
patchwork/utf8 suggests installing ext-wfio (Use WFIO for UTF-8 filesystem access on Windows)
doctrine/cache suggests installing alcaeus/mongo-php-adapter (Required to use legacy MongoDB driver)
symfony/service-contracts suggests installing symfony/service-implementation
symfony/console suggests installing symfony/event-dispatcher
symfony/console suggests installing symfony/lock
symfony/console suggests installing symfony/process
phan/phan suggests installing ext-ast (Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is needed, 1.0.6+ is recommended.)
wikibase/data-model-serialization suggests installing data-values/geo (Needed for deserialization of geographical values)
wikibase/data-model-serialization suggests installing data-values/number (Needed for deserialization of numerical values)
wikibase/data-model-serialization suggests installing data-values/time (Needed for deserialization of time values)
Package patchwork/utf8 is abandoned, you should avoid using it. Use symfony/polyfill-mbstring or symfony/string instead.
Package doctrine/reflection is abandoned, you should avoid using it. Use roave/better-reflection instead.
Package wikibase/wikibase-codesniffer is abandoned, you should avoid using it. Use mediawiki/mediawiki-codesniffer instead.
Writing lock file
Generating autoload files
19 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

$ npm install
npm WARN deprecated grunt-jasmine-nodejs@1.6.1: Deprecated in favor of npm scripts.
npm WARN deprecated left-pad@1.3.0: use String.prototype.padStart()
npm WARN deprecated request-promise-native@1.0.9: request-promise-native has been deprecated because it extends the now deprecated request package, see https://github.com/request/request/issues/3142
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated core-js@2.6.12: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.

> fibers@4.0.3 install /src/repo/node_modules/fibers
> node build.js || nodejs build.js

`linux-x64-64-glibc` exists; testing
Binary is fine; exiting

> core-js@2.6.12 postinstall /src/repo/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library!

The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 
> https://opencollective.com/core-js 
> https://www.patreon.com/zloirock 

Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -)

npm notice created a lockfile as package-lock.json. You should commit this file.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@~2.3.2 (node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN wdio-wikibase@4.0.1 requires a peer of mwbot@^1.0.10 but none is installed. You must install peer dependencies yourself.
npm WARN eslint-plugin-vue@6.2.2 requires a peer of eslint@^5.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.

added 914 packages from 1164 contributors and audited 917 packages in 2046.407s

100 packages are looking for funding
  run `npm fund` for details

found 7 vulnerabilities (3 moderate, 4 high)
  run `npm audit fix` to fix them, or `npm audit` for details

$ package-lock-lint package-lock.json
Checking package-lock.json

Attempting to npm audit fix
$ npm audit fix --only=dev
npm WARN notsup Unsupported engine for stylelint-no-unsupported-browser-features@5.0.1: wanted: {"node":">=12"} (current: {"node":"10.24.0","npm":"6.14.5"})
npm WARN notsup Not compatible with your version of node/npm: stylelint-no-unsupported-browser-features@5.0.1
npm WARN eslint-plugin-vue@6.2.2 requires a peer of eslint@^5.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN wdio-wikibase@4.0.1 requires a peer of mwbot@^1.0.10 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.3.2 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

+ stylelint-config-wikimedia@0.11.1
added 48 packages from 59 contributors, removed 30 packages and updated 8 packages in 195.548s

64 packages are looking for funding
  run `npm fund` for details

fixed 1 of 7 vulnerabilities in 917 scanned packages
  3 package updates for 6 vulnerabilities involved breaking changes
  (use `npm audit fix --force` to install breaking changes; or refer to `npm audit` for steps to fix these manually)

$ npm audit fix --only=dev
npm WARN eslint-plugin-vue@6.2.2 requires a peer of eslint@^5.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN wdio-wikibase@4.0.1 requires a peer of mwbot@^1.0.10 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.3.2 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

up to date in 4.463s

105 packages are looking for funding
  run `npm fund` for details

fixed 0 of 6 vulnerabilities in 935 scanned packages
  3 package updates for 6 vulnerabilities involved breaking changes
  (use `npm audit fix --force` to install breaking changes; or refer to `npm audit` for steps to fix these manually)

$ npm audit fix --only=dev
npm WARN eslint-plugin-vue@6.2.2 requires a peer of eslint@^5.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN wdio-wikibase@4.0.1 requires a peer of mwbot@^1.0.10 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.3.2 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

up to date in 11.614s

105 packages are looking for funding
  run `npm fund` for details

fixed 0 of 6 vulnerabilities in 935 scanned packages
  3 package updates for 6 vulnerabilities involved breaking changes
  (use `npm audit fix --force` to install breaking changes; or refer to `npm audit` for steps to fix these manually)

$ package-lock-lint package-lock.json
Checking package-lock.json

Verifying that tests still pass
$ npm ci
npm WARN prepare removing existing node_modules/ before installation

> core-js@2.6.12 postinstall /src/repo/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library!

The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 
> https://opencollective.com/core-js 
> https://www.patreon.com/zloirock 

Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -)


> fibers@4.0.3 install /src/repo/node_modules/fibers
> node build.js || nodejs build.js

`linux-x64-64-glibc` exists; testing
Binary is fine; exiting
added 933 packages in 13.866s

$ npm test

> @ test /src/repo
> grunt test

Running "eslint:all" (eslint) task
Warning: Failed to load plugin 'compat' declared in '.eslintrc.json': Cannot find module 'eslint-plugin-compat'
Require stack:
- /src/repo/__placeholder__.js Use --force to continue.

Aborted due to warnings.
npm ERR! Test failed.  See above for more details.

Traceback (most recent call last):
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/__init__.py", line 1374, in main
    libup.run(args.repo, args.output, args.branch)
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/__init__.py", line 1318, in run
    self.npm_audit_fix(new_npm_audit)
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/__init__.py", line 216, in npm_audit_fix
    self.check_call(['npm', 'test'])
  File "/venv/lib/python3.7/site-packages/runner-0.1.0-py3.7.egg/runner/shell2.py", line 40, in check_call
    res.check_returncode()
  File "/usr/lib/python3.7/subprocess.py", line 428, in check_returncode
    self.stderr)
subprocess.CalledProcessError: Command '['npm', 'test']' returned non-zero exit status 1.

composer dependencies

Dependencies
Development dependencies

npm dependencies

Development dependencies

Logs

Source code is licensed under the AGPL.