mediawiki/extensions/WSOAuth (master)

sourcepatches
From c00eba2dacffe756deb47f1f1b6585f93fb21209 Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Thu, 4 Mar 2021 08:30:17 +0000
Subject: [PATCH] build: Updating mediawiki/minus-x to 1.1.1

Change-Id: I9af2f67953060081a55a7607c7893bb00336524d
---
 composer.json | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/composer.json b/composer.json
index a331df8..188c594 100644
--- a/composer.json
+++ b/composer.json
@@ -4,7 +4,7 @@
 		"league/oauth2-facebook": "^2.0"
 	},
 	"require-dev": {
-		"mediawiki/minus-x": "1.1.0",
+		"mediawiki/minus-x": "1.1.1",
 		"php-parallel-lint/php-console-highlighter": "0.5.0",
 		"php-parallel-lint/php-parallel-lint": "1.2.0"
 	},
-- 
2.20.1

$ date
Thu Mar  4 08:29:55 UTC 2021

$ git clone file:///srv/git/mediawiki-extensions-WSOAuth.git repo --depth=1 -b master
Cloning into 'repo'...

$ git config user.name libraryupgrader

$ git config user.email tools.libraryupgrader@tools.wmflabs.org

$ git submodule update --init

$ grr init
Installed commit-msg hook.

$ git show-ref refs/heads/master
facf7a7f79efc53fa7b0a6716380d83ab08e638e refs/heads/master

$ composer install
Loading composer repositories with package information
Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2
Updating dependencies (including require-dev)
Package operations: 25 installs, 0 updates, 0 removals
  - Installing symfony/polyfill-php80 (v1.22.1): Loading from cache
  - Installing symfony/polyfill-mbstring (v1.22.1): Loading from cache
  - Installing symfony/polyfill-intl-normalizer (v1.22.1): Loading from cache
  - Installing symfony/polyfill-intl-grapheme (v1.22.1): Loading from cache
  - Installing symfony/polyfill-ctype (v1.22.1): Loading from cache
  - Installing symfony/string (v5.2.3): Loading from cache
  - Installing psr/container (1.0.0): Loading from cache
  - Installing symfony/service-contracts (v2.2.0): Loading from cache
  - Installing symfony/polyfill-php73 (v1.22.1): Loading from cache
  - Installing symfony/console (v5.2.3): Loading from cache
  - Installing mediawiki/minus-x (1.1.0): Loading from cache
  - Installing php-parallel-lint/php-console-color (v0.3): Loading from cache
  - Installing php-parallel-lint/php-console-highlighter (v0.5): Loading from cache
  - Installing php-parallel-lint/php-parallel-lint (v1.2.0): Loading from cache
  - Installing psr/log (1.1.3): Loading from cache
  - Installing mediawiki/oauthclient (1.1.0): Loading from cache
  - Installing paragonie/random_compat (v9.99.100): Loading from cache
  - Installing psr/http-message (1.0.1): Loading from cache
  - Installing psr/http-client (1.0.1): Loading from cache
  - Installing ralouphie/getallheaders (3.0.3): Loading from cache
  - Installing guzzlehttp/psr7 (1.7.0): Loading from cache
  - Installing guzzlehttp/promises (1.4.0): Loading from cache
  - Installing guzzlehttp/guzzle (7.2.0): Loading from cache
  - Installing league/oauth2-client (2.6.0): Downloading (connecting...)Downloading (0%)           Downloading (15%)Downloading (40%)Downloading (55%)Downloading (70%)Downloading (85%)Downloading (100%)
  - Installing league/oauth2-facebook (2.0.5): Downloading (connecting...)Downloading (0%)           Downloading (20%)Downloading (40%)Downloading (100%)
symfony/service-contracts suggests installing symfony/service-implementation
symfony/console suggests installing symfony/event-dispatcher
symfony/console suggests installing symfony/lock
symfony/console suggests installing symfony/process
paragonie/random_compat suggests installing ext-libsodium (Provides a modern crypto API that can be used to generate random bytes.)
guzzlehttp/psr7 suggests installing laminas/laminas-httphandlerrunner (Emit PSR-7 responses)
Writing lock file
Generating autoload files
10 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

Upgrading c:mediawiki/minus-x from 1.1.0 -> 1.1.1
$ composer update
Loading composer repositories with package information
Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2
Updating dependencies (including require-dev)
Package operations: 0 installs, 1 update, 0 removals
  - Updating mediawiki/minus-x (1.1.0 => 1.1.1): Loading from cache
Writing lock file
Generating autoload files
10 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

$ composer install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Nothing to install or update
Generating autoload files
10 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

$ composer test
> parallel-lint . --exclude vendor --exclude node_modules
PHP 7.3.19 | 10 parallel jobs
........                                                     8/8 (100 %)


Checked 8 files in 0 seconds
No syntax error found
> minus-x check .
MinusX
======
Processing /src/repo...
...........................................
All good!

$ git add .

$ git commit -F /tmp/tmpoq5jhmqt
[master c00eba2] build: Updating mediawiki/minus-x to 1.1.1
 1 file changed, 1 insertion(+), 1 deletion(-)

$ git format-patch HEAD~1 --stdout
From c00eba2dacffe756deb47f1f1b6585f93fb21209 Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Thu, 4 Mar 2021 08:30:17 +0000
Subject: [PATCH] build: Updating mediawiki/minus-x to 1.1.1

Change-Id: I9af2f67953060081a55a7607c7893bb00336524d
---
 composer.json | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/composer.json b/composer.json
index a331df8..188c594 100644
--- a/composer.json
+++ b/composer.json
@@ -4,7 +4,7 @@
 		"league/oauth2-facebook": "^2.0"
 	},
 	"require-dev": {
-		"mediawiki/minus-x": "1.1.0",
+		"mediawiki/minus-x": "1.1.1",
 		"php-parallel-lint/php-console-highlighter": "0.5.0",
 		"php-parallel-lint/php-parallel-lint": "1.2.0"
 	},
-- 
2.20.1

composer dependencies

Dependencies
Development dependencies

npm dependencies

Development dependencies

Logs

Source code is licensed under the AGPL.