mediawiki/extensions/FundraisingEmailUnsubscribe (REL1_38)

sourcepatches
$ date
--- stdout ---
Mon Jan 30 01:23:04 UTC 2023

--- end ---
$ git clone file:///srv/git/mediawiki-extensions-FundraisingEmailUnsubscribe.git repo --depth=1 -b REL1_38
--- stderr ---
Cloning into 'repo'...
--- stdout ---

--- end ---
$ git config user.name libraryupgrader
--- stdout ---

--- end ---
$ git config user.email tools.libraryupgrader@tools.wmflabs.org
--- stdout ---

--- end ---
$ git submodule update --init
--- stdout ---

--- end ---
$ grr init
--- stdout ---
Installed commit-msg hook.

--- end ---
$ git show-ref refs/heads/REL1_38
--- stdout ---
6720c4ca8b017e2e97df87bcfa36ee10049ca3cc refs/heads/REL1_38

--- end ---
$ /usr/bin/npm audit --json --legacy-peer-deps
--- stdout ---
{
  "auditReportVersion": 2,
  "vulnerabilities": {
    "grunt-contrib-jshint": {
      "name": "grunt-contrib-jshint",
      "severity": "high",
      "isDirect": true,
      "via": [
        "jshint"
      ],
      "effects": [],
      "range": "0.3.0 - 3.0.0",
      "nodes": [
        "node_modules/grunt-contrib-jshint"
      ],
      "fixAvailable": {
        "name": "grunt-contrib-jshint",
        "version": "3.2.0",
        "isSemVerMajor": true
      }
    },
    "jshint": {
      "name": "jshint",
      "severity": "high",
      "isDirect": false,
      "via": [
        "shelljs"
      ],
      "effects": [
        "grunt-contrib-jshint"
      ],
      "range": "1.1.0 - 2.13.3",
      "nodes": [
        "node_modules/jshint"
      ],
      "fixAvailable": {
        "name": "grunt-contrib-jshint",
        "version": "3.2.0",
        "isSemVerMajor": true
      }
    },
    "nomnom": {
      "name": "nomnom",
      "severity": "critical",
      "isDirect": false,
      "via": [
        "underscore"
      ],
      "effects": [],
      "range": ">=1.6.0",
      "nodes": [
        "node_modules/nomnom"
      ],
      "fixAvailable": true
    },
    "shelljs": {
      "name": "shelljs",
      "severity": "high",
      "isDirect": false,
      "via": [
        {
          "source": 1088205,
          "name": "shelljs",
          "dependency": "shelljs",
          "title": "Improper Privilege Management in shelljs",
          "url": "https://github.com/advisories/GHSA-4rq4-32rv-6wp6",
          "severity": "high",
          "cwe": [
            "CWE-269"
          ],
          "cvss": {
            "score": 7.1,
            "vectorString": "CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H"
          },
          "range": "<0.8.5"
        },
        {
          "source": 1088208,
          "name": "shelljs",
          "dependency": "shelljs",
          "title": "Improper Privilege Management in shelljs",
          "url": "https://github.com/advisories/GHSA-64g7-mvw6-v9qj",
          "severity": "moderate",
          "cwe": [
            "CWE-269"
          ],
          "cvss": {
            "score": 0,
            "vectorString": null
          },
          "range": "<0.8.5"
        }
      ],
      "effects": [
        "jshint"
      ],
      "range": "<=0.8.4",
      "nodes": [
        "node_modules/shelljs"
      ],
      "fixAvailable": {
        "name": "grunt-contrib-jshint",
        "version": "3.2.0",
        "isSemVerMajor": true
      }
    },
    "underscore": {
      "name": "underscore",
      "severity": "critical",
      "isDirect": false,
      "via": [
        {
          "source": 1089143,
          "name": "underscore",
          "dependency": "underscore",
          "title": "Arbitrary Code Execution in underscore",
          "url": "https://github.com/advisories/GHSA-cf4h-3jhx-xvhq",
          "severity": "critical",
          "cwe": [
            "CWE-94"
          ],
          "cvss": {
            "score": 9.8,
            "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
          },
          "range": ">=1.3.2 <1.12.1"
        }
      ],
      "effects": [
        "nomnom"
      ],
      "range": "1.3.2 - 1.12.0",
      "nodes": [
        "node_modules/underscore"
      ],
      "fixAvailable": true
    }
  },
  "metadata": {
    "vulnerabilities": {
      "info": 0,
      "low": 0,
      "moderate": 0,
      "high": 3,
      "critical": 2,
      "total": 5
    },
    "dependencies": {
      "prod": 1,
      "dev": 412,
      "optional": 0,
      "peer": 0,
      "peerOptional": 0,
      "total": 412
    }
  }
}

--- end ---
$ /usr/bin/composer install
--- stderr ---
No lock file found. Updating dependencies instead of installing from lock file. Use composer update over composer install if you do not have a lock file.
Loading composer repositories with package information
Info from https://repo.packagist.org: #StandWithUkraine
Updating dependencies
Lock file operations: 25 installs, 0 updates, 0 removals
  - Locking clio/clio (0.1.8)
  - Locking coderkungfu/php-queue (1.0.1)
  - Locking composer/semver (3.3.2)
  - Locking composer/spdx-licenses (1.5.7)
  - Locking mediawiki/mediawiki-codesniffer (v38.0.0)
  - Locking mediawiki/minus-x (1.1.1)
  - Locking monolog/monolog (2.8.0)
  - Locking php-parallel-lint/php-console-color (v0.3)
  - Locking php-parallel-lint/php-console-highlighter (v0.5)
  - Locking php-parallel-lint/php-parallel-lint (v1.3.1)
  - Locking predis/predis (v1.1.10)
  - Locking psr/container (1.1.2)
  - Locking psr/log (1.1.4)
  - Locking squizlabs/php_codesniffer (3.6.1)
  - Locking symfony/console (v5.4.19)
  - Locking symfony/deprecation-contracts (v2.5.2)
  - Locking symfony/polyfill-ctype (v1.27.0)
  - Locking symfony/polyfill-intl-grapheme (v1.27.0)
  - Locking symfony/polyfill-intl-normalizer (v1.27.0)
  - Locking symfony/polyfill-mbstring (v1.27.0)
  - Locking symfony/polyfill-php73 (v1.27.0)
  - Locking symfony/polyfill-php80 (v1.27.0)
  - Locking symfony/service-contracts (v2.5.2)
  - Locking symfony/string (v5.4.19)
  - Locking twig/twig (v1.44.5)
Writing lock file
Installing dependencies from lock file (including require-dev)
Package operations: 25 installs, 0 updates, 0 removals
    0 [>---------------------------]    0 [->--------------------------]    0 [--->------------------------]  - Installing psr/log (1.1.4): Extracting archive
  - Installing monolog/monolog (2.8.0): Extracting archive
  - Installing clio/clio (0.1.8): Extracting archive
  - Installing coderkungfu/php-queue (1.0.1): Extracting archive
  - Installing squizlabs/php_codesniffer (3.6.1): Extracting archive
  - Installing symfony/polyfill-mbstring (v1.27.0): Extracting archive
  - Installing composer/spdx-licenses (1.5.7): Extracting archive
  - Installing composer/semver (3.3.2): Extracting archive
  - Installing mediawiki/mediawiki-codesniffer (v38.0.0): Extracting archive
  - Installing symfony/polyfill-php80 (v1.27.0): Extracting archive
  - Installing symfony/polyfill-intl-normalizer (v1.27.0): Extracting archive
  - Installing symfony/polyfill-intl-grapheme (v1.27.0): Extracting archive
  - Installing symfony/polyfill-ctype (v1.27.0): Extracting archive
  - Installing symfony/string (v5.4.19): Extracting archive
  - Installing symfony/deprecation-contracts (v2.5.2): Extracting archive
  - Installing psr/container (1.1.2): Extracting archive
  - Installing symfony/service-contracts (v2.5.2): Extracting archive
  - Installing symfony/polyfill-php73 (v1.27.0): Extracting archive
  - Installing symfony/console (v5.4.19): Extracting archive
  - Installing mediawiki/minus-x (1.1.1): Extracting archive
  - Installing php-parallel-lint/php-console-color (v0.3): Extracting archive
  - Installing php-parallel-lint/php-console-highlighter (v0.5): Extracting archive
  - Installing php-parallel-lint/php-parallel-lint (v1.3.1): Extracting archive
  - Installing predis/predis (v1.1.10): Extracting archive
  - Installing twig/twig (v1.44.5): Extracting archive
  0/16 [>---------------------------]   0%
  9/16 [===============>------------]  56%
 16/16 [============================] 100%23 package suggestions were added by new dependencies, use `composer suggest` to see details.
Generating autoload files
15 packages you are using are looking for funding.
Use the `composer fund` command to find out more!
--- stdout ---

--- end ---
$ /usr/bin/npm audit --json --legacy-peer-deps
--- stdout ---
{
  "auditReportVersion": 2,
  "vulnerabilities": {
    "grunt-contrib-jshint": {
      "name": "grunt-contrib-jshint",
      "severity": "high",
      "isDirect": true,
      "via": [
        "jshint"
      ],
      "effects": [],
      "range": "0.3.0 - 3.0.0",
      "nodes": [
        "node_modules/grunt-contrib-jshint"
      ],
      "fixAvailable": {
        "name": "grunt-contrib-jshint",
        "version": "3.2.0",
        "isSemVerMajor": true
      }
    },
    "jshint": {
      "name": "jshint",
      "severity": "high",
      "isDirect": false,
      "via": [
        "shelljs"
      ],
      "effects": [
        "grunt-contrib-jshint"
      ],
      "range": "1.1.0 - 2.13.3",
      "nodes": [
        "node_modules/jshint"
      ],
      "fixAvailable": {
        "name": "grunt-contrib-jshint",
        "version": "3.2.0",
        "isSemVerMajor": true
      }
    },
    "nomnom": {
      "name": "nomnom",
      "severity": "critical",
      "isDirect": false,
      "via": [
        "underscore"
      ],
      "effects": [],
      "range": ">=1.6.0",
      "nodes": [
        "node_modules/nomnom"
      ],
      "fixAvailable": true
    },
    "shelljs": {
      "name": "shelljs",
      "severity": "high",
      "isDirect": false,
      "via": [
        {
          "source": 1088205,
          "name": "shelljs",
          "dependency": "shelljs",
          "title": "Improper Privilege Management in shelljs",
          "url": "https://github.com/advisories/GHSA-4rq4-32rv-6wp6",
          "severity": "high",
          "cwe": [
            "CWE-269"
          ],
          "cvss": {
            "score": 7.1,
            "vectorString": "CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H"
          },
          "range": "<0.8.5"
        },
        {
          "source": 1088208,
          "name": "shelljs",
          "dependency": "shelljs",
          "title": "Improper Privilege Management in shelljs",
          "url": "https://github.com/advisories/GHSA-64g7-mvw6-v9qj",
          "severity": "moderate",
          "cwe": [
            "CWE-269"
          ],
          "cvss": {
            "score": 0,
            "vectorString": null
          },
          "range": "<0.8.5"
        }
      ],
      "effects": [
        "jshint"
      ],
      "range": "<=0.8.4",
      "nodes": [
        "node_modules/shelljs"
      ],
      "fixAvailable": {
        "name": "grunt-contrib-jshint",
        "version": "3.2.0",
        "isSemVerMajor": true
      }
    },
    "underscore": {
      "name": "underscore",
      "severity": "critical",
      "isDirect": false,
      "via": [
        {
          "source": 1089143,
          "name": "underscore",
          "dependency": "underscore",
          "title": "Arbitrary Code Execution in underscore",
          "url": "https://github.com/advisories/GHSA-cf4h-3jhx-xvhq",
          "severity": "critical",
          "cwe": [
            "CWE-94"
          ],
          "cvss": {
            "score": 9.8,
            "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
          },
          "range": ">=1.3.2 <1.12.1"
        }
      ],
      "effects": [
        "nomnom"
      ],
      "range": "1.3.2 - 1.12.0",
      "nodes": [
        "node_modules/underscore"
      ],
      "fixAvailable": true
    }
  },
  "metadata": {
    "vulnerabilities": {
      "info": 0,
      "low": 0,
      "moderate": 0,
      "high": 3,
      "critical": 2,
      "total": 5
    },
    "dependencies": {
      "prod": 1,
      "dev": 412,
      "optional": 0,
      "peer": 0,
      "peerOptional": 0,
      "total": 412
    }
  }
}

--- end ---
Attempting to npm audit fix
$ /usr/bin/npm audit fix --dry-run --only=dev --json --legacy-peer-deps
--- stderr ---
npm WARN invalid config only="dev" set in command line options
npm WARN invalid config Must be one of: null, prod, production
--- stdout ---
{
  "added": 412,
  "removed": 0,
  "changed": 0,
  "audited": 413,
  "funding": 4,
  "audit": {
    "auditReportVersion": 2,
    "vulnerabilities": {
      "grunt-contrib-jshint": {
        "name": "grunt-contrib-jshint",
        "severity": "high",
        "isDirect": true,
        "via": [
          "jshint"
        ],
        "effects": [],
        "range": "0.3.0 - 3.0.0",
        "nodes": [
          "node_modules/grunt-contrib-jshint"
        ],
        "fixAvailable": {
          "name": "grunt-contrib-jshint",
          "version": "3.2.0",
          "isSemVerMajor": true
        }
      },
      "jshint": {
        "name": "jshint",
        "severity": "high",
        "isDirect": false,
        "via": [
          "shelljs"
        ],
        "effects": [
          "grunt-contrib-jshint"
        ],
        "range": "1.1.0 - 2.13.3",
        "nodes": [
          "node_modules/jshint"
        ],
        "fixAvailable": {
          "name": "grunt-contrib-jshint",
          "version": "3.2.0",
          "isSemVerMajor": true
        }
      },
      "nomnom": {
        "name": "nomnom",
        "severity": "critical",
        "isDirect": false,
        "via": [
          "underscore"
        ],
        "effects": [],
        "range": ">=1.6.0",
        "nodes": [
          "node_modules/nomnom"
        ],
        "fixAvailable": true
      },
      "shelljs": {
        "name": "shelljs",
        "severity": "high",
        "isDirect": false,
        "via": [
          {
            "source": 1088205,
            "name": "shelljs",
            "dependency": "shelljs",
            "title": "Improper Privilege Management in shelljs",
            "url": "https://github.com/advisories/GHSA-4rq4-32rv-6wp6",
            "severity": "high",
            "cwe": [
              "CWE-269"
            ],
            "cvss": {
              "score": 7.1,
              "vectorString": "CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H"
            },
            "range": "<0.8.5"
          },
          {
            "source": 1088208,
            "name": "shelljs",
            "dependency": "shelljs",
            "title": "Improper Privilege Management in shelljs",
            "url": "https://github.com/advisories/GHSA-64g7-mvw6-v9qj",
            "severity": "moderate",
            "cwe": [
              "CWE-269"
            ],
            "cvss": {
              "score": 0,
              "vectorString": null
            },
            "range": "<0.8.5"
          }
        ],
        "effects": [
          "jshint"
        ],
        "range": "<=0.8.4",
        "nodes": [
          "node_modules/shelljs"
        ],
        "fixAvailable": {
          "name": "grunt-contrib-jshint",
          "version": "3.2.0",
          "isSemVerMajor": true
        }
      },
      "underscore": {
        "name": "underscore",
        "severity": "critical",
        "isDirect": false,
        "via": [
          {
            "source": 1089143,
            "name": "underscore",
            "dependency": "underscore",
            "title": "Arbitrary Code Execution in underscore",
            "url": "https://github.com/advisories/GHSA-cf4h-3jhx-xvhq",
            "severity": "critical",
            "cwe": [
              "CWE-94"
            ],
            "cvss": {
              "score": 9.8,
              "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
            },
            "range": ">=1.3.2 <1.12.1"
          }
        ],
        "effects": [
          "nomnom"
        ],
        "range": "1.3.2 - 1.12.0",
        "nodes": [
          "node_modules/underscore"
        ],
        "fixAvailable": true
      }
    },
    "metadata": {
      "vulnerabilities": {
        "info": 0,
        "low": 0,
        "moderate": 0,
        "high": 3,
        "critical": 2,
        "total": 5
      },
      "dependencies": {
        "prod": 1,
        "dev": 412,
        "optional": 0,
        "peer": 0,
        "peerOptional": 0,
        "total": 412
      }
    }
  }
}

--- end ---
{"added": 412, "removed": 0, "changed": 0, "audited": 413, "funding": 4, "audit": {"auditReportVersion": 2, "vulnerabilities": {"grunt-contrib-jshint": {"name": "grunt-contrib-jshint", "severity": "high", "isDirect": true, "via": ["jshint"], "effects": [], "range": "0.3.0 - 3.0.0", "nodes": ["node_modules/grunt-contrib-jshint"], "fixAvailable": {"name": "grunt-contrib-jshint", "version": "3.2.0", "isSemVerMajor": true}}, "jshint": {"name": "jshint", "severity": "high", "isDirect": false, "via": ["shelljs"], "effects": ["grunt-contrib-jshint"], "range": "1.1.0 - 2.13.3", "nodes": ["node_modules/jshint"], "fixAvailable": {"name": "grunt-contrib-jshint", "version": "3.2.0", "isSemVerMajor": true}}, "nomnom": {"name": "nomnom", "severity": "critical", "isDirect": false, "via": ["underscore"], "effects": [], "range": ">=1.6.0", "nodes": ["node_modules/nomnom"], "fixAvailable": true}, "shelljs": {"name": "shelljs", "severity": "high", "isDirect": false, "via": [{"source": 1088205, "name": "shelljs", "dependency": "shelljs", "title": "Improper Privilege Management in shelljs", "url": "https://github.com/advisories/GHSA-4rq4-32rv-6wp6", "severity": "high", "cwe": ["CWE-269"], "cvss": {"score": 7.1, "vectorString": "CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H"}, "range": "<0.8.5"}, {"source": 1088208, "name": "shelljs", "dependency": "shelljs", "title": "Improper Privilege Management in shelljs", "url": "https://github.com/advisories/GHSA-64g7-mvw6-v9qj", "severity": "moderate", "cwe": ["CWE-269"], "cvss": {"score": 0, "vectorString": null}, "range": "<0.8.5"}], "effects": ["jshint"], "range": "<=0.8.4", "nodes": ["node_modules/shelljs"], "fixAvailable": {"name": "grunt-contrib-jshint", "version": "3.2.0", "isSemVerMajor": true}}, "underscore": {"name": "underscore", "severity": "critical", "isDirect": false, "via": [{"source": 1089143, "name": "underscore", "dependency": "underscore", "title": "Arbitrary Code Execution in underscore", "url": "https://github.com/advisories/GHSA-cf4h-3jhx-xvhq", "severity": "critical", "cwe": ["CWE-94"], "cvss": {"score": 9.8, "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"}, "range": ">=1.3.2 <1.12.1"}], "effects": ["nomnom"], "range": "1.3.2 - 1.12.0", "nodes": ["node_modules/underscore"], "fixAvailable": true}}, "metadata": {"vulnerabilities": {"info": 0, "low": 0, "moderate": 0, "high": 3, "critical": 2, "total": 5}, "dependencies": {"prod": 1, "dev": 412, "optional": 0, "peer": 0, "peerOptional": 0, "total": 412}}}}
$ /usr/bin/npm audit fix --only=dev --legacy-peer-deps
--- stderr ---
npm WARN invalid config only="dev" set in command line options
npm WARN invalid config Must be one of: null, prod, production
--- stdout ---

added 412 packages, and audited 413 packages in 4s

4 packages are looking for funding
  run `npm fund` for details

# npm audit report

shelljs  <=0.8.4
Severity: high
Improper Privilege Management in shelljs - https://github.com/advisories/GHSA-4rq4-32rv-6wp6
Improper Privilege Management in shelljs - https://github.com/advisories/GHSA-64g7-mvw6-v9qj
fix available via `npm audit fix --force`
Will install grunt-contrib-jshint@3.2.0, which is a breaking change
node_modules/shelljs
  jshint  1.1.0 - 2.13.3
  Depends on vulnerable versions of shelljs
  node_modules/jshint
    grunt-contrib-jshint  0.3.0 - 3.0.0
    Depends on vulnerable versions of jshint
    node_modules/grunt-contrib-jshint

underscore  1.3.2 - 1.12.0
Severity: critical
Arbitrary Code Execution in underscore - https://github.com/advisories/GHSA-cf4h-3jhx-xvhq
fix available via `npm audit fix`
node_modules/underscore
  nomnom  >=1.6.0
  Depends on vulnerable versions of underscore
  node_modules/nomnom

5 vulnerabilities (3 high, 2 critical)

To address issues that do not require attention, run:
  npm audit fix

To address all issues (including breaking changes), run:
  npm audit fix --force

--- end ---
$ package-lock-lint package-lock.json
--- stdout ---
Checking package-lock.json

--- end ---
Verifying that tests still pass
$ /usr/bin/npm ci --legacy-peer-deps
--- stdout ---

added 412 packages, and audited 413 packages in 3s

4 packages are looking for funding
  run `npm fund` for details

5 vulnerabilities (3 high, 2 critical)

To address issues that do not require attention, run:
  npm audit fix

To address all issues (including breaking changes), run:
  npm audit fix --force

Run `npm audit` for details.

--- end ---
$ /usr/bin/npm test
--- stdout ---

> test
> grunt test

Running "jsonlint:all" (jsonlint) task
>> 79 files lint free.

Running "stylelint:all" (stylelint) task
>> Linted 1 files without errors

Running "banana:FundraisingEmailUnsubscribe" (banana) task
>> 1 message directory checked.

Running "jshint:all" (jshint) task
>> 2 files lint free.

Done.

--- end ---
{"1089143": {"source": 1089143, "name": "underscore", "dependency": "underscore", "title": "Arbitrary Code Execution in underscore", "url": "https://github.com/advisories/GHSA-cf4h-3jhx-xvhq", "severity": "critical", "cwe": ["CWE-94"], "cvss": {"score": 9.8, "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"}, "range": ">=1.3.2 <1.12.1"}}
{"1089143": {"source": 1089143, "name": "underscore", "dependency": "underscore", "title": "Arbitrary Code Execution in underscore", "url": "https://github.com/advisories/GHSA-cf4h-3jhx-xvhq", "severity": "critical", "cwe": ["CWE-94"], "cvss": {"score": 9.8, "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"}, "range": ">=1.3.2 <1.12.1"}}
$ package-lock-lint package-lock.json
--- stdout ---
Checking package-lock.json

--- end ---
[DNM] there are no updates
$ git add .
--- stdout ---

--- end ---
$ git commit -F /tmp/tmpkjz1s42v
--- stdout ---
On branch REL1_38
Your branch is up to date with 'origin/REL1_38'.

nothing to commit, working tree clean

--- end ---

composer dependencies

Dependencies
Development dependencies

npm dependencies

Development dependencies

Logs

Source code is licensed under the AGPL.