mediawiki/extensions/FundraisingEmailUnsubscribe (REL1_35)

sourcepatches
From bafa921d73ae0984f3e10831ee26627b4cc4820a Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Sun, 22 May 2022 18:01:59 +0000
Subject: [PATCH] build: Updating npm dependencies
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* grunt: 1.4.0 → 1.5.3
* nomnom: 1.8.1 → 1.8.1
  * https://github.com/advisories/GHSA-cf4h-3jhx-xvhq
* underscore: 1.6.0 → 1.6.0
  * https://github.com/advisories/GHSA-cf4h-3jhx-xvhq

Change-Id: I4c4d81e3dace4926794f42dd791fc6e12a237e92
---
 package-lock.json | 263 ++++++++++++++++++++++------------------------
 package.json      |   2 +-
 2 files changed, 128 insertions(+), 137 deletions(-)

diff --git a/package-lock.json b/package-lock.json
index 13a844e..33744c9 100644
--- a/package-lock.json
+++ b/package-lock.json
@@ -6,7 +6,7 @@
 		"": {
 			"name": "FundraisingEmailUnsubscribe",
 			"devDependencies": {
-				"grunt": "1.4.0",
+				"grunt": "1.5.3",
 				"grunt-banana-checker": "0.9.0",
 				"grunt-contrib-jshint": "1.1.0",
 				"grunt-jsonlint": "1.0.7",
@@ -433,7 +433,7 @@
 		"node_modules/array-each": {
 			"version": "1.0.1",
 			"resolved": "https://registry.npmjs.org/array-each/-/array-each-1.0.1.tgz",
-			"integrity": "sha1-p5SvDAWrF1KEbudTofIRoFugxE8=",
+			"integrity": "sha512-zHjL5SZa68hkKHBFBK6DJCTtr9sfTCPCaph/L7tMSLcTFgy+zX7E+6q5UArbtOtMBCtxdICpfTCspRse+ywyXA==",
 			"dev": true,
 			"engines": {
 				"node": ">=0.10.0"
@@ -1494,9 +1494,9 @@
 			}
 		},
 		"node_modules/grunt": {
-			"version": "1.4.0",
-			"resolved": "https://registry.npmjs.org/grunt/-/grunt-1.4.0.tgz",
-			"integrity": "sha512-yRFc0GVCDu9yxqOFzpuXQ2pEdgtLDnFv5Qz54jfIcNnpJ8Z7B7P7kPkT4VMuRvm+N+QOsI8C4v/Q0DSaoj3LgQ==",
+			"version": "1.5.3",
+			"resolved": "https://registry.npmjs.org/grunt/-/grunt-1.5.3.tgz",
+			"integrity": "sha512-mKwmo4X2d8/4c/BmcOETHek675uOqw0RuA/zy12jaspWqvTp4+ZeQF1W+OTpcbncnaBsfbQJ6l0l4j+Sn/GmaQ==",
 			"dev": true,
 			"dependencies": {
 				"dateformat": "~3.0.3",
@@ -1504,8 +1504,8 @@
 				"exit": "~0.1.2",
 				"findup-sync": "~0.3.0",
 				"glob": "~7.1.6",
-				"grunt-cli": "~1.4.2",
-				"grunt-known-options": "~1.1.1",
+				"grunt-cli": "~1.4.3",
+				"grunt-known-options": "~2.0.0",
 				"grunt-legacy-log": "~3.0.0",
 				"grunt-legacy-util": "~2.0.1",
 				"iconv-lite": "~0.4.13",
@@ -1534,6 +1534,38 @@
 				"node": ">=8"
 			}
 		},
+		"node_modules/grunt-cli": {
+			"version": "1.4.3",
+			"resolved": "https://registry.npmjs.org/grunt-cli/-/grunt-cli-1.4.3.tgz",
+			"integrity": "sha512-9Dtx/AhVeB4LYzsViCjUQkd0Kw0McN2gYpdmGYKtE2a5Yt7v1Q+HYZVWhqXc/kGnxlMtqKDxSwotiGeFmkrCoQ==",
+			"dev": true,
+			"dependencies": {
+				"grunt-known-options": "~2.0.0",
+				"interpret": "~1.1.0",
+				"liftup": "~3.0.1",
+				"nopt": "~4.0.1",
+				"v8flags": "~3.2.0"
+			},
+			"bin": {
+				"grunt": "bin/grunt"
+			},
+			"engines": {
+				"node": ">=10"
+			}
+		},
+		"node_modules/grunt-cli/node_modules/nopt": {
+			"version": "4.0.3",
+			"resolved": "https://registry.npmjs.org/nopt/-/nopt-4.0.3.tgz",
+			"integrity": "sha512-CvaGwVMztSMJLOeXPrez7fyfObdZqNUK1cPAEzLHrTybIua9pMdmmPR5YwtfNftIOMv3DPUhFaxsZMNTQO20Kg==",
+			"dev": true,
+			"dependencies": {
+				"abbrev": "1",
+				"osenv": "^0.1.4"
+			},
+			"bin": {
+				"nopt": "bin/nopt.js"
+			}
+		},
 		"node_modules/grunt-contrib-jshint": {
 			"version": "1.1.0",
 			"resolved": "https://registry.npmjs.org/grunt-contrib-jshint/-/grunt-contrib-jshint-1.1.0.tgz",
@@ -1602,9 +1634,9 @@
 			}
 		},
 		"node_modules/grunt-known-options": {
-			"version": "1.1.1",
-			"resolved": "https://registry.npmjs.org/grunt-known-options/-/grunt-known-options-1.1.1.tgz",
-			"integrity": "sha512-cHwsLqoighpu7TuYj5RonnEuxGVFnztcUqTqp5rXFGYL4OuPFofwC4Ycg7n9fYwvK6F5WbYgeVOwph9Crs2fsQ==",
+			"version": "2.0.0",
+			"resolved": "https://registry.npmjs.org/grunt-known-options/-/grunt-known-options-2.0.0.tgz",
+			"integrity": "sha512-GD7cTz0I4SAede1/+pAbmJRG44zFLPipVtdL9o3vqx9IEyb7b4/Y3s7r6ofI3CchR5GvYJ+8buCSioDv5dQLiA==",
 			"dev": true,
 			"engines": {
 				"node": ">=0.10.0"
@@ -1815,38 +1847,6 @@
 				"node": ">=8"
 			}
 		},
-		"node_modules/grunt/node_modules/grunt-cli": {
-			"version": "1.4.2",
-			"resolved": "https://registry.npmjs.org/grunt-cli/-/grunt-cli-1.4.2.tgz",
-			"integrity": "sha512-wsu6BZh7KCnfeaSkDrKIAvOlqGKxNRTZjc8xfZlvxCByQIqUfZ31kh5uHpPnhQ4NdVgvaWaVxa1LUbVU80nACw==",
-			"dev": true,
-			"dependencies": {
-				"grunt-known-options": "~1.1.1",
-				"interpret": "~1.1.0",
-				"liftup": "~3.0.1",
-				"nopt": "~4.0.1",
-				"v8flags": "~3.2.0"
-			},
-			"bin": {
-				"grunt": "bin/grunt"
-			},
-			"engines": {
-				"node": ">=10"
-			}
-		},
-		"node_modules/grunt/node_modules/grunt-cli/node_modules/nopt": {
-			"version": "4.0.3",
-			"resolved": "https://registry.npmjs.org/nopt/-/nopt-4.0.3.tgz",
-			"integrity": "sha512-CvaGwVMztSMJLOeXPrez7fyfObdZqNUK1cPAEzLHrTybIua9pMdmmPR5YwtfNftIOMv3DPUhFaxsZMNTQO20Kg==",
-			"dev": true,
-			"dependencies": {
-				"abbrev": "1",
-				"osenv": "^0.1.4"
-			},
-			"bin": {
-				"nopt": "bin/nopt.js"
-			}
-		},
 		"node_modules/grunt/node_modules/mkdirp": {
 			"version": "1.0.4",
 			"resolved": "https://registry.npmjs.org/mkdirp/-/mkdirp-1.0.4.tgz",
@@ -2120,12 +2120,15 @@
 			}
 		},
 		"node_modules/is-core-module": {
-			"version": "2.4.0",
-			"resolved": "https://registry.npmjs.org/is-core-module/-/is-core-module-2.4.0.tgz",
-			"integrity": "sha512-6A2fkfq1rfeQZjxrZJGerpLCTHRNEBiSgnu0+obeJpEPZRUooHgsizvzv0ZjJwOz3iWIHdJtVWJ/tmPr3D21/A==",
+			"version": "2.9.0",
+			"resolved": "https://registry.npmjs.org/is-core-module/-/is-core-module-2.9.0.tgz",
+			"integrity": "sha512-+5FPy5PnwmO3lvfMb0AsoPaBG+5KHUI0wYFXOtYPnVVVspTFUuMZNfNaNVRt3FZadstu2c8x23vykRW/NBoU6A==",
 			"dev": true,
 			"dependencies": {
 				"has": "^1.0.3"
+			},
+			"funding": {
+				"url": "https://github.com/sponsors/ljharb"
 			}
 		},
 		"node_modules/is-decimal": {
@@ -2458,16 +2461,6 @@
 				"node": ">= 8"
 			}
 		},
-		"node_modules/liftup/node_modules/resolve": {
-			"version": "1.20.0",
-			"resolved": "https://registry.npmjs.org/resolve/-/resolve-1.20.0.tgz",
-			"integrity": "sha512-wENBPt4ySzg4ybFQW2TT1zMQucPK95HSh/nq2CFTZVOGut2+pQvSsgtda4d26YrYcr067wjbmzOG8byDPBX63A==",
-			"dev": true,
-			"dependencies": {
-				"is-core-module": "^2.2.0",
-				"path-parse": "^1.0.6"
-			}
-		},
 		"node_modules/lines-and-columns": {
 			"version": "1.1.6",
 			"resolved": "https://registry.npmjs.org/lines-and-columns/-/lines-and-columns-1.1.6.tgz",
@@ -2829,16 +2822,6 @@
 				"node": ">=10"
 			}
 		},
-		"node_modules/normalize-package-data/node_modules/resolve": {
-			"version": "1.20.0",
-			"resolved": "https://registry.npmjs.org/resolve/-/resolve-1.20.0.tgz",
-			"integrity": "sha512-wENBPt4ySzg4ybFQW2TT1zMQucPK95HSh/nq2CFTZVOGut2+pQvSsgtda4d26YrYcr067wjbmzOG8byDPBX63A==",
-			"dev": true,
-			"dependencies": {
-				"is-core-module": "^2.2.0",
-				"path-parse": "^1.0.6"
-			}
-		},
 		"node_modules/normalize-package-data/node_modules/semver": {
 			"version": "7.3.5",
 			"resolved": "https://registry.npmjs.org/semver/-/semver-7.3.5.tgz",
@@ -3425,9 +3408,9 @@
 			}
 		},
 		"node_modules/rechoir": {
-			"version": "0.7.0",
-			"resolved": "https://registry.npmjs.org/rechoir/-/rechoir-0.7.0.tgz",
-			"integrity": "sha512-ADsDEH2bvbjltXEP+hTIAmeFekTFK0V2BTxMkok6qILyAJEXV0AFfoWcAq4yfll5VdIMd/RVXq0lR+wQi5ZU3Q==",
+			"version": "0.7.1",
+			"resolved": "https://registry.npmjs.org/rechoir/-/rechoir-0.7.1.tgz",
+			"integrity": "sha512-/njmZ8s1wVeR6pjTZ+0nCnv8SpZNRMT2D1RLOJQESlYFDBvwpTA4KWJpZ+sBJ4+vhjILRcK7JIFdGCdxEAAitg==",
 			"dev": true,
 			"dependencies": {
 				"resolve": "^1.9.0"
@@ -3506,12 +3489,20 @@
 			}
 		},
 		"node_modules/resolve": {
-			"version": "1.14.2",
-			"resolved": "https://registry.npmjs.org/resolve/-/resolve-1.14.2.tgz",
-			"integrity": "sha512-EjlOBLBO1kxsUxsKjLt7TAECyKW6fOh1VRkykQkKGzcBbjjPIxBqGh0jf7GJ3k/f5mxMqW3htMD3WdTUVtW8HQ==",
+			"version": "1.22.0",
+			"resolved": "https://registry.npmjs.org/resolve/-/resolve-1.22.0.tgz",
+			"integrity": "sha512-Hhtrw0nLeSrFQ7phPp4OOcVjLPIeMnRlr5mcnVuMe7M/7eBn98A3hmFRLoFo3DLZkivSYwhRUJTyPyWAk56WLw==",
 			"dev": true,
 			"dependencies": {
-				"path-parse": "^1.0.6"
+				"is-core-module": "^2.8.1",
+				"path-parse": "^1.0.7",
+				"supports-preserve-symlinks-flag": "^1.0.0"
+			},
+			"bin": {
+				"resolve": "bin/resolve"
+			},
+			"funding": {
+				"url": "https://github.com/sponsors/ljharb"
 			}
 		},
 		"node_modules/resolve-dir": {
@@ -4010,6 +4001,18 @@
 				"node": ">=4"
 			}
 		},
+		"node_modules/supports-preserve-symlinks-flag": {
+			"version": "1.0.0",
+			"resolved": "https://registry.npmjs.org/supports-preserve-symlinks-flag/-/supports-preserve-symlinks-flag-1.0.0.tgz",
+			"integrity": "sha512-ot0WnXS9fgdkgIcePe6RHNk1WA8+muPa6cSjeR3V8K27q9BB1rTE3R1p7Hv0z1ZyAc8s6Vvv8DIyWf681MAt0w==",
+			"dev": true,
+			"engines": {
+				"node": ">= 0.4"
+			},
+			"funding": {
+				"url": "https://github.com/sponsors/ljharb"
+			}
+		},
 		"node_modules/svg-tags": {
 			"version": "1.0.0",
 			"resolved": "https://registry.npmjs.org/svg-tags/-/svg-tags-1.0.0.tgz",
@@ -4833,7 +4836,7 @@
 		"array-each": {
 			"version": "1.0.1",
 			"resolved": "https://registry.npmjs.org/array-each/-/array-each-1.0.1.tgz",
-			"integrity": "sha1-p5SvDAWrF1KEbudTofIRoFugxE8=",
+			"integrity": "sha512-zHjL5SZa68hkKHBFBK6DJCTtr9sfTCPCaph/L7tMSLcTFgy+zX7E+6q5UArbtOtMBCtxdICpfTCspRse+ywyXA==",
 			"dev": true
 		},
 		"array-slice": {
@@ -5704,9 +5707,9 @@
 			}
 		},
 		"grunt": {
-			"version": "1.4.0",
-			"resolved": "https://registry.npmjs.org/grunt/-/grunt-1.4.0.tgz",
-			"integrity": "sha512-yRFc0GVCDu9yxqOFzpuXQ2pEdgtLDnFv5Qz54jfIcNnpJ8Z7B7P7kPkT4VMuRvm+N+QOsI8C4v/Q0DSaoj3LgQ==",
+			"version": "1.5.3",
+			"resolved": "https://registry.npmjs.org/grunt/-/grunt-1.5.3.tgz",
+			"integrity": "sha512-mKwmo4X2d8/4c/BmcOETHek675uOqw0RuA/zy12jaspWqvTp4+ZeQF1W+OTpcbncnaBsfbQJ6l0l4j+Sn/GmaQ==",
 			"dev": true,
 			"requires": {
 				"dateformat": "~3.0.3",
@@ -5714,8 +5717,8 @@
 				"exit": "~0.1.2",
 				"findup-sync": "~0.3.0",
 				"glob": "~7.1.6",
-				"grunt-cli": "~1.4.2",
-				"grunt-known-options": "~1.1.1",
+				"grunt-cli": "~1.4.3",
+				"grunt-known-options": "~2.0.0",
 				"grunt-legacy-log": "~3.0.0",
 				"grunt-legacy-util": "~2.0.1",
 				"iconv-lite": "~0.4.13",
@@ -5726,31 +5729,6 @@
 				"rimraf": "~3.0.2"
 			},
 			"dependencies": {
-				"grunt-cli": {
-					"version": "1.4.2",
-					"resolved": "https://registry.npmjs.org/grunt-cli/-/grunt-cli-1.4.2.tgz",
-					"integrity": "sha512-wsu6BZh7KCnfeaSkDrKIAvOlqGKxNRTZjc8xfZlvxCByQIqUfZ31kh5uHpPnhQ4NdVgvaWaVxa1LUbVU80nACw==",
-					"dev": true,
-					"requires": {
-						"grunt-known-options": "~1.1.1",
-						"interpret": "~1.1.0",
-						"liftup": "~3.0.1",
-						"nopt": "~4.0.1",
-						"v8flags": "~3.2.0"
-					},
-					"dependencies": {
-						"nopt": {
-							"version": "4.0.3",
-							"resolved": "https://registry.npmjs.org/nopt/-/nopt-4.0.3.tgz",
-							"integrity": "sha512-CvaGwVMztSMJLOeXPrez7fyfObdZqNUK1cPAEzLHrTybIua9pMdmmPR5YwtfNftIOMv3DPUhFaxsZMNTQO20Kg==",
-							"dev": true,
-							"requires": {
-								"abbrev": "1",
-								"osenv": "^0.1.4"
-							}
-						}
-					}
-				},
 				"mkdirp": {
 					"version": "1.0.4",
 					"resolved": "https://registry.npmjs.org/mkdirp/-/mkdirp-1.0.4.tgz",
@@ -5774,6 +5752,31 @@
 			"integrity": "sha512-SqPiB6OazWqR8USL0NymtuT5Br3mD9WBBsM1rHC/3wIi2SrZNM6/+j9CIeuEM5oCn+AtO2Y0+rzzFyOdC9afAg==",
 			"dev": true
 		},
+		"grunt-cli": {
+			"version": "1.4.3",
+			"resolved": "https://registry.npmjs.org/grunt-cli/-/grunt-cli-1.4.3.tgz",
+			"integrity": "sha512-9Dtx/AhVeB4LYzsViCjUQkd0Kw0McN2gYpdmGYKtE2a5Yt7v1Q+HYZVWhqXc/kGnxlMtqKDxSwotiGeFmkrCoQ==",
+			"dev": true,
+			"requires": {
+				"grunt-known-options": "~2.0.0",
+				"interpret": "~1.1.0",
+				"liftup": "~3.0.1",
+				"nopt": "~4.0.1",
+				"v8flags": "~3.2.0"
+			},
+			"dependencies": {
+				"nopt": {
+					"version": "4.0.3",
+					"resolved": "https://registry.npmjs.org/nopt/-/nopt-4.0.3.tgz",
+					"integrity": "sha512-CvaGwVMztSMJLOeXPrez7fyfObdZqNUK1cPAEzLHrTybIua9pMdmmPR5YwtfNftIOMv3DPUhFaxsZMNTQO20Kg==",
+					"dev": true,
+					"requires": {
+						"abbrev": "1",
+						"osenv": "^0.1.4"
+					}
+				}
+			}
+		},
 		"grunt-contrib-jshint": {
 			"version": "1.1.0",
 			"resolved": "https://registry.npmjs.org/grunt-contrib-jshint/-/grunt-contrib-jshint-1.1.0.tgz",
@@ -5831,9 +5834,9 @@
 			}
 		},
 		"grunt-known-options": {
-			"version": "1.1.1",
-			"resolved": "https://registry.npmjs.org/grunt-known-options/-/grunt-known-options-1.1.1.tgz",
-			"integrity": "sha512-cHwsLqoighpu7TuYj5RonnEuxGVFnztcUqTqp5rXFGYL4OuPFofwC4Ycg7n9fYwvK6F5WbYgeVOwph9Crs2fsQ==",
+			"version": "2.0.0",
+			"resolved": "https://registry.npmjs.org/grunt-known-options/-/grunt-known-options-2.0.0.tgz",
+			"integrity": "sha512-GD7cTz0I4SAede1/+pAbmJRG44zFLPipVtdL9o3vqx9IEyb7b4/Y3s7r6ofI3CchR5GvYJ+8buCSioDv5dQLiA==",
 			"dev": true
 		},
 		"grunt-legacy-log": {
@@ -6199,9 +6202,9 @@
 			"dev": true
 		},
 		"is-core-module": {
-			"version": "2.4.0",
-			"resolved": "https://registry.npmjs.org/is-core-module/-/is-core-module-2.4.0.tgz",
-			"integrity": "sha512-6A2fkfq1rfeQZjxrZJGerpLCTHRNEBiSgnu0+obeJpEPZRUooHgsizvzv0ZjJwOz3iWIHdJtVWJ/tmPr3D21/A==",
+			"version": "2.9.0",
+			"resolved": "https://registry.npmjs.org/is-core-module/-/is-core-module-2.9.0.tgz",
+			"integrity": "sha512-+5FPy5PnwmO3lvfMb0AsoPaBG+5KHUI0wYFXOtYPnVVVspTFUuMZNfNaNVRt3FZadstu2c8x23vykRW/NBoU6A==",
 			"dev": true,
 			"requires": {
 				"has": "^1.0.3"
@@ -6469,16 +6472,6 @@
 						"micromatch": "^4.0.2",
 						"resolve-dir": "^1.0.1"
 					}
-				},
-				"resolve": {
-					"version": "1.20.0",
-					"resolved": "https://registry.npmjs.org/resolve/-/resolve-1.20.0.tgz",
-					"integrity": "sha512-wENBPt4ySzg4ybFQW2TT1zMQucPK95HSh/nq2CFTZVOGut2+pQvSsgtda4d26YrYcr067wjbmzOG8byDPBX63A==",
-					"dev": true,
-					"requires": {
-						"is-core-module": "^2.2.0",
-						"path-parse": "^1.0.6"
-					}
 				}
 			}
 		},
@@ -6780,16 +6773,6 @@
 				"validate-npm-package-license": "^3.0.1"
 			},
 			"dependencies": {
-				"resolve": {
-					"version": "1.20.0",
-					"resolved": "https://registry.npmjs.org/resolve/-/resolve-1.20.0.tgz",
-					"integrity": "sha512-wENBPt4ySzg4ybFQW2TT1zMQucPK95HSh/nq2CFTZVOGut2+pQvSsgtda4d26YrYcr067wjbmzOG8byDPBX63A==",
-					"dev": true,
-					"requires": {
-						"is-core-module": "^2.2.0",
-						"path-parse": "^1.0.6"
-					}
-				},
 				"semver": {
 					"version": "7.3.5",
 					"resolved": "https://registry.npmjs.org/semver/-/semver-7.3.5.tgz",
@@ -7274,9 +7257,9 @@
 			}
 		},
 		"rechoir": {
-			"version": "0.7.0",
-			"resolved": "https://registry.npmjs.org/rechoir/-/rechoir-0.7.0.tgz",
-			"integrity": "sha512-ADsDEH2bvbjltXEP+hTIAmeFekTFK0V2BTxMkok6qILyAJEXV0AFfoWcAq4yfll5VdIMd/RVXq0lR+wQi5ZU3Q==",
+			"version": "0.7.1",
+			"resolved": "https://registry.npmjs.org/rechoir/-/rechoir-0.7.1.tgz",
+			"integrity": "sha512-/njmZ8s1wVeR6pjTZ+0nCnv8SpZNRMT2D1RLOJQESlYFDBvwpTA4KWJpZ+sBJ4+vhjILRcK7JIFdGCdxEAAitg==",
 			"dev": true,
 			"requires": {
 				"resolve": "^1.9.0"
@@ -7340,12 +7323,14 @@
 			"dev": true
 		},
 		"resolve": {
-			"version": "1.14.2",
-			"resolved": "https://registry.npmjs.org/resolve/-/resolve-1.14.2.tgz",
-			"integrity": "sha512-EjlOBLBO1kxsUxsKjLt7TAECyKW6fOh1VRkykQkKGzcBbjjPIxBqGh0jf7GJ3k/f5mxMqW3htMD3WdTUVtW8HQ==",
+			"version": "1.22.0",
+			"resolved": "https://registry.npmjs.org/resolve/-/resolve-1.22.0.tgz",
+			"integrity": "sha512-Hhtrw0nLeSrFQ7phPp4OOcVjLPIeMnRlr5mcnVuMe7M/7eBn98A3hmFRLoFo3DLZkivSYwhRUJTyPyWAk56WLw==",
 			"dev": true,
 			"requires": {
-				"path-parse": "^1.0.6"
+				"is-core-module": "^2.8.1",
+				"path-parse": "^1.0.7",
+				"supports-preserve-symlinks-flag": "^1.0.0"
 			}
 		},
 		"resolve-dir": {
@@ -7765,6 +7750,12 @@
 				"has-flag": "^3.0.0"
 			}
 		},
+		"supports-preserve-symlinks-flag": {
+			"version": "1.0.0",
+			"resolved": "https://registry.npmjs.org/supports-preserve-symlinks-flag/-/supports-preserve-symlinks-flag-1.0.0.tgz",
+			"integrity": "sha512-ot0WnXS9fgdkgIcePe6RHNk1WA8+muPa6cSjeR3V8K27q9BB1rTE3R1p7Hv0z1ZyAc8s6Vvv8DIyWf681MAt0w==",
+			"dev": true
+		},
 		"svg-tags": {
 			"version": "1.0.0",
 			"resolved": "https://registry.npmjs.org/svg-tags/-/svg-tags-1.0.0.tgz",
diff --git a/package.json b/package.json
index 7ff262f..2b9742e 100644
--- a/package.json
+++ b/package.json
@@ -5,7 +5,7 @@
 		"test": "grunt test"
 	},
 	"devDependencies": {
-		"grunt": "1.4.0",
+		"grunt": "1.5.3",
 		"grunt-banana-checker": "0.9.0",
 		"grunt-contrib-jshint": "1.1.0",
 		"grunt-jsonlint": "1.0.7",
-- 
2.30.2

$ date
--- stdout ---
Sun May 22 18:01:33 UTC 2022

--- end ---
$ git clone file:///srv/git/mediawiki-extensions-FundraisingEmailUnsubscribe.git repo --depth=1 -b REL1_35
--- stderr ---
Cloning into 'repo'...
--- stdout ---

--- end ---
$ git config user.name libraryupgrader
--- stdout ---

--- end ---
$ git config user.email tools.libraryupgrader@tools.wmflabs.org
--- stdout ---

--- end ---
$ git submodule update --init
--- stdout ---

--- end ---
$ grr init
--- stdout ---
Installed commit-msg hook.

--- end ---
$ git show-ref refs/heads/REL1_35
--- stdout ---
05146cca297ea05814bc50cf5387e0615b8d7030 refs/heads/REL1_35

--- end ---
$ /usr/bin/npm audit --json --legacy-peer-deps
--- stdout ---
{
  "auditReportVersion": 2,
  "vulnerabilities": {
    "grunt": {
      "name": "grunt",
      "severity": "moderate",
      "via": [
        {
          "source": 1070249,
          "name": "grunt",
          "dependency": "grunt",
          "title": "Path Traversal in Grunt",
          "url": "https://github.com/advisories/GHSA-j383-35pm-c5h4",
          "severity": "moderate",
          "range": "<1.5.2"
        }
      ],
      "effects": [],
      "range": "<1.5.2",
      "nodes": [
        "node_modules/grunt"
      ],
      "fixAvailable": {
        "name": "grunt",
        "version": "1.5.3",
        "isSemVerMajor": false
      }
    },
    "grunt-contrib-jshint": {
      "name": "grunt-contrib-jshint",
      "severity": "high",
      "via": [
        "jshint"
      ],
      "effects": [],
      "range": "0.3.0 - 3.0.0",
      "nodes": [
        "node_modules/grunt-contrib-jshint"
      ],
      "fixAvailable": {
        "name": "grunt-contrib-jshint",
        "version": "3.2.0",
        "isSemVerMajor": true
      }
    },
    "jshint": {
      "name": "jshint",
      "severity": "high",
      "via": [
        "shelljs"
      ],
      "effects": [
        "grunt-contrib-jshint"
      ],
      "range": "1.1.0 - 2.13.3",
      "nodes": [
        "node_modules/jshint"
      ],
      "fixAvailable": {
        "name": "grunt-contrib-jshint",
        "version": "3.2.0",
        "isSemVerMajor": true
      }
    },
    "nomnom": {
      "name": "nomnom",
      "severity": "high",
      "via": [
        "underscore"
      ],
      "effects": [],
      "range": ">=1.6.0",
      "nodes": [
        "node_modules/nomnom"
      ],
      "fixAvailable": true
    },
    "shelljs": {
      "name": "shelljs",
      "severity": "high",
      "via": [
        {
          "source": 1067444,
          "name": "shelljs",
          "dependency": "shelljs",
          "title": "Improper Privilege Management in shelljs",
          "url": "https://github.com/advisories/GHSA-4rq4-32rv-6wp6",
          "severity": "high",
          "range": "<0.8.5"
        }
      ],
      "effects": [
        "jshint"
      ],
      "range": "<0.8.5",
      "nodes": [
        "node_modules/shelljs"
      ],
      "fixAvailable": {
        "name": "grunt-contrib-jshint",
        "version": "3.2.0",
        "isSemVerMajor": true
      }
    },
    "underscore": {
      "name": "underscore",
      "severity": "high",
      "via": [
        {
          "source": 1068134,
          "name": "underscore",
          "dependency": "underscore",
          "title": "Arbitrary Code Execution in underscore",
          "url": "https://github.com/advisories/GHSA-cf4h-3jhx-xvhq",
          "severity": "high",
          "range": ">=1.3.2 <1.12.1"
        }
      ],
      "effects": [
        "nomnom"
      ],
      "range": "1.3.2 - 1.12.0",
      "nodes": [
        "node_modules/underscore"
      ],
      "fixAvailable": true
    }
  },
  "metadata": {
    "vulnerabilities": {
      "info": 0,
      "low": 0,
      "moderate": 1,
      "high": 5,
      "critical": 0,
      "total": 6
    },
    "dependencies": {
      "prod": 1,
      "dev": 429,
      "optional": 0,
      "peer": 0,
      "peerOptional": 0,
      "total": 429
    }
  }
}

--- end ---
$ /usr/bin/composer install
--- stderr ---
No lock file found. Updating dependencies instead of installing from lock file. Use composer update over composer install if you do not have a lock file.
Loading composer repositories with package information
Info from https://repo.packagist.org: #StandWithUkraine
Updating dependencies
Lock file operations: 21 installs, 0 updates, 0 removals
  - Locking clio/clio (0.1.8)
  - Locking coderkungfu/php-queue (1.0.1)
  - Locking composer/semver (3.3.2)
  - Locking composer/spdx-licenses (1.5.6)
  - Locking jakub-onderka/php-console-color (v0.2)
  - Locking mediawiki/mediawiki-codesniffer (v38.0.0)
  - Locking mediawiki/minus-x (0.3.2)
  - Locking monolog/monolog (2.6.0)
  - Locking php-parallel-lint/php-console-highlighter (v0.4)
  - Locking php-parallel-lint/php-parallel-lint (v1.0.0)
  - Locking predis/predis (v1.1.10)
  - Locking psr/container (1.1.2)
  - Locking psr/log (1.1.4)
  - Locking squizlabs/php_codesniffer (3.6.1)
  - Locking symfony/console (v4.4.41)
  - Locking symfony/deprecation-contracts (v2.5.1)
  - Locking symfony/polyfill-mbstring (v1.25.0)
  - Locking symfony/polyfill-php73 (v1.25.0)
  - Locking symfony/polyfill-php80 (v1.25.0)
  - Locking symfony/service-contracts (v2.5.1)
  - Locking twig/twig (v1.24.2)
Writing lock file
Installing dependencies from lock file (including require-dev)
Package operations: 21 installs, 0 updates, 0 removals
  - Downloading twig/twig (v1.24.2)
 0/1 [>---------------------------]   0%
 1/1 [============================] 100%  - Installing psr/log (1.1.4): Extracting archive
  - Installing monolog/monolog (2.6.0): Extracting archive
  - Installing clio/clio (0.1.8): Extracting archive
  - Installing coderkungfu/php-queue (1.0.1): Extracting archive
  - Installing squizlabs/php_codesniffer (3.6.1): Extracting archive
  - Installing symfony/polyfill-mbstring (v1.25.0): Extracting archive
  - Installing composer/spdx-licenses (1.5.6): Extracting archive
  - Installing composer/semver (3.3.2): Extracting archive
  - Installing mediawiki/mediawiki-codesniffer (v38.0.0): Extracting archive
  - Installing symfony/deprecation-contracts (v2.5.1): Extracting archive
  - Installing psr/container (1.1.2): Extracting archive
  - Installing symfony/service-contracts (v2.5.1): Extracting archive
  - Installing symfony/polyfill-php80 (v1.25.0): Extracting archive
  - Installing symfony/polyfill-php73 (v1.25.0): Extracting archive
  - Installing symfony/console (v4.4.41): Extracting archive
  - Installing mediawiki/minus-x (0.3.2): Extracting archive
  - Installing jakub-onderka/php-console-color (v0.2): Extracting archive
  - Installing php-parallel-lint/php-console-highlighter (v0.4): Extracting archive
  - Installing php-parallel-lint/php-parallel-lint (v1.0.0): Extracting archive
  - Installing predis/predis (v1.1.10): Extracting archive
  - Installing twig/twig (v1.24.2): Extracting archive
  0/12 [>---------------------------]   0%
  9/12 [=====================>------]  75%
 12/12 [============================] 100%25 package suggestions were added by new dependencies, use `composer suggest` to see details.
Package jakub-onderka/php-console-color is abandoned, you should avoid using it. Use php-parallel-lint/php-console-color instead.
Generating autoload files
10 packages you are using are looking for funding.
Use the `composer fund` command to find out more!
--- stdout ---

--- end ---
$ /usr/bin/npm audit --json --legacy-peer-deps
--- stdout ---
{
  "auditReportVersion": 2,
  "vulnerabilities": {
    "grunt": {
      "name": "grunt",
      "severity": "moderate",
      "via": [
        {
          "source": 1070249,
          "name": "grunt",
          "dependency": "grunt",
          "title": "Path Traversal in Grunt",
          "url": "https://github.com/advisories/GHSA-j383-35pm-c5h4",
          "severity": "moderate",
          "range": "<1.5.2"
        }
      ],
      "effects": [],
      "range": "<1.5.2",
      "nodes": [
        "node_modules/grunt"
      ],
      "fixAvailable": {
        "name": "grunt",
        "version": "1.5.3",
        "isSemVerMajor": false
      }
    },
    "grunt-contrib-jshint": {
      "name": "grunt-contrib-jshint",
      "severity": "high",
      "via": [
        "jshint"
      ],
      "effects": [],
      "range": "0.3.0 - 3.0.0",
      "nodes": [
        "node_modules/grunt-contrib-jshint"
      ],
      "fixAvailable": {
        "name": "grunt-contrib-jshint",
        "version": "3.2.0",
        "isSemVerMajor": true
      }
    },
    "jshint": {
      "name": "jshint",
      "severity": "high",
      "via": [
        "shelljs"
      ],
      "effects": [
        "grunt-contrib-jshint"
      ],
      "range": "1.1.0 - 2.13.3",
      "nodes": [
        "node_modules/jshint"
      ],
      "fixAvailable": {
        "name": "grunt-contrib-jshint",
        "version": "3.2.0",
        "isSemVerMajor": true
      }
    },
    "nomnom": {
      "name": "nomnom",
      "severity": "high",
      "via": [
        "underscore"
      ],
      "effects": [],
      "range": ">=1.6.0",
      "nodes": [
        "node_modules/nomnom"
      ],
      "fixAvailable": true
    },
    "shelljs": {
      "name": "shelljs",
      "severity": "high",
      "via": [
        {
          "source": 1067444,
          "name": "shelljs",
          "dependency": "shelljs",
          "title": "Improper Privilege Management in shelljs",
          "url": "https://github.com/advisories/GHSA-4rq4-32rv-6wp6",
          "severity": "high",
          "range": "<0.8.5"
        }
      ],
      "effects": [
        "jshint"
      ],
      "range": "<0.8.5",
      "nodes": [
        "node_modules/shelljs"
      ],
      "fixAvailable": {
        "name": "grunt-contrib-jshint",
        "version": "3.2.0",
        "isSemVerMajor": true
      }
    },
    "underscore": {
      "name": "underscore",
      "severity": "high",
      "via": [
        {
          "source": 1068134,
          "name": "underscore",
          "dependency": "underscore",
          "title": "Arbitrary Code Execution in underscore",
          "url": "https://github.com/advisories/GHSA-cf4h-3jhx-xvhq",
          "severity": "high",
          "range": ">=1.3.2 <1.12.1"
        }
      ],
      "effects": [
        "nomnom"
      ],
      "range": "1.3.2 - 1.12.0",
      "nodes": [
        "node_modules/underscore"
      ],
      "fixAvailable": true
    }
  },
  "metadata": {
    "vulnerabilities": {
      "info": 0,
      "low": 0,
      "moderate": 1,
      "high": 5,
      "critical": 0,
      "total": 6
    },
    "dependencies": {
      "prod": 1,
      "dev": 429,
      "optional": 0,
      "peer": 0,
      "peerOptional": 0,
      "total": 429
    }
  }
}

--- end ---
Attempting to npm audit fix
$ /usr/bin/npm audit fix --dry-run --only=dev --json --legacy-peer-deps
--- stdout ---
{
  "added": 429,
  "removed": 0,
  "changed": 0,
  "audited": 430,
  "funding": 0,
  "audit": {
    "auditReportVersion": 2,
    "vulnerabilities": {
      "grunt": {
        "name": "grunt",
        "severity": "moderate",
        "via": [
          {
            "source": 1070249,
            "name": "grunt",
            "dependency": "grunt",
            "title": "Path Traversal in Grunt",
            "url": "https://github.com/advisories/GHSA-j383-35pm-c5h4",
            "severity": "moderate",
            "range": "<1.5.2"
          }
        ],
        "effects": [],
        "range": "<1.5.2",
        "nodes": [
          "node_modules/grunt"
        ],
        "fixAvailable": {
          "name": "grunt",
          "version": "1.5.3",
          "isSemVerMajor": false
        }
      },
      "grunt-contrib-jshint": {
        "name": "grunt-contrib-jshint",
        "severity": "high",
        "via": [
          "jshint"
        ],
        "effects": [],
        "range": "0.3.0 - 3.0.0",
        "nodes": [
          "node_modules/grunt-contrib-jshint"
        ],
        "fixAvailable": {
          "name": "grunt-contrib-jshint",
          "version": "3.2.0",
          "isSemVerMajor": true
        }
      },
      "jshint": {
        "name": "jshint",
        "severity": "high",
        "via": [
          "shelljs"
        ],
        "effects": [
          "grunt-contrib-jshint"
        ],
        "range": "1.1.0 - 2.13.3",
        "nodes": [
          "node_modules/jshint"
        ],
        "fixAvailable": {
          "name": "grunt-contrib-jshint",
          "version": "3.2.0",
          "isSemVerMajor": true
        }
      },
      "nomnom": {
        "name": "nomnom",
        "severity": "high",
        "via": [
          "underscore"
        ],
        "effects": [],
        "range": ">=1.6.0",
        "nodes": [
          "node_modules/nomnom"
        ],
        "fixAvailable": true
      },
      "shelljs": {
        "name": "shelljs",
        "severity": "high",
        "via": [
          {
            "source": 1067444,
            "name": "shelljs",
            "dependency": "shelljs",
            "title": "Improper Privilege Management in shelljs",
            "url": "https://github.com/advisories/GHSA-4rq4-32rv-6wp6",
            "severity": "high",
            "range": "<0.8.5"
          }
        ],
        "effects": [
          "jshint"
        ],
        "range": "<0.8.5",
        "nodes": [
          "node_modules/shelljs"
        ],
        "fixAvailable": {
          "name": "grunt-contrib-jshint",
          "version": "3.2.0",
          "isSemVerMajor": true
        }
      },
      "underscore": {
        "name": "underscore",
        "severity": "high",
        "via": [
          {
            "source": 1068134,
            "name": "underscore",
            "dependency": "underscore",
            "title": "Arbitrary Code Execution in underscore",
            "url": "https://github.com/advisories/GHSA-cf4h-3jhx-xvhq",
            "severity": "high",
            "range": ">=1.3.2 <1.12.1"
          }
        ],
        "effects": [
          "nomnom"
        ],
        "range": "1.3.2 - 1.12.0",
        "nodes": [
          "node_modules/underscore"
        ],
        "fixAvailable": true
      }
    },
    "metadata": {
      "vulnerabilities": {
        "info": 0,
        "low": 0,
        "moderate": 1,
        "high": 5,
        "critical": 0,
        "total": 6
      },
      "dependencies": {
        "prod": 1,
        "dev": 429,
        "optional": 0,
        "peer": 0,
        "peerOptional": 0,
        "total": 429
      }
    }
  }
}

--- end ---
{"added": 429, "removed": 0, "changed": 0, "audited": 430, "funding": 0, "audit": {"auditReportVersion": 2, "vulnerabilities": {"grunt": {"name": "grunt", "severity": "moderate", "via": [{"source": 1070249, "name": "grunt", "dependency": "grunt", "title": "Path Traversal in Grunt", "url": "https://github.com/advisories/GHSA-j383-35pm-c5h4", "severity": "moderate", "range": "<1.5.2"}], "effects": [], "range": "<1.5.2", "nodes": ["node_modules/grunt"], "fixAvailable": {"name": "grunt", "version": "1.5.3", "isSemVerMajor": false}}, "grunt-contrib-jshint": {"name": "grunt-contrib-jshint", "severity": "high", "via": ["jshint"], "effects": [], "range": "0.3.0 - 3.0.0", "nodes": ["node_modules/grunt-contrib-jshint"], "fixAvailable": {"name": "grunt-contrib-jshint", "version": "3.2.0", "isSemVerMajor": true}}, "jshint": {"name": "jshint", "severity": "high", "via": ["shelljs"], "effects": ["grunt-contrib-jshint"], "range": "1.1.0 - 2.13.3", "nodes": ["node_modules/jshint"], "fixAvailable": {"name": "grunt-contrib-jshint", "version": "3.2.0", "isSemVerMajor": true}}, "nomnom": {"name": "nomnom", "severity": "high", "via": ["underscore"], "effects": [], "range": ">=1.6.0", "nodes": ["node_modules/nomnom"], "fixAvailable": true}, "shelljs": {"name": "shelljs", "severity": "high", "via": [{"source": 1067444, "name": "shelljs", "dependency": "shelljs", "title": "Improper Privilege Management in shelljs", "url": "https://github.com/advisories/GHSA-4rq4-32rv-6wp6", "severity": "high", "range": "<0.8.5"}], "effects": ["jshint"], "range": "<0.8.5", "nodes": ["node_modules/shelljs"], "fixAvailable": {"name": "grunt-contrib-jshint", "version": "3.2.0", "isSemVerMajor": true}}, "underscore": {"name": "underscore", "severity": "high", "via": [{"source": 1068134, "name": "underscore", "dependency": "underscore", "title": "Arbitrary Code Execution in underscore", "url": "https://github.com/advisories/GHSA-cf4h-3jhx-xvhq", "severity": "high", "range": ">=1.3.2 <1.12.1"}], "effects": ["nomnom"], "range": "1.3.2 - 1.12.0", "nodes": ["node_modules/underscore"], "fixAvailable": true}}, "metadata": {"vulnerabilities": {"info": 0, "low": 0, "moderate": 1, "high": 5, "critical": 0, "total": 6}, "dependencies": {"prod": 1, "dev": 429, "optional": 0, "peer": 0, "peerOptional": 0, "total": 429}}}}
{}
Upgrading n:grunt from 1.4.0 -> 1.5.3
$ /usr/bin/npm audit fix --only=dev --legacy-peer-deps
--- stdout ---

added 428 packages, and audited 429 packages in 6s

3 packages are looking for funding
  run `npm fund` for details

# npm audit report

shelljs  <0.8.5
Severity: high
Improper Privilege Management in shelljs - https://github.com/advisories/GHSA-4rq4-32rv-6wp6
fix available via `npm audit fix --force`
Will install grunt-contrib-jshint@3.2.0, which is a breaking change
node_modules/shelljs
  jshint  1.1.0 - 2.13.3
  Depends on vulnerable versions of shelljs
  node_modules/jshint
    grunt-contrib-jshint  0.3.0 - 3.0.0
    Depends on vulnerable versions of jshint
    node_modules/grunt-contrib-jshint

underscore  1.3.2 - 1.12.0
Severity: high
Arbitrary Code Execution in underscore - https://github.com/advisories/GHSA-cf4h-3jhx-xvhq
fix available via `npm audit fix`
node_modules/underscore
  nomnom  >=1.6.0
  Depends on vulnerable versions of underscore
  node_modules/nomnom

5 high severity vulnerabilities

To address issues that do not require attention, run:
  npm audit fix

To address all issues (including breaking changes), run:
  npm audit fix --force

--- end ---
$ package-lock-lint package-lock.json
--- stdout ---
Checking package-lock.json

--- end ---
Verifying that tests still pass
$ /usr/bin/npm ci
--- stdout ---

added 428 packages, and audited 429 packages in 5s

3 packages are looking for funding
  run `npm fund` for details

5 high severity vulnerabilities

To address issues that do not require attention, run:
  npm audit fix

To address all issues (including breaking changes), run:
  npm audit fix --force

Run `npm audit` for details.

--- end ---
$ /usr/bin/npm test
--- stdout ---

> test
> grunt test

Running "jsonlint:all" (jsonlint) task
>> 75 files lint free.

Running "stylelint:all" (stylelint) task
>> Linted 1 files without errors

Running "banana:FundraisingEmailUnsubscribe" (banana) task
>> 1 message directory checked.

Running "jshint:all" (jshint) task
>> 2 files lint free.

Done.

--- end ---
{"1068134": {"source": 1068134, "name": "underscore", "dependency": "underscore", "title": "Arbitrary Code Execution in underscore", "url": "https://github.com/advisories/GHSA-cf4h-3jhx-xvhq", "severity": "high", "range": ">=1.3.2 <1.12.1"}}
Upgrading n:nomnom from 1.8.1 -> 1.8.1
{"1068134": {"source": 1068134, "name": "underscore", "dependency": "underscore", "title": "Arbitrary Code Execution in underscore", "url": "https://github.com/advisories/GHSA-cf4h-3jhx-xvhq", "severity": "high", "range": ">=1.3.2 <1.12.1"}}
Upgrading n:underscore from 1.6.0 -> 1.6.0
$ package-lock-lint package-lock.json
--- stdout ---
Checking package-lock.json

--- end ---
build: Updating npm dependencies

* grunt: 1.4.0 → 1.5.3
* nomnom: 1.8.1 → 1.8.1
  * https://github.com/advisories/GHSA-cf4h-3jhx-xvhq
* underscore: 1.6.0 → 1.6.0
  * https://github.com/advisories/GHSA-cf4h-3jhx-xvhq

$ git add .
--- stdout ---

--- end ---
$ git commit -F /tmp/tmpb9i_9r8w
--- stdout ---
[REL1_35 bafa921] build: Updating npm dependencies
 2 files changed, 128 insertions(+), 137 deletions(-)

--- end ---
$ git format-patch HEAD~1 --stdout
--- stdout ---
From bafa921d73ae0984f3e10831ee26627b4cc4820a Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Sun, 22 May 2022 18:01:59 +0000
Subject: [PATCH] build: Updating npm dependencies
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* grunt: 1.4.0 → 1.5.3
* nomnom: 1.8.1 → 1.8.1
  * https://github.com/advisories/GHSA-cf4h-3jhx-xvhq
* underscore: 1.6.0 → 1.6.0
  * https://github.com/advisories/GHSA-cf4h-3jhx-xvhq

Change-Id: I4c4d81e3dace4926794f42dd791fc6e12a237e92
---
 package-lock.json | 263 ++++++++++++++++++++++------------------------
 package.json      |   2 +-
 2 files changed, 128 insertions(+), 137 deletions(-)

diff --git a/package-lock.json b/package-lock.json
index 13a844e..33744c9 100644
--- a/package-lock.json
+++ b/package-lock.json
@@ -6,7 +6,7 @@
 		"": {
 			"name": "FundraisingEmailUnsubscribe",
 			"devDependencies": {
-				"grunt": "1.4.0",
+				"grunt": "1.5.3",
 				"grunt-banana-checker": "0.9.0",
 				"grunt-contrib-jshint": "1.1.0",
 				"grunt-jsonlint": "1.0.7",
@@ -433,7 +433,7 @@
 		"node_modules/array-each": {
 			"version": "1.0.1",
 			"resolved": "https://registry.npmjs.org/array-each/-/array-each-1.0.1.tgz",
-			"integrity": "sha1-p5SvDAWrF1KEbudTofIRoFugxE8=",
+			"integrity": "sha512-zHjL5SZa68hkKHBFBK6DJCTtr9sfTCPCaph/L7tMSLcTFgy+zX7E+6q5UArbtOtMBCtxdICpfTCspRse+ywyXA==",
 			"dev": true,
 			"engines": {
 				"node": ">=0.10.0"
@@ -1494,9 +1494,9 @@
 			}
 		},
 		"node_modules/grunt": {
-			"version": "1.4.0",
-			"resolved": "https://registry.npmjs.org/grunt/-/grunt-1.4.0.tgz",
-			"integrity": "sha512-yRFc0GVCDu9yxqOFzpuXQ2pEdgtLDnFv5Qz54jfIcNnpJ8Z7B7P7kPkT4VMuRvm+N+QOsI8C4v/Q0DSaoj3LgQ==",
+			"version": "1.5.3",
+			"resolved": "https://registry.npmjs.org/grunt/-/grunt-1.5.3.tgz",
+			"integrity": "sha512-mKwmo4X2d8/4c/BmcOETHek675uOqw0RuA/zy12jaspWqvTp4+ZeQF1W+OTpcbncnaBsfbQJ6l0l4j+Sn/GmaQ==",
 			"dev": true,
 			"dependencies": {
 				"dateformat": "~3.0.3",
@@ -1504,8 +1504,8 @@
 				"exit": "~0.1.2",
 				"findup-sync": "~0.3.0",
 				"glob": "~7.1.6",
-				"grunt-cli": "~1.4.2",
-				"grunt-known-options": "~1.1.1",
+				"grunt-cli": "~1.4.3",
+				"grunt-known-options": "~2.0.0",
 				"grunt-legacy-log": "~3.0.0",
 				"grunt-legacy-util": "~2.0.1",
 				"iconv-lite": "~0.4.13",
@@ -1534,6 +1534,38 @@
 				"node": ">=8"
 			}
 		},
+		"node_modules/grunt-cli": {
+			"version": "1.4.3",
+			"resolved": "https://registry.npmjs.org/grunt-cli/-/grunt-cli-1.4.3.tgz",
+			"integrity": "sha512-9Dtx/AhVeB4LYzsViCjUQkd0Kw0McN2gYpdmGYKtE2a5Yt7v1Q+HYZVWhqXc/kGnxlMtqKDxSwotiGeFmkrCoQ==",
+			"dev": true,
+			"dependencies": {
+				"grunt-known-options": "~2.0.0",
+				"interpret": "~1.1.0",
+				"liftup": "~3.0.1",
+				"nopt": "~4.0.1",
+				"v8flags": "~3.2.0"
+			},
+			"bin": {
+				"grunt": "bin/grunt"
+			},
+			"engines": {
+				"node": ">=10"
+			}
+		},
+		"node_modules/grunt-cli/node_modules/nopt": {
+			"version": "4.0.3",
+			"resolved": "https://registry.npmjs.org/nopt/-/nopt-4.0.3.tgz",
+			"integrity": "sha512-CvaGwVMztSMJLOeXPrez7fyfObdZqNUK1cPAEzLHrTybIua9pMdmmPR5YwtfNftIOMv3DPUhFaxsZMNTQO20Kg==",
+			"dev": true,
+			"dependencies": {
+				"abbrev": "1",
+				"osenv": "^0.1.4"
+			},
+			"bin": {
+				"nopt": "bin/nopt.js"
+			}
+		},
 		"node_modules/grunt-contrib-jshint": {
 			"version": "1.1.0",
 			"resolved": "https://registry.npmjs.org/grunt-contrib-jshint/-/grunt-contrib-jshint-1.1.0.tgz",
@@ -1602,9 +1634,9 @@
 			}
 		},
 		"node_modules/grunt-known-options": {
-			"version": "1.1.1",
-			"resolved": "https://registry.npmjs.org/grunt-known-options/-/grunt-known-options-1.1.1.tgz",
-			"integrity": "sha512-cHwsLqoighpu7TuYj5RonnEuxGVFnztcUqTqp5rXFGYL4OuPFofwC4Ycg7n9fYwvK6F5WbYgeVOwph9Crs2fsQ==",
+			"version": "2.0.0",
+			"resolved": "https://registry.npmjs.org/grunt-known-options/-/grunt-known-options-2.0.0.tgz",
+			"integrity": "sha512-GD7cTz0I4SAede1/+pAbmJRG44zFLPipVtdL9o3vqx9IEyb7b4/Y3s7r6ofI3CchR5GvYJ+8buCSioDv5dQLiA==",
 			"dev": true,
 			"engines": {
 				"node": ">=0.10.0"
@@ -1815,38 +1847,6 @@
 				"node": ">=8"
 			}
 		},
-		"node_modules/grunt/node_modules/grunt-cli": {
-			"version": "1.4.2",
-			"resolved": "https://registry.npmjs.org/grunt-cli/-/grunt-cli-1.4.2.tgz",
-			"integrity": "sha512-wsu6BZh7KCnfeaSkDrKIAvOlqGKxNRTZjc8xfZlvxCByQIqUfZ31kh5uHpPnhQ4NdVgvaWaVxa1LUbVU80nACw==",
-			"dev": true,
-			"dependencies": {
-				"grunt-known-options": "~1.1.1",
-				"interpret": "~1.1.0",
-				"liftup": "~3.0.1",
-				"nopt": "~4.0.1",
-				"v8flags": "~3.2.0"
-			},
-			"bin": {
-				"grunt": "bin/grunt"
-			},
-			"engines": {
-				"node": ">=10"
-			}
-		},
-		"node_modules/grunt/node_modules/grunt-cli/node_modules/nopt": {
-			"version": "4.0.3",
-			"resolved": "https://registry.npmjs.org/nopt/-/nopt-4.0.3.tgz",
-			"integrity": "sha512-CvaGwVMztSMJLOeXPrez7fyfObdZqNUK1cPAEzLHrTybIua9pMdmmPR5YwtfNftIOMv3DPUhFaxsZMNTQO20Kg==",
-			"dev": true,
-			"dependencies": {
-				"abbrev": "1",
-				"osenv": "^0.1.4"
-			},
-			"bin": {
-				"nopt": "bin/nopt.js"
-			}
-		},
 		"node_modules/grunt/node_modules/mkdirp": {
 			"version": "1.0.4",
 			"resolved": "https://registry.npmjs.org/mkdirp/-/mkdirp-1.0.4.tgz",
@@ -2120,12 +2120,15 @@
 			}
 		},
 		"node_modules/is-core-module": {
-			"version": "2.4.0",
-			"resolved": "https://registry.npmjs.org/is-core-module/-/is-core-module-2.4.0.tgz",
-			"integrity": "sha512-6A2fkfq1rfeQZjxrZJGerpLCTHRNEBiSgnu0+obeJpEPZRUooHgsizvzv0ZjJwOz3iWIHdJtVWJ/tmPr3D21/A==",
+			"version": "2.9.0",
+			"resolved": "https://registry.npmjs.org/is-core-module/-/is-core-module-2.9.0.tgz",
+			"integrity": "sha512-+5FPy5PnwmO3lvfMb0AsoPaBG+5KHUI0wYFXOtYPnVVVspTFUuMZNfNaNVRt3FZadstu2c8x23vykRW/NBoU6A==",
 			"dev": true,
 			"dependencies": {
 				"has": "^1.0.3"
+			},
+			"funding": {
+				"url": "https://github.com/sponsors/ljharb"
 			}
 		},
 		"node_modules/is-decimal": {
@@ -2458,16 +2461,6 @@
 				"node": ">= 8"
 			}
 		},
-		"node_modules/liftup/node_modules/resolve": {
-			"version": "1.20.0",
-			"resolved": "https://registry.npmjs.org/resolve/-/resolve-1.20.0.tgz",
-			"integrity": "sha512-wENBPt4ySzg4ybFQW2TT1zMQucPK95HSh/nq2CFTZVOGut2+pQvSsgtda4d26YrYcr067wjbmzOG8byDPBX63A==",
-			"dev": true,
-			"dependencies": {
-				"is-core-module": "^2.2.0",
-				"path-parse": "^1.0.6"
-			}
-		},
 		"node_modules/lines-and-columns": {
 			"version": "1.1.6",
 			"resolved": "https://registry.npmjs.org/lines-and-columns/-/lines-and-columns-1.1.6.tgz",
@@ -2829,16 +2822,6 @@
 				"node": ">=10"
 			}
 		},
-		"node_modules/normalize-package-data/node_modules/resolve": {
-			"version": "1.20.0",
-			"resolved": "https://registry.npmjs.org/resolve/-/resolve-1.20.0.tgz",
-			"integrity": "sha512-wENBPt4ySzg4ybFQW2TT1zMQucPK95HSh/nq2CFTZVOGut2+pQvSsgtda4d26YrYcr067wjbmzOG8byDPBX63A==",
-			"dev": true,
-			"dependencies": {
-				"is-core-module": "^2.2.0",
-				"path-parse": "^1.0.6"
-			}
-		},
 		"node_modules/normalize-package-data/node_modules/semver": {
 			"version": "7.3.5",
 			"resolved": "https://registry.npmjs.org/semver/-/semver-7.3.5.tgz",
@@ -3425,9 +3408,9 @@
 			}
 		},
 		"node_modules/rechoir": {
-			"version": "0.7.0",
-			"resolved": "https://registry.npmjs.org/rechoir/-/rechoir-0.7.0.tgz",
-			"integrity": "sha512-ADsDEH2bvbjltXEP+hTIAmeFekTFK0V2BTxMkok6qILyAJEXV0AFfoWcAq4yfll5VdIMd/RVXq0lR+wQi5ZU3Q==",
+			"version": "0.7.1",
+			"resolved": "https://registry.npmjs.org/rechoir/-/rechoir-0.7.1.tgz",
+			"integrity": "sha512-/njmZ8s1wVeR6pjTZ+0nCnv8SpZNRMT2D1RLOJQESlYFDBvwpTA4KWJpZ+sBJ4+vhjILRcK7JIFdGCdxEAAitg==",
 			"dev": true,
 			"dependencies": {
 				"resolve": "^1.9.0"
@@ -3506,12 +3489,20 @@
 			}
 		},
 		"node_modules/resolve": {
-			"version": "1.14.2",
-			"resolved": "https://registry.npmjs.org/resolve/-/resolve-1.14.2.tgz",
-			"integrity": "sha512-EjlOBLBO1kxsUxsKjLt7TAECyKW6fOh1VRkykQkKGzcBbjjPIxBqGh0jf7GJ3k/f5mxMqW3htMD3WdTUVtW8HQ==",
+			"version": "1.22.0",
+			"resolved": "https://registry.npmjs.org/resolve/-/resolve-1.22.0.tgz",
+			"integrity": "sha512-Hhtrw0nLeSrFQ7phPp4OOcVjLPIeMnRlr5mcnVuMe7M/7eBn98A3hmFRLoFo3DLZkivSYwhRUJTyPyWAk56WLw==",
 			"dev": true,
 			"dependencies": {
-				"path-parse": "^1.0.6"
+				"is-core-module": "^2.8.1",
+				"path-parse": "^1.0.7",
+				"supports-preserve-symlinks-flag": "^1.0.0"
+			},
+			"bin": {
+				"resolve": "bin/resolve"
+			},
+			"funding": {
+				"url": "https://github.com/sponsors/ljharb"
 			}
 		},
 		"node_modules/resolve-dir": {
@@ -4010,6 +4001,18 @@
 				"node": ">=4"
 			}
 		},
+		"node_modules/supports-preserve-symlinks-flag": {
+			"version": "1.0.0",
+			"resolved": "https://registry.npmjs.org/supports-preserve-symlinks-flag/-/supports-preserve-symlinks-flag-1.0.0.tgz",
+			"integrity": "sha512-ot0WnXS9fgdkgIcePe6RHNk1WA8+muPa6cSjeR3V8K27q9BB1rTE3R1p7Hv0z1ZyAc8s6Vvv8DIyWf681MAt0w==",
+			"dev": true,
+			"engines": {
+				"node": ">= 0.4"
+			},
+			"funding": {
+				"url": "https://github.com/sponsors/ljharb"
+			}
+		},
 		"node_modules/svg-tags": {
 			"version": "1.0.0",
 			"resolved": "https://registry.npmjs.org/svg-tags/-/svg-tags-1.0.0.tgz",
@@ -4833,7 +4836,7 @@
 		"array-each": {
 			"version": "1.0.1",
 			"resolved": "https://registry.npmjs.org/array-each/-/array-each-1.0.1.tgz",
-			"integrity": "sha1-p5SvDAWrF1KEbudTofIRoFugxE8=",
+			"integrity": "sha512-zHjL5SZa68hkKHBFBK6DJCTtr9sfTCPCaph/L7tMSLcTFgy+zX7E+6q5UArbtOtMBCtxdICpfTCspRse+ywyXA==",
 			"dev": true
 		},
 		"array-slice": {
@@ -5704,9 +5707,9 @@
 			}
 		},
 		"grunt": {
-			"version": "1.4.0",
-			"resolved": "https://registry.npmjs.org/grunt/-/grunt-1.4.0.tgz",
-			"integrity": "sha512-yRFc0GVCDu9yxqOFzpuXQ2pEdgtLDnFv5Qz54jfIcNnpJ8Z7B7P7kPkT4VMuRvm+N+QOsI8C4v/Q0DSaoj3LgQ==",
+			"version": "1.5.3",
+			"resolved": "https://registry.npmjs.org/grunt/-/grunt-1.5.3.tgz",
+			"integrity": "sha512-mKwmo4X2d8/4c/BmcOETHek675uOqw0RuA/zy12jaspWqvTp4+ZeQF1W+OTpcbncnaBsfbQJ6l0l4j+Sn/GmaQ==",
 			"dev": true,
 			"requires": {
 				"dateformat": "~3.0.3",
@@ -5714,8 +5717,8 @@
 				"exit": "~0.1.2",
 				"findup-sync": "~0.3.0",
 				"glob": "~7.1.6",
-				"grunt-cli": "~1.4.2",
-				"grunt-known-options": "~1.1.1",
+				"grunt-cli": "~1.4.3",
+				"grunt-known-options": "~2.0.0",
 				"grunt-legacy-log": "~3.0.0",
 				"grunt-legacy-util": "~2.0.1",
 				"iconv-lite": "~0.4.13",
@@ -5726,31 +5729,6 @@
 				"rimraf": "~3.0.2"
 			},
 			"dependencies": {
-				"grunt-cli": {
-					"version": "1.4.2",
-					"resolved": "https://registry.npmjs.org/grunt-cli/-/grunt-cli-1.4.2.tgz",
-					"integrity": "sha512-wsu6BZh7KCnfeaSkDrKIAvOlqGKxNRTZjc8xfZlvxCByQIqUfZ31kh5uHpPnhQ4NdVgvaWaVxa1LUbVU80nACw==",
-					"dev": true,
-					"requires": {
-						"grunt-known-options": "~1.1.1",
-						"interpret": "~1.1.0",
-						"liftup": "~3.0.1",
-						"nopt": "~4.0.1",
-						"v8flags": "~3.2.0"
-					},
-					"dependencies": {
-						"nopt": {
-							"version": "4.0.3",
-							"resolved": "https://registry.npmjs.org/nopt/-/nopt-4.0.3.tgz",
-							"integrity": "sha512-CvaGwVMztSMJLOeXPrez7fyfObdZqNUK1cPAEzLHrTybIua9pMdmmPR5YwtfNftIOMv3DPUhFaxsZMNTQO20Kg==",
-							"dev": true,
-							"requires": {
-								"abbrev": "1",
-								"osenv": "^0.1.4"
-							}
-						}
-					}
-				},
 				"mkdirp": {
 					"version": "1.0.4",
 					"resolved": "https://registry.npmjs.org/mkdirp/-/mkdirp-1.0.4.tgz",
@@ -5774,6 +5752,31 @@
 			"integrity": "sha512-SqPiB6OazWqR8USL0NymtuT5Br3mD9WBBsM1rHC/3wIi2SrZNM6/+j9CIeuEM5oCn+AtO2Y0+rzzFyOdC9afAg==",
 			"dev": true
 		},
+		"grunt-cli": {
+			"version": "1.4.3",
+			"resolved": "https://registry.npmjs.org/grunt-cli/-/grunt-cli-1.4.3.tgz",
+			"integrity": "sha512-9Dtx/AhVeB4LYzsViCjUQkd0Kw0McN2gYpdmGYKtE2a5Yt7v1Q+HYZVWhqXc/kGnxlMtqKDxSwotiGeFmkrCoQ==",
+			"dev": true,
+			"requires": {
+				"grunt-known-options": "~2.0.0",
+				"interpret": "~1.1.0",
+				"liftup": "~3.0.1",
+				"nopt": "~4.0.1",
+				"v8flags": "~3.2.0"
+			},
+			"dependencies": {
+				"nopt": {
+					"version": "4.0.3",
+					"resolved": "https://registry.npmjs.org/nopt/-/nopt-4.0.3.tgz",
+					"integrity": "sha512-CvaGwVMztSMJLOeXPrez7fyfObdZqNUK1cPAEzLHrTybIua9pMdmmPR5YwtfNftIOMv3DPUhFaxsZMNTQO20Kg==",
+					"dev": true,
+					"requires": {
+						"abbrev": "1",
+						"osenv": "^0.1.4"
+					}
+				}
+			}
+		},
 		"grunt-contrib-jshint": {
 			"version": "1.1.0",
 			"resolved": "https://registry.npmjs.org/grunt-contrib-jshint/-/grunt-contrib-jshint-1.1.0.tgz",
@@ -5831,9 +5834,9 @@
 			}
 		},
 		"grunt-known-options": {
-			"version": "1.1.1",
-			"resolved": "https://registry.npmjs.org/grunt-known-options/-/grunt-known-options-1.1.1.tgz",
-			"integrity": "sha512-cHwsLqoighpu7TuYj5RonnEuxGVFnztcUqTqp5rXFGYL4OuPFofwC4Ycg7n9fYwvK6F5WbYgeVOwph9Crs2fsQ==",
+			"version": "2.0.0",
+			"resolved": "https://registry.npmjs.org/grunt-known-options/-/grunt-known-options-2.0.0.tgz",
+			"integrity": "sha512-GD7cTz0I4SAede1/+pAbmJRG44zFLPipVtdL9o3vqx9IEyb7b4/Y3s7r6ofI3CchR5GvYJ+8buCSioDv5dQLiA==",
 			"dev": true
 		},
 		"grunt-legacy-log": {
@@ -6199,9 +6202,9 @@
 			"dev": true
 		},
 		"is-core-module": {
-			"version": "2.4.0",
-			"resolved": "https://registry.npmjs.org/is-core-module/-/is-core-module-2.4.0.tgz",
-			"integrity": "sha512-6A2fkfq1rfeQZjxrZJGerpLCTHRNEBiSgnu0+obeJpEPZRUooHgsizvzv0ZjJwOz3iWIHdJtVWJ/tmPr3D21/A==",
+			"version": "2.9.0",
+			"resolved": "https://registry.npmjs.org/is-core-module/-/is-core-module-2.9.0.tgz",
+			"integrity": "sha512-+5FPy5PnwmO3lvfMb0AsoPaBG+5KHUI0wYFXOtYPnVVVspTFUuMZNfNaNVRt3FZadstu2c8x23vykRW/NBoU6A==",
 			"dev": true,
 			"requires": {
 				"has": "^1.0.3"
@@ -6469,16 +6472,6 @@
 						"micromatch": "^4.0.2",
 						"resolve-dir": "^1.0.1"
 					}
-				},
-				"resolve": {
-					"version": "1.20.0",
-					"resolved": "https://registry.npmjs.org/resolve/-/resolve-1.20.0.tgz",
-					"integrity": "sha512-wENBPt4ySzg4ybFQW2TT1zMQucPK95HSh/nq2CFTZVOGut2+pQvSsgtda4d26YrYcr067wjbmzOG8byDPBX63A==",
-					"dev": true,
-					"requires": {
-						"is-core-module": "^2.2.0",
-						"path-parse": "^1.0.6"
-					}
 				}
 			}
 		},
@@ -6780,16 +6773,6 @@
 				"validate-npm-package-license": "^3.0.1"
 			},
 			"dependencies": {
-				"resolve": {
-					"version": "1.20.0",
-					"resolved": "https://registry.npmjs.org/resolve/-/resolve-1.20.0.tgz",
-					"integrity": "sha512-wENBPt4ySzg4ybFQW2TT1zMQucPK95HSh/nq2CFTZVOGut2+pQvSsgtda4d26YrYcr067wjbmzOG8byDPBX63A==",
-					"dev": true,
-					"requires": {
-						"is-core-module": "^2.2.0",
-						"path-parse": "^1.0.6"
-					}
-				},
 				"semver": {
 					"version": "7.3.5",
 					"resolved": "https://registry.npmjs.org/semver/-/semver-7.3.5.tgz",
@@ -7274,9 +7257,9 @@
 			}
 		},
 		"rechoir": {
-			"version": "0.7.0",
-			"resolved": "https://registry.npmjs.org/rechoir/-/rechoir-0.7.0.tgz",
-			"integrity": "sha512-ADsDEH2bvbjltXEP+hTIAmeFekTFK0V2BTxMkok6qILyAJEXV0AFfoWcAq4yfll5VdIMd/RVXq0lR+wQi5ZU3Q==",
+			"version": "0.7.1",
+			"resolved": "https://registry.npmjs.org/rechoir/-/rechoir-0.7.1.tgz",
+			"integrity": "sha512-/njmZ8s1wVeR6pjTZ+0nCnv8SpZNRMT2D1RLOJQESlYFDBvwpTA4KWJpZ+sBJ4+vhjILRcK7JIFdGCdxEAAitg==",
 			"dev": true,
 			"requires": {
 				"resolve": "^1.9.0"
@@ -7340,12 +7323,14 @@
 			"dev": true
 		},
 		"resolve": {
-			"version": "1.14.2",
-			"resolved": "https://registry.npmjs.org/resolve/-/resolve-1.14.2.tgz",
-			"integrity": "sha512-EjlOBLBO1kxsUxsKjLt7TAECyKW6fOh1VRkykQkKGzcBbjjPIxBqGh0jf7GJ3k/f5mxMqW3htMD3WdTUVtW8HQ==",
+			"version": "1.22.0",
+			"resolved": "https://registry.npmjs.org/resolve/-/resolve-1.22.0.tgz",
+			"integrity": "sha512-Hhtrw0nLeSrFQ7phPp4OOcVjLPIeMnRlr5mcnVuMe7M/7eBn98A3hmFRLoFo3DLZkivSYwhRUJTyPyWAk56WLw==",
 			"dev": true,
 			"requires": {
-				"path-parse": "^1.0.6"
+				"is-core-module": "^2.8.1",
+				"path-parse": "^1.0.7",
+				"supports-preserve-symlinks-flag": "^1.0.0"
 			}
 		},
 		"resolve-dir": {
@@ -7765,6 +7750,12 @@
 				"has-flag": "^3.0.0"
 			}
 		},
+		"supports-preserve-symlinks-flag": {
+			"version": "1.0.0",
+			"resolved": "https://registry.npmjs.org/supports-preserve-symlinks-flag/-/supports-preserve-symlinks-flag-1.0.0.tgz",
+			"integrity": "sha512-ot0WnXS9fgdkgIcePe6RHNk1WA8+muPa6cSjeR3V8K27q9BB1rTE3R1p7Hv0z1ZyAc8s6Vvv8DIyWf681MAt0w==",
+			"dev": true
+		},
 		"svg-tags": {
 			"version": "1.0.0",
 			"resolved": "https://registry.npmjs.org/svg-tags/-/svg-tags-1.0.0.tgz",
diff --git a/package.json b/package.json
index 7ff262f..2b9742e 100644
--- a/package.json
+++ b/package.json
@@ -5,7 +5,7 @@
 		"test": "grunt test"
 	},
 	"devDependencies": {
-		"grunt": "1.4.0",
+		"grunt": "1.5.3",
 		"grunt-banana-checker": "0.9.0",
 		"grunt-contrib-jshint": "1.1.0",
 		"grunt-jsonlint": "1.0.7",
-- 
2.30.2


--- end ---

composer dependencies

Dependencies
Development dependencies

npm dependencies

Development dependencies

Logs

Source code is licensed under the AGPL.