mediawiki/extensions/CognitiveProcessDesigner (REL1_35)

sourcepatches
From fedcd64108f8e9107f97aa68d97e8d9a450927d7 Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Sun, 22 May 2022 12:00:36 +0000
Subject: [PATCH] build: Updating npm dependencies
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* grunt: 1.4.0 → 1.5.3
* nomnom: 1.8.1 → 1.8.1
  * https://github.com/advisories/GHSA-cf4h-3jhx-xvhq
* underscore: 1.6.0 → 1.6.0
  * https://github.com/advisories/GHSA-cf4h-3jhx-xvhq

Additional changes:
* Committed package-lock.json (T179229) too.

Change-Id: Ibb040b4bc5867708f7d2fb1641c14be6b0156c27
---
 package.json | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/package.json b/package.json
index ce93210..8401c12 100644
--- a/package.json
+++ b/package.json
@@ -5,7 +5,7 @@
 		"test": "grunt test"
 	},
 	"devDependencies": {
-		"grunt": "1.4.0",
+		"grunt": "1.5.3",
 		"grunt-banana-checker": "0.6.0",
 		"grunt-jsonlint": "1.1.0"
 	}
-- 
2.30.2

$ date
--- stdout ---
Sun May 22 12:00:17 UTC 2022

--- end ---
$ git clone file:///srv/git/mediawiki-extensions-CognitiveProcessDesigner.git repo --depth=1 -b REL1_35
--- stderr ---
Cloning into 'repo'...
--- stdout ---

--- end ---
$ git config user.name libraryupgrader
--- stdout ---

--- end ---
$ git config user.email tools.libraryupgrader@tools.wmflabs.org
--- stdout ---

--- end ---
$ git submodule update --init
--- stdout ---

--- end ---
$ grr init
--- stdout ---
Installed commit-msg hook.

--- end ---
$ git show-ref refs/heads/REL1_35
--- stdout ---
8dddebb655a7afa092512d41d51cfe993068f58b refs/heads/REL1_35

--- end ---
$ /usr/bin/npm i --package-lock-only
--- stdout ---

up to date, audited 116 packages in 5s

8 packages are looking for funding
  run `npm fund` for details

3 vulnerabilities (1 moderate, 2 high)

To address issues that do not require attention, run:
  npm audit fix

To address all issues, run:
  npm audit fix --force

Run `npm audit` for details.

--- end ---
$ package-lock-lint package-lock.json
--- stdout ---
Checking package-lock.json

--- end ---
Editing .gitignore to remove package-lock.json
$ /usr/bin/npm audit --json --legacy-peer-deps
--- stdout ---
{
  "auditReportVersion": 2,
  "vulnerabilities": {
    "grunt": {
      "name": "grunt",
      "severity": "moderate",
      "via": [
        {
          "source": 1070249,
          "name": "grunt",
          "dependency": "grunt",
          "title": "Path Traversal in Grunt",
          "url": "https://github.com/advisories/GHSA-j383-35pm-c5h4",
          "severity": "moderate",
          "range": "<1.5.2"
        }
      ],
      "effects": [],
      "range": "<1.5.2",
      "nodes": [
        "node_modules/grunt"
      ],
      "fixAvailable": {
        "name": "grunt",
        "version": "1.5.3",
        "isSemVerMajor": false
      }
    },
    "nomnom": {
      "name": "nomnom",
      "severity": "high",
      "via": [
        "underscore"
      ],
      "effects": [],
      "range": ">=1.6.0",
      "nodes": [
        "node_modules/nomnom"
      ],
      "fixAvailable": true
    },
    "underscore": {
      "name": "underscore",
      "severity": "high",
      "via": [
        {
          "source": 1068134,
          "name": "underscore",
          "dependency": "underscore",
          "title": "Arbitrary Code Execution in underscore",
          "url": "https://github.com/advisories/GHSA-cf4h-3jhx-xvhq",
          "severity": "high",
          "range": ">=1.3.2 <1.12.1"
        }
      ],
      "effects": [
        "nomnom"
      ],
      "range": "1.3.2 - 1.12.0",
      "nodes": [
        "node_modules/underscore"
      ],
      "fixAvailable": true
    }
  },
  "metadata": {
    "vulnerabilities": {
      "info": 0,
      "low": 0,
      "moderate": 1,
      "high": 2,
      "critical": 0,
      "total": 3
    },
    "dependencies": {
      "prod": 1,
      "dev": 115,
      "optional": 0,
      "peer": 0,
      "peerOptional": 0,
      "total": 115
    }
  }
}

--- end ---
$ /usr/bin/composer install
--- stderr ---
No lock file found. Updating dependencies instead of installing from lock file. Use composer update over composer install if you do not have a lock file.
Loading composer repositories with package information
Info from https://repo.packagist.org: #StandWithUkraine
Updating dependencies
Lock file operations: 29 installs, 0 updates, 0 removals
  - Locking composer/installers (v1.12.0)
  - Locking composer/semver (1.7.2)
  - Locking composer/spdx-licenses (1.5.6)
  - Locking composer/xdebug-handler (1.4.6)
  - Locking felixfbecker/advanced-json-rpc (v3.2.1)
  - Locking jakub-onderka/php-console-color (v0.2)
  - Locking mediawiki/mediawiki-codesniffer (v38.0.0)
  - Locking mediawiki/mediawiki-phan-config (0.9.2)
  - Locking mediawiki/minus-x (0.3.2)
  - Locking microsoft/tolerant-php-parser (v0.0.18)
  - Locking netresearch/jsonmapper (v1.6.0)
  - Locking phan/phan (2.4.9)
  - Locking php-parallel-lint/php-console-highlighter (v0.4)
  - Locking php-parallel-lint/php-parallel-lint (v1.0.0)
  - Locking phpdocumentor/reflection-common (2.2.0)
  - Locking phpdocumentor/reflection-docblock (5.3.0)
  - Locking phpdocumentor/type-resolver (1.6.1)
  - Locking psr/container (1.1.2)
  - Locking psr/log (1.1.4)
  - Locking sabre/event (5.1.4)
  - Locking squizlabs/php_codesniffer (3.6.1)
  - Locking symfony/console (v4.4.41)
  - Locking symfony/deprecation-contracts (v2.5.1)
  - Locking symfony/polyfill-ctype (v1.25.0)
  - Locking symfony/polyfill-mbstring (v1.25.0)
  - Locking symfony/polyfill-php73 (v1.25.0)
  - Locking symfony/polyfill-php80 (v1.25.0)
  - Locking symfony/service-contracts (v2.5.1)
  - Locking webmozart/assert (1.10.0)
Writing lock file
Installing dependencies from lock file (including require-dev)
Package operations: 29 installs, 0 updates, 0 removals
  - Downloading symfony/console (v4.4.41)
  - Downloading netresearch/jsonmapper (v1.6.0)
  - Downloading microsoft/tolerant-php-parser (v0.0.18)
  - Downloading phan/phan (2.4.9)
  - Downloading mediawiki/mediawiki-phan-config (0.9.2)
  - Downloading mediawiki/minus-x (0.3.2)
 0/6 [>---------------------------]   0%
 4/6 [==================>---------]  66%
 5/6 [=======================>----]  83%
 6/6 [============================] 100%  - Installing composer/installers (v1.12.0): Extracting archive
  - Installing squizlabs/php_codesniffer (3.6.1): Extracting archive
  - Installing symfony/polyfill-mbstring (v1.25.0): Extracting archive
  - Installing composer/spdx-licenses (1.5.6): Extracting archive
  - Installing composer/semver (1.7.2): Extracting archive
  - Installing mediawiki/mediawiki-codesniffer (v38.0.0): Extracting archive
  - Installing symfony/deprecation-contracts (v2.5.1): Extracting archive
  - Installing psr/container (1.1.2): Extracting archive
  - Installing symfony/service-contracts (v2.5.1): Extracting archive
  - Installing symfony/polyfill-php80 (v1.25.0): Extracting archive
  - Installing symfony/polyfill-php73 (v1.25.0): Extracting archive
  - Installing symfony/console (v4.4.41): Extracting archive
  - Installing sabre/event (5.1.4): Extracting archive
  - Installing netresearch/jsonmapper (v1.6.0): Extracting archive
  - Installing microsoft/tolerant-php-parser (v0.0.18): Extracting archive
  - Installing symfony/polyfill-ctype (v1.25.0): Extracting archive
  - Installing webmozart/assert (1.10.0): Extracting archive
  - Installing phpdocumentor/reflection-common (2.2.0): Extracting archive
  - Installing phpdocumentor/type-resolver (1.6.1): Extracting archive
  - Installing phpdocumentor/reflection-docblock (5.3.0): Extracting archive
  - Installing felixfbecker/advanced-json-rpc (v3.2.1): Extracting archive
  - Installing psr/log (1.1.4): Extracting archive
  - Installing composer/xdebug-handler (1.4.6): Extracting archive
  - Installing phan/phan (2.4.9): Extracting archive
  - Installing mediawiki/mediawiki-phan-config (0.9.2): Extracting archive
  - Installing mediawiki/minus-x (0.3.2): Extracting archive
  - Installing jakub-onderka/php-console-color (v0.2): Extracting archive
  - Installing php-parallel-lint/php-console-highlighter (v0.4): Extracting archive
  - Installing php-parallel-lint/php-parallel-lint (v1.0.0): Extracting archive
  0/19 [>---------------------------]   0%
 10/19 [==============>-------------]  52%
 18/19 [==========================>-]  94%
 19/19 [============================] 100%6 package suggestions were added by new dependencies, use `composer suggest` to see details.
Package jakub-onderka/php-console-color is abandoned, you should avoid using it. Use php-parallel-lint/php-console-color instead.
Generating autoload files
11 packages you are using are looking for funding.
Use the `composer fund` command to find out more!
--- stdout ---

--- end ---
$ /usr/bin/npm audit --json --legacy-peer-deps
--- stdout ---
{
  "auditReportVersion": 2,
  "vulnerabilities": {
    "grunt": {
      "name": "grunt",
      "severity": "moderate",
      "via": [
        {
          "source": 1070249,
          "name": "grunt",
          "dependency": "grunt",
          "title": "Path Traversal in Grunt",
          "url": "https://github.com/advisories/GHSA-j383-35pm-c5h4",
          "severity": "moderate",
          "range": "<1.5.2"
        }
      ],
      "effects": [],
      "range": "<1.5.2",
      "nodes": [
        "node_modules/grunt"
      ],
      "fixAvailable": {
        "name": "grunt",
        "version": "1.5.3",
        "isSemVerMajor": false
      }
    },
    "nomnom": {
      "name": "nomnom",
      "severity": "high",
      "via": [
        "underscore"
      ],
      "effects": [],
      "range": ">=1.6.0",
      "nodes": [
        "node_modules/nomnom"
      ],
      "fixAvailable": true
    },
    "underscore": {
      "name": "underscore",
      "severity": "high",
      "via": [
        {
          "source": 1068134,
          "name": "underscore",
          "dependency": "underscore",
          "title": "Arbitrary Code Execution in underscore",
          "url": "https://github.com/advisories/GHSA-cf4h-3jhx-xvhq",
          "severity": "high",
          "range": ">=1.3.2 <1.12.1"
        }
      ],
      "effects": [
        "nomnom"
      ],
      "range": "1.3.2 - 1.12.0",
      "nodes": [
        "node_modules/underscore"
      ],
      "fixAvailable": true
    }
  },
  "metadata": {
    "vulnerabilities": {
      "info": 0,
      "low": 0,
      "moderate": 1,
      "high": 2,
      "critical": 0,
      "total": 3
    },
    "dependencies": {
      "prod": 1,
      "dev": 115,
      "optional": 0,
      "peer": 0,
      "peerOptional": 0,
      "total": 115
    }
  }
}

--- end ---
Attempting to npm audit fix
$ /usr/bin/npm audit fix --dry-run --only=dev --json --legacy-peer-deps
--- stdout ---
{
  "added": 115,
  "removed": 0,
  "changed": 0,
  "audited": 116,
  "funding": 8,
  "audit": {
    "auditReportVersion": 2,
    "vulnerabilities": {
      "grunt": {
        "name": "grunt",
        "severity": "moderate",
        "via": [
          {
            "source": 1070249,
            "name": "grunt",
            "dependency": "grunt",
            "title": "Path Traversal in Grunt",
            "url": "https://github.com/advisories/GHSA-j383-35pm-c5h4",
            "severity": "moderate",
            "range": "<1.5.2"
          }
        ],
        "effects": [],
        "range": "<1.5.2",
        "nodes": [
          "node_modules/grunt"
        ],
        "fixAvailable": {
          "name": "grunt",
          "version": "1.5.3",
          "isSemVerMajor": false
        }
      },
      "nomnom": {
        "name": "nomnom",
        "severity": "high",
        "via": [
          "underscore"
        ],
        "effects": [],
        "range": ">=1.6.0",
        "nodes": [
          "node_modules/nomnom"
        ],
        "fixAvailable": true
      },
      "underscore": {
        "name": "underscore",
        "severity": "high",
        "via": [
          {
            "source": 1068134,
            "name": "underscore",
            "dependency": "underscore",
            "title": "Arbitrary Code Execution in underscore",
            "url": "https://github.com/advisories/GHSA-cf4h-3jhx-xvhq",
            "severity": "high",
            "range": ">=1.3.2 <1.12.1"
          }
        ],
        "effects": [
          "nomnom"
        ],
        "range": "1.3.2 - 1.12.0",
        "nodes": [
          "node_modules/underscore"
        ],
        "fixAvailable": true
      }
    },
    "metadata": {
      "vulnerabilities": {
        "info": 0,
        "low": 0,
        "moderate": 1,
        "high": 2,
        "critical": 0,
        "total": 3
      },
      "dependencies": {
        "prod": 1,
        "dev": 115,
        "optional": 0,
        "peer": 0,
        "peerOptional": 0,
        "total": 115
      }
    }
  }
}

--- end ---
{"added": 115, "removed": 0, "changed": 0, "audited": 116, "funding": 8, "audit": {"auditReportVersion": 2, "vulnerabilities": {"grunt": {"name": "grunt", "severity": "moderate", "via": [{"source": 1070249, "name": "grunt", "dependency": "grunt", "title": "Path Traversal in Grunt", "url": "https://github.com/advisories/GHSA-j383-35pm-c5h4", "severity": "moderate", "range": "<1.5.2"}], "effects": [], "range": "<1.5.2", "nodes": ["node_modules/grunt"], "fixAvailable": {"name": "grunt", "version": "1.5.3", "isSemVerMajor": false}}, "nomnom": {"name": "nomnom", "severity": "high", "via": ["underscore"], "effects": [], "range": ">=1.6.0", "nodes": ["node_modules/nomnom"], "fixAvailable": true}, "underscore": {"name": "underscore", "severity": "high", "via": [{"source": 1068134, "name": "underscore", "dependency": "underscore", "title": "Arbitrary Code Execution in underscore", "url": "https://github.com/advisories/GHSA-cf4h-3jhx-xvhq", "severity": "high", "range": ">=1.3.2 <1.12.1"}], "effects": ["nomnom"], "range": "1.3.2 - 1.12.0", "nodes": ["node_modules/underscore"], "fixAvailable": true}}, "metadata": {"vulnerabilities": {"info": 0, "low": 0, "moderate": 1, "high": 2, "critical": 0, "total": 3}, "dependencies": {"prod": 1, "dev": 115, "optional": 0, "peer": 0, "peerOptional": 0, "total": 115}}}}
{}
Upgrading n:grunt from 1.4.0 -> 1.5.3
$ /usr/bin/npm audit fix --only=dev --legacy-peer-deps
--- stderr ---
npm WARN deprecated nomnom@1.8.1: Package no longer supported. Contact support@npmjs.com for more info.
--- stdout ---

added 114 packages, and audited 115 packages in 2s

8 packages are looking for funding
  run `npm fund` for details

# npm audit report

underscore  1.3.2 - 1.12.0
Severity: high
Arbitrary Code Execution in underscore - https://github.com/advisories/GHSA-cf4h-3jhx-xvhq
fix available via `npm audit fix`
node_modules/underscore
  nomnom  >=1.6.0
  Depends on vulnerable versions of underscore
  node_modules/nomnom

2 high severity vulnerabilities

To address all issues, run:
  npm audit fix

--- end ---
$ package-lock-lint package-lock.json
--- stdout ---
Checking package-lock.json

--- end ---
Verifying that tests still pass
$ /usr/bin/npm ci
--- stderr ---
npm WARN deprecated nomnom@1.8.1: Package no longer supported. Contact support@npmjs.com for more info.
--- stdout ---

added 114 packages, and audited 115 packages in 2s

8 packages are looking for funding
  run `npm fund` for details

2 high severity vulnerabilities

To address all issues, run:
  npm audit fix

Run `npm audit` for details.

--- end ---
$ /usr/bin/npm test
--- stdout ---

> test
> grunt test

Running "jsonlint:all" (jsonlint) task
>> 58 files lint free.

Running "banana:CognitiveProcessDesigner" (banana) task
>> 63 messages checked.

Done.

--- end ---
{"1068134": {"source": 1068134, "name": "underscore", "dependency": "underscore", "title": "Arbitrary Code Execution in underscore", "url": "https://github.com/advisories/GHSA-cf4h-3jhx-xvhq", "severity": "high", "range": ">=1.3.2 <1.12.1"}}
Upgrading n:nomnom from 1.8.1 -> 1.8.1
{"1068134": {"source": 1068134, "name": "underscore", "dependency": "underscore", "title": "Arbitrary Code Execution in underscore", "url": "https://github.com/advisories/GHSA-cf4h-3jhx-xvhq", "severity": "high", "range": ">=1.3.2 <1.12.1"}}
Upgrading n:underscore from 1.6.0 -> 1.6.0
$ package-lock-lint package-lock.json
--- stdout ---
Checking package-lock.json

--- end ---
build: Updating npm dependencies

* grunt: 1.4.0 → 1.5.3
* nomnom: 1.8.1 → 1.8.1
  * https://github.com/advisories/GHSA-cf4h-3jhx-xvhq
* underscore: 1.6.0 → 1.6.0
  * https://github.com/advisories/GHSA-cf4h-3jhx-xvhq

Additional changes:
* Committed package-lock.json (T179229) too.

$ git add .
--- stdout ---

--- end ---
$ git commit -F /tmp/tmpdyy7qg_6
--- stdout ---
[REL1_35 fedcd64] build: Updating npm dependencies
 1 file changed, 1 insertion(+), 1 deletion(-)

--- end ---
$ git format-patch HEAD~1 --stdout
--- stdout ---
From fedcd64108f8e9107f97aa68d97e8d9a450927d7 Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Sun, 22 May 2022 12:00:36 +0000
Subject: [PATCH] build: Updating npm dependencies
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* grunt: 1.4.0 → 1.5.3
* nomnom: 1.8.1 → 1.8.1
  * https://github.com/advisories/GHSA-cf4h-3jhx-xvhq
* underscore: 1.6.0 → 1.6.0
  * https://github.com/advisories/GHSA-cf4h-3jhx-xvhq

Additional changes:
* Committed package-lock.json (T179229) too.

Change-Id: Ibb040b4bc5867708f7d2fb1641c14be6b0156c27
---
 package.json | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/package.json b/package.json
index ce93210..8401c12 100644
--- a/package.json
+++ b/package.json
@@ -5,7 +5,7 @@
 		"test": "grunt test"
 	},
 	"devDependencies": {
-		"grunt": "1.4.0",
+		"grunt": "1.5.3",
 		"grunt-banana-checker": "0.6.0",
 		"grunt-jsonlint": "1.1.0"
 	}
-- 
2.30.2


--- end ---

composer dependencies

Dependencies
Development dependencies

npm dependencies

Development dependencies

Logs

Source code is licensed under the AGPL.