wikimedia/slimapp: main (log #788663)

sourcepatches

This run took 12 seconds.

$ date
--- stdout ---
Fri Nov 25 05:57:41 UTC 2022

--- end ---
$ git clone file:///srv/git/wikimedia-slimapp.git repo --depth=1 -b master
--- stderr ---
Cloning into 'repo'...
--- stdout ---

--- end ---
$ git config user.name libraryupgrader
--- stdout ---

--- end ---
$ git config user.email tools.libraryupgrader@tools.wmflabs.org
--- stdout ---

--- end ---
$ git submodule update --init
--- stdout ---

--- end ---
$ grr init
--- stdout ---
Installed commit-msg hook.

--- end ---
$ git show-ref refs/heads/master
--- stdout ---
6862c8ccdd0c69ca7f44c735ab3f27b08065f6b9 refs/heads/master

--- end ---
Upgrading c:php-parallel-lint/php-parallel-lint from ~1.3 -> 1.3.2
Upgrading c:mediawiki/mediawiki-codesniffer from 38.0.0 -> 40.0.1
$ /usr/bin/composer update
--- stderr ---
Loading composer repositories with package information
Info from https://repo.packagist.org: #StandWithUkraine
Updating dependencies
Lock file operations: 1 install, 10 updates, 5 removals
  - Removing phpdocumentor/reflection-common (2.2.0)
  - Removing phpdocumentor/reflection-docblock (5.3.0)
  - Removing phpdocumentor/type-resolver (1.6.1)
  - Removing phpspec/prophecy (v1.15.0)
  - Removing webmozart/assert (1.10.0)
  - Upgrading composer/spdx-licenses (1.5.6 => 1.5.7)
  - Upgrading mediawiki/mediawiki-codesniffer (v38.0.0 => v40.0.1)
  - Upgrading phpmailer/phpmailer (v6.6.0 => v6.6.5)
  - Upgrading phpunit/php-token-stream (3.1.3 => 4.0.4)
  - Upgrading phpunit/phpunit (8.5.26 => 8.5.31)
  - Upgrading sebastian/comparator (3.0.3 => 3.0.5)
  - Upgrading sebastian/exporter (3.1.4 => 3.1.5)
  - Upgrading squizlabs/php_codesniffer (3.6.1 => 3.7.1)
  - Upgrading symfony/polyfill-ctype (v1.25.0 => v1.27.0)
  - Locking symfony/polyfill-php80 (v1.27.0)
  - Upgrading twig/twig (v1.44.6 => v1.44.7)
Writing lock file
Installing dependencies from lock file (including require-dev)
Package operations: 38 installs, 0 updates, 0 removals
    0 [>---------------------------]    0 [->--------------------------]    0 [--->------------------------]  - Installing psr/log (1.1.4): Extracting archive
  - Installing monolog/monolog (1.23.0): Extracting archive
  - Installing bd808/monolog-udp2log-handler (v1.0.1): Extracting archive
  - Installing symfony/polyfill-php80 (v1.27.0): Extracting archive
  - Installing squizlabs/php_codesniffer (3.7.1): Extracting archive
  - Installing composer/spdx-licenses (1.5.7): Extracting archive
  - Installing composer/semver (3.3.2): Extracting archive
  - Installing mediawiki/mediawiki-codesniffer (v40.0.1): Extracting archive
  - Installing php-parallel-lint/php-parallel-lint (v1.3.2): Extracting archive
  - Installing symfony/polyfill-ctype (v1.27.0): Extracting archive
  - Installing phpmailer/phpmailer (v6.6.5): Extracting archive
  - Installing phpunit/php-token-stream (4.0.4): Extracting archive
  - Installing sebastian/version (2.0.1): Extracting archive
  - Installing sebastian/type (1.1.4): Extracting archive
  - Installing sebastian/resource-operations (2.0.2): Extracting archive
  - Installing sebastian/recursion-context (3.0.1): Extracting archive
  - Installing sebastian/object-reflector (1.1.2): Extracting archive
  - Installing sebastian/object-enumerator (3.0.4): Extracting archive
  - Installing sebastian/global-state (3.0.2): Extracting archive
  - Installing sebastian/exporter (3.1.5): Extracting archive
  - Installing sebastian/environment (4.2.4): Extracting archive
  - Installing sebastian/diff (3.0.3): Extracting archive
  - Installing sebastian/comparator (3.0.5): Extracting archive
  - Installing phpunit/php-timer (2.1.3): Extracting archive
  - Installing phpunit/php-text-template (1.2.1): Extracting archive
  - Installing phpunit/php-file-iterator (2.0.5): Extracting archive
  - Installing theseer/tokenizer (1.2.1): Extracting archive
  - Installing sebastian/code-unit-reverse-lookup (1.0.2): Extracting archive
  - Installing phpunit/php-code-coverage (7.0.15): Extracting archive
  - Installing phar-io/version (3.2.1): Extracting archive
  - Installing phar-io/manifest (2.0.3): Extracting archive
  - Installing myclabs/deep-copy (1.11.0): Extracting archive
  - Installing doctrine/instantiator (1.4.1): Extracting archive
  - Installing phpunit/phpunit (8.5.31): Extracting archive
  - Installing slim/slim (2.6.3): Extracting archive
  - Installing slim/views (0.1.3): Extracting archive
  - Installing twig/twig (v1.44.7): Extracting archive
  - Installing wikimedia/simplei18n (v1.0.1): Extracting archive
  0/29 [>---------------------------]   0%
 10/29 [=========>------------------]  34%
 20/29 [===================>--------]  68%
 29/29 [============================] 100%Package slim/views is abandoned, you should avoid using it. No replacement was suggested.
Package phpunit/php-token-stream is abandoned, you should avoid using it. No replacement was suggested.
Generating autoload files
25 packages you are using are looking for funding.
Use the `composer fund` command to find out more!
--- stdout ---

--- end ---
set()
Error, invalid JSON, skipping
..W................ 19 / 19 (100%)


{"totals":{"errors":0,"warnings":1,"fixable":0},"files":{"\/src\/repo\/tests\/Auth\/PasswordTest.php":{"errors":0,"warnings":0,"messages":[]},"\/src\/repo\/tests\/ConfigTest.php":{"errors":0,"warnings":0,"messages":[]},"\/src\/repo\/tests\/FormTest.php":{"errors":0,"warnings":1,"messages":[{"message":"assertEmpty performs loose comparisons and should not be used.","source":"MediaWiki.PHPUnit.AssertEmpty.AssertEmptyUsed","severity":5,"fixable":false,"type":"WARNING","line":90,"column":16}]},"\/src\/repo\/tests\/Dao\/AbstractDaoTest.php":{"errors":0,"warnings":0,"messages":[]},"\/src\/repo\/tests\/bootstrap.php":{"errors":0,"warnings":0,"messages":[]},"\/src\/repo\/src\/Config.php":{"errors":0,"warnings":0,"messages":[]},"\/src\/repo\/src\/CsrfMiddleware.php":{"errors":0,"warnings":0,"messages":[]},"\/src\/repo\/src\/Mailer.php":{"errors":0,"warnings":0,"messages":[]},"\/src\/repo\/src\/Auth\/UserManager.php":{"errors":0,"warnings":0,"messages":[]},"\/src\/repo\/src\/Auth\/UserData.php":{"errors":0,"warnings":0,"messages":[]},"\/src\/repo\/src\/Auth\/Password.php":{"errors":0,"warnings":0,"messages":[]},"\/src\/repo\/src\/Auth\/AuthManager.php":{"errors":0,"warnings":0,"messages":[]},"\/src\/repo\/src\/AbstractApp.php":{"errors":0,"warnings":0,"messages":[]},"\/src\/repo\/src\/TwigExtension.php":{"errors":0,"warnings":0,"messages":[]},"\/src\/repo\/src\/Controller.php":{"errors":0,"warnings":0,"messages":[]},"\/src\/repo\/src\/Dao\/AbstractDao.php":{"errors":0,"warnings":0,"messages":[]},"\/src\/repo\/src\/HeaderMiddleware.php":{"errors":0,"warnings":0,"messages":[]},"\/src\/repo\/src\/Form.php":{"errors":0,"warnings":0,"messages":[]},"\/src\/repo\/src\/ParsoidClient.php":{"errors":0,"warnings":0,"messages":[]}}}

$ /usr/bin/composer install
--- stderr ---
Installing dependencies from lock file (including require-dev)
Verifying lock file contents can be installed on current platform.
Nothing to install, update or remove
Package slim/views is abandoned, you should avoid using it. No replacement was suggested.
Package phpunit/php-token-stream is abandoned, you should avoid using it. No replacement was suggested.
Generating autoload files
25 packages you are using are looking for funding.
Use the `composer fund` command to find out more!
--- stdout ---

--- end ---
$ /usr/bin/composer test
--- stderr ---
> parallel-lint . --exclude vendor
> phpunit $PHPUNIT_ARGS
> phpcs
Script phpcs handling the phpcs event returned with error code 1
Script @phpcs was called via test
--- stdout ---
PHP 7.4.30 | 10 parallel jobs
...................                                          19/19 (100 %)


Checked 19 files in 0.1 seconds
No syntax error found
PHPUnit 8.5.31 by Sebastian Bergmann and contributors.

Runtime:       PHP 7.4.30
Configuration: /src/repo/phpunit.xml.dist

................................                                  32 / 32 (100%)

Time: 112 ms, Memory: 4.00 MB

OK (32 tests, 109 assertions)
..W................ 19 / 19 (100%)



FILE: /src/repo/tests/FormTest.php
----------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
----------------------------------------------------------------------
 90 | WARNING | assertEmpty performs loose comparisons and should not
    |         | be used.
    |         | (MediaWiki.PHPUnit.AssertEmpty.AssertEmptyUsed)
----------------------------------------------------------------------

Time: 328ms; Memory: 14MB


--- end ---
Traceback (most recent call last):
  File "/venv/lib/python3.9/site-packages/runner-0.1.0-py3.9.egg/runner/__init__.py", line 1400, in main
    libup.run(args.repo, args.output, args.branch)
  File "/venv/lib/python3.9/site-packages/runner-0.1.0-py3.9.egg/runner/__init__.py", line 1339, in run
    self.composer_upgrade(plan)
  File "/venv/lib/python3.9/site-packages/runner-0.1.0-py3.9.egg/runner/__init__.py", line 876, in composer_upgrade
    self.composer_test()
  File "/venv/lib/python3.9/site-packages/runner-0.1.0-py3.9.egg/runner/__init__.py", line 297, in composer_test
    self.check_call(['composer', 'test'])
  File "/venv/lib/python3.9/site-packages/runner-0.1.0-py3.9.egg/runner/shell2.py", line 54, in check_call
    res.check_returncode()
  File "/usr/lib/python3.9/subprocess.py", line 460, in check_returncode
    raise CalledProcessError(self.returncode, self.args, self.stdout,
subprocess.CalledProcessError: Command '['/usr/bin/composer', 'test']' returned non-zero exit status 1.
Source code is licensed under the AGPL.