mediawiki/extensions/Workflows: main (log #564981)

sourcepatches

This run took 10 seconds.

From a1dd21b4976a065321c3e111f7ca432e2032fac5 Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Wed, 5 Jan 2022 14:00:44 +0000
Subject: [PATCH] [DNM] there are no updates

Change-Id: I2a55070015b7208825459445e4ad1bfa6222c4f0
---
 composer.json | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/composer.json b/composer.json
index 500ea03..6e4c44c 100644
--- a/composer.json
+++ b/composer.json
@@ -34,11 +34,12 @@
 		"test": [
 			"parallel-lint . --exclude vendor --exclude node_modules",
 			"minus-x check .",
-			"phpcs -sp"
+			"@phpcs"
 		],
 		"fix": [
 			"minus-x fix .",
 			"phpcbf"
-		]
+		],
+		"phpcs": "phpcs -sp"
 	}
 }
-- 
2.20.1

$ date
Wed Jan  5 14:00:38 UTC 2022

$ git clone file:///srv/git/mediawiki-extensions-Workflows.git repo --depth=1 -b master
Cloning into 'repo'...

$ git config user.name libraryupgrader

$ git config user.email tools.libraryupgrader@tools.wmflabs.org

$ git submodule update --init

$ grr init
Installed commit-msg hook.

$ git show-ref refs/heads/master
9f8df3eacb37ecbbfbc22a3eb265ed372d5fc254 refs/heads/master

$ composer install
Loading composer repositories with package information
Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/
Updating dependencies (including require-dev)
Package operations: 30 installs, 0 updates, 0 removals
  - Installing composer/installers (v1.12.0): Loading from cache
  - Installing mwstake/mediawiki-component-alertbanners (1.0.0): Loading from cache
  - Installing squizlabs/php_codesniffer (3.6.1): Loading from cache
  - Installing composer/spdx-licenses (1.5.6): Loading from cache
  - Installing composer/semver (3.2.7): Loading from cache
  - Installing mediawiki/mediawiki-codesniffer (v38.0.0): Loading from cache
  - Installing symfony/polyfill-mbstring (v1.24.0): Loading from cache
  - Installing symfony/polyfill-intl-normalizer (v1.24.0): Loading from cache
  - Installing symfony/polyfill-intl-grapheme (v1.24.0): Loading from cache
  - Installing symfony/polyfill-ctype (v1.24.0): Loading from cache
  - Installing symfony/polyfill-php80 (v1.24.0): Loading from cache
  - Installing symfony/string (v5.4.2): Loading from cache
  - Installing symfony/deprecation-contracts (v2.5.0): Loading from cache
  - Installing psr/container (1.1.1): Loading from cache
  - Installing symfony/service-contracts (v2.5.0): Loading from cache
  - Installing symfony/polyfill-php73 (v1.24.0): Loading from cache
  - Installing symfony/console (v5.4.2): Loading from cache
  - Installing mediawiki/minus-x (1.1.1): Loading from cache
  - Installing php-parallel-lint/php-console-color (v0.3): Loading from cache
  - Installing php-parallel-lint/php-console-highlighter (v0.5): Loading from cache
  - Installing php-parallel-lint/php-parallel-lint (v1.3.1): Loading from cache
  - Installing symfony/yaml (v5.4.2): Loading from cache
  - Installing symfony/polyfill-php81 (v1.24.0): Loading from cache
  - Installing ramsey/collection (1.2.2): Loading from cache
  - Installing brick/math (0.9.3): Loading from cache
  - Installing ramsey/uuid (4.2.3): Loading from cache
  - Installing eventsauce/eventsauce (0.8.2): Loading from cache
  - Installing mwstake/mediawiki-component-formengine (1.0.6): Loading from cache
  - Installing mwstake/mediawiki-component-notifications (1.0.2): Loading from cache
  - Installing mwstake/mediawiki-component-runjobstrigger (1.0.4): Loading from cache
symfony/service-contracts suggests installing symfony/service-implementation
symfony/console suggests installing symfony/event-dispatcher
symfony/console suggests installing symfony/lock
symfony/console suggests installing symfony/process
symfony/console suggests installing psr/log (For using the console logger)
ramsey/uuid suggests installing ext-bcmath (Enables faster math with arbitrary-precision integers using BCMath.)
ramsey/uuid suggests installing ext-uuid (Enables the use of PeclUuidTimeGenerator and PeclUuidRandomGenerator.)
ramsey/uuid suggests installing paragonie/random-lib (Provides RandomLib for use with the RandomLibAdapter)
ramsey/uuid suggests installing ramsey/uuid-doctrine (Allows the use of Ramsey\Uuid\Uuid as Doctrine field type.)
Writing lock file
Generating autoload files
19 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

$ git add .

$ git commit -F /tmp/tmpx7bclyr8
[master a1dd21b] [DNM] there are no updates
 1 file changed, 3 insertions(+), 2 deletions(-)

$ git format-patch HEAD~1 --stdout
From a1dd21b4976a065321c3e111f7ca432e2032fac5 Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Wed, 5 Jan 2022 14:00:44 +0000
Subject: [PATCH] [DNM] there are no updates

Change-Id: I2a55070015b7208825459445e4ad1bfa6222c4f0
---
 composer.json | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/composer.json b/composer.json
index 500ea03..6e4c44c 100644
--- a/composer.json
+++ b/composer.json
@@ -34,11 +34,12 @@
 		"test": [
 			"parallel-lint . --exclude vendor --exclude node_modules",
 			"minus-x check .",
-			"phpcs -sp"
+			"@phpcs"
 		],
 		"fix": [
 			"minus-x fix .",
 			"phpcbf"
-		]
+		],
+		"phpcs": "phpcs -sp"
 	}
 }
-- 
2.20.1

Source code is licensed under the AGPL.