mediawiki/tools/dependency-analysis: main (log #562647)

sourcepatches

This run took 22 seconds.

From fc456b5fdd0c89d2c5a6cb9b51910a7d99a32c88 Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Tue, 28 Dec 2021 00:00:50 +0000
Subject: [PATCH] build: Updating php-parallel-lint/php-parallel-lint to 1.3.1

Change-Id: I1f1bdf44ea86c75739c97f6711aebe1d07a2053e
---
 composer.json | 76 +++++++++++++++++++++++++--------------------------
 1 file changed, 38 insertions(+), 38 deletions(-)

diff --git a/composer.json b/composer.json
index 4b5e8ce..46482c7 100644
--- a/composer.json
+++ b/composer.json
@@ -1,40 +1,40 @@
 {
-    "name": "mediawiki/dependency-analysis",
-    "description": "Dependency analysis and report for MediaWiki.",
-    "version": "0.1",
-    "type": "project",
-    "keywords": [
-        "phpda",
-        "quality",
-        "mediawiki",
-        "dependency",
-        "cyclic",
-        "metrics"
-    ],
-    "license": "GPL-2.0-or-later",
-    "authors": [
-        {
-            "name": "Daniel Kinzler"
-        }
-    ],
-    "require": {
-        "php": ">=7.2.0",
-        "dephpend/dephpend": "~0.5",
-        "phploc/phploc": "^5",
-        "symfony/event-dispatcher": ">=4.2 <4.3"
-    },
-    "require-dev": {
-        "mediawiki/minus-x": "1.1.1",
-        "php-parallel-lint/php-parallel-lint": "1.3.0",
-        "php-parallel-lint/php-console-highlighter": "0.5.0"
-    },
-    "scripts": {
-        "test": [
-            "parallel-lint . --exclude vendor",
-            "minus-x check ."
-        ],
-         "fix": [
-            "minus-x fix ."
-        ]
-    }
+	"name": "mediawiki/dependency-analysis",
+	"description": "Dependency analysis and report for MediaWiki.",
+	"version": "0.1",
+	"type": "project",
+	"keywords": [
+		"phpda",
+		"quality",
+		"mediawiki",
+		"dependency",
+		"cyclic",
+		"metrics"
+	],
+	"license": "GPL-2.0-or-later",
+	"authors": [
+		{
+			"name": "Daniel Kinzler"
+		}
+	],
+	"require": {
+		"php": ">=7.2.0",
+		"dephpend/dephpend": "~0.5",
+		"phploc/phploc": "^5",
+		"symfony/event-dispatcher": ">=4.2 <4.3"
+	},
+	"require-dev": {
+		"mediawiki/minus-x": "1.1.1",
+		"php-parallel-lint/php-console-highlighter": "0.5.0",
+		"php-parallel-lint/php-parallel-lint": "1.3.1"
+	},
+	"scripts": {
+		"test": [
+			"parallel-lint . --exclude vendor",
+			"minus-x check ."
+		],
+		"fix": [
+			"minus-x fix ."
+		]
+	}
 }
-- 
2.20.1

$ date
Tue Dec 28 00:00:32 UTC 2021

$ git clone file:///srv/git/mediawiki-tools-dependency-analysis.git repo --depth=1 -b master
Cloning into 'repo'...

$ git config user.name libraryupgrader

$ git config user.email tools.libraryupgrader@tools.wmflabs.org

$ git submodule update --init
Submodule 'contrib/breaking_cycles_in_noisy_hierarchies' (https://github.com/zhenv5/breaking_cycles_in_noisy_hierarchies.git) registered for path 'contrib/breaking_cycles_in_noisy_hierarchies'
Cloning into '/src/repo/contrib/breaking_cycles_in_noisy_hierarchies'...
Submodule path 'contrib/breaking_cycles_in_noisy_hierarchies': checked out '10430c611825faba6d9d4c2632fdb623b725d573'

$ grr init
Installed commit-msg hook.

$ git show-ref refs/heads/master
fb1f1d26ec6f8fbb3cb369e0624e24351596a6ab refs/heads/master

$ composer install
Loading composer repositories with package information
Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/
Updating dependencies (including require-dev)
Package operations: 19 installs, 0 updates, 0 removals
  - Installing symfony/deprecation-contracts (v2.5.0): Loading from cache
  - Installing psr/container (1.1.1): Loading from cache
  - Installing psr/cache (1.0.1): Loading from cache
  - Installing symfony/contracts (v1.1.11): Loading from cache
  - Installing symfony/polyfill-php80 (v1.23.1): Loading from cache
  - Installing symfony/polyfill-mbstring (v1.23.1): Loading from cache
  - Installing symfony/console (v4.2.12): Loading from cache
  - Installing sebastian/version (2.0.1): Loading from cache
  - Installing symfony/finder (v5.4.0): Loading from cache
  - Installing theseer/fdomdocument (1.6.6): Loading from cache
  - Installing sebastian/finder-facade (1.2.3): Loading from cache
  - Installing phploc/phploc (5.0.0): Loading from cache
  - Installing mediawiki/minus-x (1.1.1): Loading from cache
  - Installing php-parallel-lint/php-parallel-lint (v1.3.0): Loading from cache
  - Installing php-parallel-lint/php-console-color (v0.3): Loading from cache
  - Installing php-parallel-lint/php-console-highlighter (v0.5): Loading from cache
  - Installing symfony/event-dispatcher (v4.2.12): Loading from cache
  - Installing nikic/php-parser (v4.13.2): Loading from cache
  - Installing dephpend/dephpend (0.8.1): Loading from cache
symfony/contracts suggests installing psr/event-dispatcher (When using the EventDispatcher contracts)
symfony/contracts suggests installing symfony/cache-implementation
symfony/contracts suggests installing symfony/event-dispatcher-implementation
symfony/contracts suggests installing symfony/http-client-implementation
symfony/contracts suggests installing symfony/service-implementation
symfony/contracts suggests installing symfony/translation-implementation
symfony/console suggests installing symfony/lock
symfony/console suggests installing symfony/process
symfony/console suggests installing psr/log (For using the console logger)
symfony/event-dispatcher suggests installing symfony/dependency-injection
symfony/event-dispatcher suggests installing symfony/http-kernel
Package sebastian/finder-facade is abandoned, you should avoid using it. No replacement was suggested.
Writing lock file
Generating autoload files
5 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

Upgrading c:php-parallel-lint/php-parallel-lint from 1.3.0 -> 1.3.1
$ composer update
Loading composer repositories with package information
Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/
Updating dependencies (including require-dev)
Package operations: 0 installs, 1 update, 0 removals
  - Updating php-parallel-lint/php-parallel-lint (v1.3.0 => v1.3.1): Loading from cache
Package sebastian/finder-facade is abandoned, you should avoid using it. No replacement was suggested.
Writing lock file
Generating autoload files
5 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

$ composer install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Nothing to install or update
Package sebastian/finder-facade is abandoned, you should avoid using it. No replacement was suggested.
Generating autoload files
5 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

$ composer test
> parallel-lint . --exclude vendor
PHP 7.3.29 | 10 parallel jobs
.                                                            1/1 (100 %)


Checked 1 files in 0 seconds
No syntax error found
> minus-x check .
MinusX
======
Processing /src/repo...
...................
All good!

$ git add .

$ git commit -F /tmp/tmpizgfdp51
[master fc456b5] build: Updating php-parallel-lint/php-parallel-lint to 1.3.1
 1 file changed, 40 insertions(+), 40 deletions(-)
 rewrite composer.json (99%)

$ git format-patch HEAD~1 --stdout
From fc456b5fdd0c89d2c5a6cb9b51910a7d99a32c88 Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Tue, 28 Dec 2021 00:00:50 +0000
Subject: [PATCH] build: Updating php-parallel-lint/php-parallel-lint to 1.3.1

Change-Id: I1f1bdf44ea86c75739c97f6711aebe1d07a2053e
---
 composer.json | 76 +++++++++++++++++++++++++--------------------------
 1 file changed, 38 insertions(+), 38 deletions(-)

diff --git a/composer.json b/composer.json
index 4b5e8ce..46482c7 100644
--- a/composer.json
+++ b/composer.json
@@ -1,40 +1,40 @@
 {
-    "name": "mediawiki/dependency-analysis",
-    "description": "Dependency analysis and report for MediaWiki.",
-    "version": "0.1",
-    "type": "project",
-    "keywords": [
-        "phpda",
-        "quality",
-        "mediawiki",
-        "dependency",
-        "cyclic",
-        "metrics"
-    ],
-    "license": "GPL-2.0-or-later",
-    "authors": [
-        {
-            "name": "Daniel Kinzler"
-        }
-    ],
-    "require": {
-        "php": ">=7.2.0",
-        "dephpend/dephpend": "~0.5",
-        "phploc/phploc": "^5",
-        "symfony/event-dispatcher": ">=4.2 <4.3"
-    },
-    "require-dev": {
-        "mediawiki/minus-x": "1.1.1",
-        "php-parallel-lint/php-parallel-lint": "1.3.0",
-        "php-parallel-lint/php-console-highlighter": "0.5.0"
-    },
-    "scripts": {
-        "test": [
-            "parallel-lint . --exclude vendor",
-            "minus-x check ."
-        ],
-         "fix": [
-            "minus-x fix ."
-        ]
-    }
+	"name": "mediawiki/dependency-analysis",
+	"description": "Dependency analysis and report for MediaWiki.",
+	"version": "0.1",
+	"type": "project",
+	"keywords": [
+		"phpda",
+		"quality",
+		"mediawiki",
+		"dependency",
+		"cyclic",
+		"metrics"
+	],
+	"license": "GPL-2.0-or-later",
+	"authors": [
+		{
+			"name": "Daniel Kinzler"
+		}
+	],
+	"require": {
+		"php": ">=7.2.0",
+		"dephpend/dephpend": "~0.5",
+		"phploc/phploc": "^5",
+		"symfony/event-dispatcher": ">=4.2 <4.3"
+	},
+	"require-dev": {
+		"mediawiki/minus-x": "1.1.1",
+		"php-parallel-lint/php-console-highlighter": "0.5.0",
+		"php-parallel-lint/php-parallel-lint": "1.3.1"
+	},
+	"scripts": {
+		"test": [
+			"parallel-lint . --exclude vendor",
+			"minus-x check ."
+		],
+		"fix": [
+			"minus-x fix ."
+		]
+	}
 }
-- 
2.20.1

Source code is licensed under the AGPL.