mediawiki/extensions/Mailgun: main (log #530205)

sourcepatches

This run took 16 seconds.

From 20bece8fedf179e7409e8b906de134b4b844896d Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Mon, 8 Nov 2021 07:11:18 +0000
Subject: [PATCH] build: Updating php-parallel-lint/php-console-highlighter to
 0.5.0

Change-Id: I18f1f00121300df05551332b05bb38ba4f445faf
---
 composer.json | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/composer.json b/composer.json
index fe4a436..fd51cf3 100644
--- a/composer.json
+++ b/composer.json
@@ -9,7 +9,7 @@
 	"require-dev": {
 		"mediawiki/mediawiki-codesniffer": "38.0.0",
 		"mediawiki/minus-x": "1.1.1",
-		"php-parallel-lint/php-console-highlighter": "0.3.2",
+		"php-parallel-lint/php-console-highlighter": "0.5.0",
 		"php-parallel-lint/php-parallel-lint": "1.3.1"
 	},
 	"scripts": {
-- 
2.20.1

$ date
Mon Nov  8 07:11:05 UTC 2021

$ git clone file:///srv/git/mediawiki-extensions-Mailgun.git repo --depth=1 -b master
Cloning into 'repo'...

$ git config user.name libraryupgrader

$ git config user.email tools.libraryupgrader@tools.wmflabs.org

$ git submodule update --init

$ grr init
Installed commit-msg hook.

$ git show-ref refs/heads/master
28bd47353015c9c0fbaad9342bca444c465a0b92 refs/heads/master

$ composer install
Loading composer repositories with package information
Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/
Updating dependencies (including require-dev)
Package operations: 34 installs, 0 updates, 0 removals
  - Installing symfony/polyfill-ctype (v1.23.0): Loading from cache
  - Installing webmozart/assert (1.10.0): Loading from cache
  - Installing psr/http-message (1.0.1): Loading from cache
  - Installing psr/http-client (1.0.1): Loading from cache
  - Installing php-http/discovery (1.14.1): Loading from cache
  - Installing php-http/message-factory (v1.0.2): Loading from cache
  - Installing psr/http-factory (1.0.1): Loading from cache
  - Installing php-http/multipart-stream-builder (1.2.0): Loading from cache
  - Installing symfony/polyfill-php80 (v1.23.1): Loading from cache
  - Installing symfony/polyfill-php73 (v1.23.0): Loading from cache
  - Installing symfony/deprecation-contracts (v2.4.0): Loading from cache
  - Installing symfony/options-resolver (v5.3.7): Loading from cache
  - Installing clue/stream-filter (v1.5.0): Loading from cache
  - Installing php-http/message (1.12.0): Loading from cache
  - Installing php-http/promise (1.1.0): Loading from cache
  - Installing php-http/httplug (2.2.0): Loading from cache
  - Installing php-http/client-common (2.4.0): Loading from cache
  - Installing mailgun/mailgun-php (v3.5.1): Loading from cache
  - Installing squizlabs/php_codesniffer (3.6.1): Loading from cache
  - Installing composer/spdx-licenses (1.5.5): Loading from cache
  - Installing composer/semver (3.2.6): Loading from cache
  - Installing mediawiki/mediawiki-codesniffer (v38.0.0): Loading from cache
  - Installing symfony/polyfill-mbstring (v1.23.1): Loading from cache
  - Installing symfony/polyfill-intl-normalizer (v1.23.0): Loading from cache
  - Installing symfony/polyfill-intl-grapheme (v1.23.1): Loading from cache
  - Installing symfony/string (v5.3.10): Loading from cache
  - Installing psr/container (1.1.1): Loading from cache
  - Installing symfony/service-contracts (v2.4.0): Loading from cache
  - Installing symfony/console (v5.3.10): Loading from cache
  - Installing mediawiki/minus-x (1.1.1): Loading from cache
  - Installing jakub-onderka/php-console-color (v0.2): Loading from cache
  - Installing php-parallel-lint/php-console-highlighter (v0.3.2): Loading from cache
  - Installing php-parallel-lint/php-parallel-lint (v1.3.1): Loading from cache
  - Installing nyholm/psr7 (1.4.1): Loading from cache
php-http/message suggests installing guzzlehttp/psr7 (Used with Guzzle PSR-7 Factories)
php-http/message suggests installing laminas/laminas-diactoros (Used with Diactoros Factories)
php-http/message suggests installing slim/slim (Used with Slim Framework PSR-7 implementation)
php-http/client-common suggests installing php-http/logger-plugin (PSR-3 Logger plugin)
php-http/client-common suggests installing php-http/cache-plugin (PSR-6 Cache plugin)
php-http/client-common suggests installing php-http/stopwatch-plugin (Symfony Stopwatch plugin)
mailgun/mailgun-php suggests installing guzzlehttp/psr7 (PSR-7 message implementation that also provides common utility methods)
mailgun/mailgun-php suggests installing php-http/curl-client (cURL client for PHP-HTTP)
symfony/service-contracts suggests installing symfony/service-implementation
symfony/console suggests installing psr/log (For using the console logger)
symfony/console suggests installing symfony/event-dispatcher
symfony/console suggests installing symfony/lock
symfony/console suggests installing symfony/process
Package jakub-onderka/php-console-color is abandoned, you should avoid using it. Use php-parallel-lint/php-console-color instead.
Writing lock file
Generating autoload files
15 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

Upgrading c:php-parallel-lint/php-console-highlighter from 0.3.2 -> 0.5.0
$ composer update
Loading composer repositories with package information
Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/
Updating dependencies (including require-dev)
Package operations: 0 installs, 2 updates, 0 removals
  - Updating php-parallel-lint/php-console-color (v0.2 => v0.3): Loading from cache
  - Updating php-parallel-lint/php-console-highlighter (v0.3.2 => v0.5): Loading from cache
Writing lock file
Generating autoload files
15 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

$ composer install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Nothing to install or update
Generating autoload files
15 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

$ composer test
> parallel-lint . --exclude vendor --exclude node_modules
PHP 7.3.29 | 10 parallel jobs
...                                                          3/3 (100 %)


Checked 3 files in 0 seconds
No syntax error found
> minus-x check .
MinusX
======
Processing /src/repo...
............................................
All good!
> phpcs -sp --cache
... 3 / 3 (100%)


Time: 112ms; Memory: 12MB


$ package-lock-lint package-lock.json
Checking package-lock.json

$ git add .

$ git commit -F /tmp/tmpljset81n
[master 20bece8] build: Updating php-parallel-lint/php-console-highlighter to 0.5.0
 1 file changed, 1 insertion(+), 1 deletion(-)

$ git format-patch HEAD~1 --stdout
From 20bece8fedf179e7409e8b906de134b4b844896d Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Mon, 8 Nov 2021 07:11:18 +0000
Subject: [PATCH] build: Updating php-parallel-lint/php-console-highlighter to
 0.5.0

Change-Id: I18f1f00121300df05551332b05bb38ba4f445faf
---
 composer.json | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/composer.json b/composer.json
index fe4a436..fd51cf3 100644
--- a/composer.json
+++ b/composer.json
@@ -9,7 +9,7 @@
 	"require-dev": {
 		"mediawiki/mediawiki-codesniffer": "38.0.0",
 		"mediawiki/minus-x": "1.1.1",
-		"php-parallel-lint/php-console-highlighter": "0.3.2",
+		"php-parallel-lint/php-console-highlighter": "0.5.0",
 		"php-parallel-lint/php-parallel-lint": "1.3.1"
 	},
 	"scripts": {
-- 
2.20.1

Source code is licensed under the AGPL.