unicodejs: main (log #319220)

sourcepatches

This run took 51 seconds.

From 85067adc16f8ff6aa4c850325fccc5237641ac04 Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Fri, 11 Jun 2021 03:13:37 +0000
Subject: [PATCH] build: Updating npm dependencies
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* ws: 7.4.5 → 7.4.6
  * https://npmjs.com/advisories/1748 (CVE-2021-32640)
* glob-parent: 5.1.1 → 5.1.2
  * https://npmjs.com/advisories/1751 (CVE-2020-28469)

Change-Id: Ib22829e040b38eedafc74ff28b445be09eacdb60
---
 package-lock.json | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/package-lock.json b/package-lock.json
index db17986..2b78071 100644
--- a/package-lock.json
+++ b/package-lock.json
@@ -1713,9 +1713,9 @@
 			}
 		},
 		"glob-parent": {
-			"version": "5.1.1",
-			"resolved": "https://registry.npmjs.org/glob-parent/-/glob-parent-5.1.1.tgz",
-			"integrity": "sha512-FnI+VGOpnlGHWZxthPGR+QhR78fuiK0sNLkHQv+bL9fQi57lNNdquIbna/WrfROrolq8GK5Ek6BiMwqL/voRYQ==",
+			"version": "5.1.2",
+			"resolved": "https://registry.npmjs.org/glob-parent/-/glob-parent-5.1.2.tgz",
+			"integrity": "sha512-AOIgSQCepiJYwP3ARnGx+5VnTu2HBYdzbGP45eLw1vr3zB3vZLeyed1sC9hnbcOc9/SrMyM5RPQrkGz4aS9Zow==",
 			"dev": true,
 			"requires": {
 				"is-glob": "^4.0.1"
@@ -3717,9 +3717,9 @@
 			"dev": true
 		},
 		"ws": {
-			"version": "7.4.5",
-			"resolved": "https://registry.npmjs.org/ws/-/ws-7.4.5.tgz",
-			"integrity": "sha512-xzyu3hFvomRfXKH8vOFMU3OguG6oOvhXMo3xsGy3xWExqaM2dxBbVxuD99O7m3ZUFMvvscsZDqxfgMaRr/Nr1g==",
+			"version": "7.4.6",
+			"resolved": "https://registry.npmjs.org/ws/-/ws-7.4.6.tgz",
+			"integrity": "sha512-YmhHDO4MzaDLB+M9ym/mDA5z0naX8j7SIlT8f8z+I0VtzsRbekxEutHSme7NPS2qE8StCYQNUnfWdXta/Yu85A==",
 			"dev": true
 		},
 		"y18n": {
-- 
2.20.1

$ date
Fri Jun 11 03:12:49 UTC 2021

$ git clone file:///srv/git/unicodejs.git repo --depth=1 -b master
Cloning into 'repo'...

$ git config user.name libraryupgrader

$ git config user.email tools.libraryupgrader@tools.wmflabs.org

$ git submodule update --init

$ grr init
Installed commit-msg hook.

$ git show-ref refs/heads/master
9e481fd1a03da0e3c2783848c8faa076c4e3d769 refs/heads/master

Attempting to npm audit fix
$ npm audit fix --only=dev

> core-js@3.10.1 postinstall /src/repo/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library!

The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 
> https://opencollective.com/core-js 
> https://www.patreon.com/zloirock 

Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -)

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

added 435 packages from 989 contributors in 10.447s

42 packages are looking for funding
  run `npm fund` for details

fixed 4 of 4 vulnerabilities in 436 scanned packages

$ npm audit fix --only=dev
npm WARN grunt-karma@4.0.0 requires a peer of karma@^4.0.0 || ^5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

up to date in 2.387s

42 packages are looking for funding
  run `npm fund` for details

fixed 0 of 0 vulnerabilities in 436 scanned packages

$ npm audit fix --only=dev
npm WARN grunt-karma@4.0.0 requires a peer of karma@^4.0.0 || ^5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

up to date in 2.386s

42 packages are looking for funding
  run `npm fund` for details

fixed 0 of 0 vulnerabilities in 436 scanned packages

$ package-lock-lint package-lock.json
0 issues found in: package-lock.json

Verifying that tests still pass
$ npm ci
npm WARN prepare removing existing node_modules/ before installation

> core-js@3.10.1 postinstall /src/repo/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

added 436 packages in 9.031s

$ npm test

> unicodejs@13.0.3 test /src/repo
> grunt test

Running "set-meta" task

Running "set-dev" task

Running "clean:dist" (clean) task
>> 0 paths cleaned.

Running "concat:all" (concat) task

Running "copy:dist" (copy) task
Copied 4 files

Running "eslint:all" (eslint) task

Running "karma:chrome" (karma) task
11 06 2021 03:13:30.273:WARN [karma-server]: Passing raw CLI options to `new Server(config, done)` is deprecated. Use `parseConfig(configFilePath, cliOptions, {promiseConfig: true, throwErrors: true})` to prepare a processed `Config` instance and pass that as the `config` argument instead.
11 06 2021 03:13:31.473:INFO [karma-server]: Karma v6.3.2 server started at http://localhost:9876/
11 06 2021 03:13:31.474:INFO [launcher]: Launching browsers ChromeCustom with concurrency unlimited
11 06 2021 03:13:31.484:INFO [launcher]: Starting browser ChromeHeadless
11 06 2021 03:13:32.367:INFO [Chrome Headless 90.0.4430.212 (Linux x86_64)]: Connected on socket 0cmjeuyDB3iTy2j0AAAB with id 60698637
.........
Chrome Headless 90.0.4430.212 (Linux x86_64): Executed 9 of 9 SUCCESS (0.193 secs / 0.173 secs)

=============================== Coverage summary ===============================
Statements   : 100% ( 252/252 )
Branches     : 100% ( 238/238 )
Functions    : 100% ( 25/25 )
Lines        : 100% ( 250/250 )
================================================================================

Running "karma:firefox" (karma) task
11 06 2021 03:13:32.900:WARN [karma-server]: Passing raw CLI options to `new Server(config, done)` is deprecated. Use `parseConfig(configFilePath, cliOptions, {promiseConfig: true, throwErrors: true})` to prepare a processed `Config` instance and pass that as the `config` argument instead.
11 06 2021 03:13:33.363:INFO [karma-server]: Karma v6.3.2 server started at http://localhost:9876/
11 06 2021 03:13:33.363:INFO [launcher]: Launching browsers FirefoxHeadless with concurrency unlimited
11 06 2021 03:13:33.365:INFO [launcher]: Starting browser FirefoxHeadless
11 06 2021 03:13:35.983:INFO [Firefox 78.0 (Linux x86_64)]: Connected on socket BvWuNUaLII-ETgY4AAAD with id 51821463
.........
Firefox 78.0 (Linux x86_64): Executed 9 of 9 SUCCESS (0.41 secs / 0.315 secs)

=============================== Coverage summary ===============================
Statements   : 100% ( 252/252 )
Branches     : 100% ( 238/238 )
Functions    : 100% ( 25/25 )
Lines        : 100% ( 250/250 )
================================================================================

Done.

Upgrading n:ws from 7.4.5 -> 7.4.6
Upgrading n:glob-parent from 5.1.1 -> 5.1.2
$ package-lock-lint package-lock.json
0 issues found in: package-lock.json

$ git add .

$ git commit -F /tmp/tmp71ya8bnr
[master 85067ad] build: Updating npm dependencies
 1 file changed, 6 insertions(+), 6 deletions(-)

$ git format-patch HEAD~1 --stdout
From 85067adc16f8ff6aa4c850325fccc5237641ac04 Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Fri, 11 Jun 2021 03:13:37 +0000
Subject: [PATCH] build: Updating npm dependencies
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* ws: 7.4.5 → 7.4.6
  * https://npmjs.com/advisories/1748 (CVE-2021-32640)
* glob-parent: 5.1.1 → 5.1.2
  * https://npmjs.com/advisories/1751 (CVE-2020-28469)

Change-Id: Ib22829e040b38eedafc74ff28b445be09eacdb60
---
 package-lock.json | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/package-lock.json b/package-lock.json
index db17986..2b78071 100644
--- a/package-lock.json
+++ b/package-lock.json
@@ -1713,9 +1713,9 @@
 			}
 		},
 		"glob-parent": {
-			"version": "5.1.1",
-			"resolved": "https://registry.npmjs.org/glob-parent/-/glob-parent-5.1.1.tgz",
-			"integrity": "sha512-FnI+VGOpnlGHWZxthPGR+QhR78fuiK0sNLkHQv+bL9fQi57lNNdquIbna/WrfROrolq8GK5Ek6BiMwqL/voRYQ==",
+			"version": "5.1.2",
+			"resolved": "https://registry.npmjs.org/glob-parent/-/glob-parent-5.1.2.tgz",
+			"integrity": "sha512-AOIgSQCepiJYwP3ARnGx+5VnTu2HBYdzbGP45eLw1vr3zB3vZLeyed1sC9hnbcOc9/SrMyM5RPQrkGz4aS9Zow==",
 			"dev": true,
 			"requires": {
 				"is-glob": "^4.0.1"
@@ -3717,9 +3717,9 @@
 			"dev": true
 		},
 		"ws": {
-			"version": "7.4.5",
-			"resolved": "https://registry.npmjs.org/ws/-/ws-7.4.5.tgz",
-			"integrity": "sha512-xzyu3hFvomRfXKH8vOFMU3OguG6oOvhXMo3xsGy3xWExqaM2dxBbVxuD99O7m3ZUFMvvscsZDqxfgMaRr/Nr1g==",
+			"version": "7.4.6",
+			"resolved": "https://registry.npmjs.org/ws/-/ws-7.4.6.tgz",
+			"integrity": "sha512-YmhHDO4MzaDLB+M9ym/mDA5z0naX8j7SIlT8f8z+I0VtzsRbekxEutHSme7NPS2qE8StCYQNUnfWdXta/Yu85A==",
 			"dev": true
 		},
 		"y18n": {
-- 
2.20.1

Source code is licensed under the AGPL.