mediawiki/extensions/Wikibase: REL1_36 (log #318814)

sourcepatches

This run took 2800 seconds.

$ date
Thu Jun 10 22:15:30 UTC 2021

$ git clone file:///srv/git/mediawiki-extensions-Wikibase.git repo --depth=1 -b REL1_36
Cloning into 'repo'...

$ git config user.name libraryupgrader

$ git config user.email tools.libraryupgrader@tools.wmflabs.org

$ git submodule update --init
Submodule 'lib/resources/wikibase-api' (https://gerrit.wikimedia.org/r/wikibase/javascript-api) registered for path 'lib/resources/wikibase-api'
Submodule 'view/lib/wikibase-data-model' (https://phabricator.wikimedia.org/source/wikibase-data-model.git) registered for path 'view/lib/wikibase-data-model'
Submodule 'view/lib/wikibase-data-values' (https://phabricator.wikimedia.org/source/datavalues-javascript.git) registered for path 'view/lib/wikibase-data-values'
Submodule 'view/lib/wikibase-data-values-value-view' (https://gerrit.wikimedia.org/r/data-values/value-view) registered for path 'view/lib/wikibase-data-values-value-view'
Submodule 'view/lib/wikibase-serialization' (https://phabricator.wikimedia.org/source/wikibase-serialization.git) registered for path 'view/lib/wikibase-serialization'
Submodule 'view/lib/wikibase-termbox' (https://gerrit.wikimedia.org/r/wikibase/termbox) registered for path 'view/lib/wikibase-termbox'
Cloning into '/src/repo/lib/resources/wikibase-api'...
Cloning into '/src/repo/view/lib/wikibase-data-model'...
Cloning into '/src/repo/view/lib/wikibase-data-values-value-view'...
Cloning into '/src/repo/view/lib/wikibase-data-values'...
Cloning into '/src/repo/view/lib/wikibase-termbox'...
Cloning into '/src/repo/view/lib/wikibase-serialization'...
Submodule path 'lib/resources/wikibase-api': checked out '2bdd34cbe4c31cf67f0bf72d968c289209ff6cc8'
Submodule path 'view/lib/wikibase-data-model': checked out 'b284d2e8d204d86515ebadd9b3fbe1b26e786099'
Submodule path 'view/lib/wikibase-data-values': checked out '59086c58bdb1b95a1c653b9cc4b7c1ebf69f117c'
Submodule path 'view/lib/wikibase-data-values-value-view': checked out '6cf115362f22024d5dd5549ce3c3a3e9bbef5b03'
Submodule path 'view/lib/wikibase-serialization': checked out '6b97c0fea57a217f95cea3f18cee80d9ce30f69d'
Submodule path 'view/lib/wikibase-termbox': checked out 'e969fbba1ad9cd7c349c4dada72fc0c862067544'

$ grr init
Installed commit-msg hook.

$ git show-ref refs/heads/REL1_36
134f67d1e3c1e3b6c8dad2735b5be9a31eb51fcb refs/heads/REL1_36

$ composer install
Loading composer repositories with package information
Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/
Updating dependencies (including require-dev)
Package operations: 57 installs, 0 updates, 0 removals
  - Installing composer/installers (v1.11.0): Loading from cache
  - Installing squizlabs/php_codesniffer (3.5.8): Loading from cache
  - Installing dealerdirect/phpcodesniffer-composer-installer (v0.7.1): Loading from cache
  - Installing wikimedia/purtle (v1.0.7): Loading from cache
  - Installing wikimedia/timestamp (v3.0.0): Loading from cache
  - Installing psr/simple-cache (1.0.1): Loading from cache
  - Installing psr/http-message (1.0.1): Loading from cache
  - Installing composer/spdx-licenses (1.5.5): Loading from cache
  - Installing composer/semver (3.2.5): Loading from cache
  - Installing mediawiki/mediawiki-codesniffer (v35.0.0): Loading from cache
  - Installing symfony/polyfill-php80 (v1.23.0): Loading from cache
  - Installing symfony/polyfill-mbstring (v1.23.0): Loading from cache
  - Installing symfony/polyfill-intl-normalizer (v1.23.0): Loading from cache
  - Installing symfony/polyfill-intl-grapheme (v1.23.0): Loading from cache
  - Installing symfony/polyfill-ctype (v1.23.0): Loading from cache
  - Installing symfony/string (v5.3.0): Loading from cache
  - Installing psr/container (1.1.1): Loading from cache
  - Installing symfony/service-contracts (v2.4.0): Loading from cache
  - Installing symfony/polyfill-php73 (v1.23.0): Loading from cache
  - Installing symfony/deprecation-contracts (v2.4.0): Loading from cache
  - Installing symfony/console (v5.3.0): Loading from cache
  - Installing psr/log (1.1.4): Loading from cache
  - Installing sabre/event (5.1.2): Loading from cache
  - Installing netresearch/jsonmapper (v2.1.0): Loading from cache
  - Installing microsoft/tolerant-php-parser (v0.0.23): Loading from cache
  - Installing phpdocumentor/reflection-common (2.2.0): Loading from cache
  - Installing webmozart/assert (1.10.0): Loading from cache
  - Installing phpdocumentor/type-resolver (1.4.0): Loading from cache
  - Installing phpdocumentor/reflection-docblock (5.2.2): Loading from cache
  - Installing felixfbecker/advanced-json-rpc (v3.2.0): Loading from cache
  - Installing composer/xdebug-handler (1.4.6): Loading from cache
  - Installing phan/phan (3.2.6): Loading from cache
  - Installing mediawiki/phan-taint-check-plugin (3.2.1): Loading from cache
  - Installing mediawiki/mediawiki-phan-config (0.10.6): Loading from cache
  - Installing mediawiki/minus-x (1.1.0): Loading from cache
  - Installing php-parallel-lint/php-console-color (v0.3): Loading from cache
  - Installing php-parallel-lint/php-console-highlighter (v0.5): Loading from cache
  - Installing php-parallel-lint/php-parallel-lint (v1.2.0): Loading from cache
  - Installing data-values/interfaces (0.2.5): Loading from cache
  - Installing data-values/data-values (2.3.0): Loading from cache
  - Installing data-values/geo (4.3.0): Loading from cache
  - Installing data-values/common (0.4.3): Loading from cache
  - Installing data-values/number (0.11.1): Downloading (connecting...)Downloading (100%)         
  - Installing data-values/time (1.0.3): Loading from cache
  - Installing serialization/serialization (4.0.0): Loading from cache
  - Installing data-values/serialization (1.2.4): Loading from cache
  - Installing monolog/monolog (2.2.0): Loading from cache
  - Installing wikimedia/assert (v0.5.0): Loading from cache
  - Installing wikibase/data-model (9.6.1): Loading from cache
  - Installing wikibase/data-model-serialization (2.9.1): Loading from cache
  - Installing wikibase/internal-serialization (2.10.0): Loading from cache
  - Installing diff/diff (3.2.0): Loading from cache
  - Installing wikibase/data-model-services (5.4.0): Loading from cache
  - Installing wikimedia/at-ease (v2.1.0): Loading from cache
  - Installing onoi/message-reporter (1.4.2): Loading from cache
  - Installing phpstan/phpdoc-parser (0.4.9): Loading from cache
  - Installing slevomat/coding-standard (6.4.1): Loading from cache
symfony/service-contracts suggests installing symfony/service-implementation
symfony/console suggests installing symfony/event-dispatcher
symfony/console suggests installing symfony/lock
symfony/console suggests installing symfony/process
phan/phan suggests installing ext-ast (Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is needed, 1.0.8+ is recommended.)
monolog/monolog suggests installing graylog2/gelf-php (Allow sending log messages to a GrayLog2 server)
monolog/monolog suggests installing doctrine/couchdb (Allow sending log messages to a CouchDB server)
monolog/monolog suggests installing ruflin/elastica (Allow sending log messages to an Elastic Search server)
monolog/monolog suggests installing elasticsearch/elasticsearch (Allow sending log messages to an Elasticsearch server via official client)
monolog/monolog suggests installing php-amqplib/php-amqplib (Allow sending log messages to an AMQP server using php-amqplib)
monolog/monolog suggests installing ext-amqp (Allow sending log messages to an AMQP server (1.0+ required))
monolog/monolog suggests installing ext-mongodb (Allow sending log messages to a MongoDB server (via driver))
monolog/monolog suggests installing mongodb/mongodb (Allow sending log messages to a MongoDB server (via library))
monolog/monolog suggests installing aws/aws-sdk-php (Allow sending log messages to AWS services like DynamoDB)
monolog/monolog suggests installing rollbar/rollbar (Allow sending log messages to Rollbar)
monolog/monolog suggests installing php-console/php-console (Allow sending log messages to Google Chrome)
Writing lock file
Generating autoload files
18 packages you are using are looking for funding.
Use the `composer fund` command to find out more!
PHP CodeSniffer Config installed_paths set to ../../mediawiki/mediawiki-codesniffer,../../slevomat/coding-standard

$ npm install
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated har-validator@5.1.5: this library is no longer supported

> fibers@4.0.3 install /src/repo/node_modules/fibers
> node build.js || nodejs build.js

`linux-x64-64-glibc` exists; testing
Binary is fine; exiting

> Wikibase@0.1.0 postinstall /src/repo
> npm-run-all -p install:*


> Wikibase@0.1.0 install:tainted-ref /src/repo
> npm --prefix view/lib/wikibase-tainted-ref ci


> Wikibase@0.1.0 install:bridge /src/repo
> npm --prefix client/data-bridge ci


> core-js@3.6.5 postinstall /src/repo/client/data-bridge/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library!

The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 
> https://opencollective.com/core-js 
> https://www.patreon.com/zloirock 

Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -)


> node-sass@4.14.1 install /src/repo/client/data-bridge/node_modules/node-sass
> node scripts/install.js


> core-js@2.6.11 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

Cached binary found at /cache/_cacache/node-sass/4.14.1/linux-x64-64_binding.node

> node-sass@4.14.1 postinstall /src/repo/client/data-bridge/node_modules/node-sass
> node scripts/build.js


> node-sass@4.14.1 install /src/repo/view/lib/wikibase-tainted-ref/node_modules/node-sass
> node scripts/install.js

Binary found at /src/repo/client/data-bridge/node_modules/node-sass/vendor/linux-x64-64/binding.node
Testing binary
Binary is fine

> fibers_node_v8@3.1.5 preinstall /src/repo/client/data-bridge/node_modules/fibers_node_v8
> node preinstall.js


> fibers_node_v8@3.1.5 install /src/repo/client/data-bridge/node_modules/fibers_node_v8
> node build.js

Cached binary found at /cache/_cacache/node-sass/4.14.1/linux-x64-64_binding.node

> node-sass@4.14.1 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/node-sass
> node scripts/build.js

ignore install

> fibers@4.0.3 install /src/repo/client/data-bridge/node_modules/fibers
> node build.js || nodejs build.js

Binary found at /src/repo/view/lib/wikibase-tainted-ref/node_modules/node-sass/vendor/linux-x64-64/binding.node
Testing binary
`linux-x64-64-glibc` exists; testing
Binary is fine

> fsevents@1.2.9 install /src/repo/view/lib/wikibase-tainted-ref/node_modules/fsevents
> node install

Binary is fine; exiting

> ejs@3.1.3 postinstall /src/repo/client/data-bridge/node_modules/@wdio/cli/node_modules/ejs
> node --harmony ./postinstall.js


> fibers@4.0.3 install /src/repo/view/lib/wikibase-tainted-ref/node_modules/fibers
> node build.js || nodejs build.js

Thank you for installing EJS: built with the Jake JavaScript build tool (https://jakejs.com/)


> fsevents@1.2.13 install /src/repo/client/data-bridge/node_modules/fsevents
> node install.js

`linux-x64-64-glibc` exists; testing

Skipping 'fsevents' build as platform linux is not supported

> ejs@2.7.4 postinstall /src/repo/client/data-bridge/node_modules/ejs
> node ./postinstall.js

Binary is fine; exiting

> fibers_node_v8@3.1.5 preinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/fibers_node_v8
> node preinstall.js

Thank you for installing EJS: built with the Jake JavaScript build tool (https://jakejs.com/)


> fibers_node_v8@3.1.5 install /src/repo/view/lib/wikibase-tainted-ref/node_modules/fibers_node_v8
> node build.js


> core-js@2.6.11 postinstall /src/repo/client/data-bridge/node_modules/babel-runtime/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

ignore install

> ejs@3.1.3 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@wdio/cli/node_modules/ejs
> node --harmony ./postinstall.js


> deasync@0.1.20 install /src/repo/client/data-bridge/node_modules/deasync
> node ./build.js

Thank you for installing EJS: built with the Jake JavaScript build tool (https://jakejs.com/)


> ejs@2.7.4 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/ejs
> node ./postinstall.js

`linux-x64-node-10` exists; testing
Thank you for installing EJS: built with the Jake JavaScript build tool (https://jakejs.com/)

Binary is fine; exiting

> deasync@0.1.20 install /src/repo/view/lib/wikibase-tainted-ref/node_modules/deasync
> node ./build.js


> yorkie@2.0.0 install /src/repo/client/data-bridge/node_modules/yorkie
> node bin/install.js

`linux-x64-node-10` exists; testing
setting up Git hooks
can't find .git directory, skipping Git hooks installation

> core-js-pure@3.9.1 postinstall /src/repo/client/data-bridge/node_modules/core-js-pure
> node -e "try{require('./postinstall')}catch(e){}"

Binary is fine; exiting

> yorkie@2.0.0 install /src/repo/view/lib/wikibase-tainted-ref/node_modules/yorkie
> node bin/install.js


> data-bridge@0.1.0 prepare /src/repo/client/data-bridge
> node build/wikimedia-ui-base.js

setting up Git hooks
can't find .git directory, skipping Git hooks installation

> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/api/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

added 3666 packages in 69.929s

> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/theming/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/client-logger/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/router/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/core-events/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/channels/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/addons/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/vue/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/lazy-universal-dotenv/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> ejs@2.7.4 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/core/node_modules/ejs
> node ./postinstall.js

Thank you for installing EJS: built with the Jake JavaScript build tool (https://jakejs.com/)


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/core/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/simplebar/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/components/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js-pure@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/core-js-pure
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/ui/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/node-logger/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/channel-postmessage/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/client-api/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/addon-links/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/addon-actions/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/addon-a11y/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> tainted-ref@0.1.0 prepare /src/repo/view/lib/wikibase-tainted-ref
> node build/wikimedia-ui-base.js

added 3262 packages in 88.759s
npm notice created a lockfile as package-lock.json. You should commit this file.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@~2.3.1 (node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN wdio-wikibase@4.0.1 requires a peer of mwbot@^1.0.10 but none is installed. You must install peer dependencies yourself.
npm WARN eslint-plugin-vue@6.2.2 requires a peer of eslint@^5.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.

added 1374 packages from 860 contributors and audited 1377 packages in 806.906s

129 packages are looking for funding
  run `npm fund` for details

found 7 moderate severity vulnerabilities
  run `npm audit fix` to fix them, or `npm audit` for details

$ package-lock-lint package-lock.json
0 issues found in: package-lock.json

Upgrading n:grunt from 1.3.0 -> 1.4.0
$ npm install

> Wikibase@0.1.0 postinstall /src/repo
> npm-run-all -p install:*


> Wikibase@0.1.0 install:bridge /src/repo
> npm --prefix client/data-bridge ci


> Wikibase@0.1.0 install:tainted-ref /src/repo
> npm --prefix view/lib/wikibase-tainted-ref ci

npm WARN prepare removing existing node_modules/ before installation
npm WARN prepare removing existing node_modules/ before installation

> core-js@3.6.5 postinstall /src/repo/client/data-bridge/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library!

The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 
> https://opencollective.com/core-js 
> https://www.patreon.com/zloirock 

Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -)


> node-sass@4.14.1 install /src/repo/client/data-bridge/node_modules/node-sass
> node scripts/install.js


> core-js@2.6.11 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

Cached binary found at /cache/_cacache/node-sass/4.14.1/linux-x64-64_binding.node

> node-sass@4.14.1 postinstall /src/repo/client/data-bridge/node_modules/node-sass
> node scripts/build.js

Binary found at /src/repo/client/data-bridge/node_modules/node-sass/vendor/linux-x64-64/binding.node
Testing binary

> node-sass@4.14.1 install /src/repo/view/lib/wikibase-tainted-ref/node_modules/node-sass
> node scripts/install.js

Binary is fine

> fibers_node_v8@3.1.5 preinstall /src/repo/client/data-bridge/node_modules/fibers_node_v8
> node preinstall.js


> fibers_node_v8@3.1.5 install /src/repo/client/data-bridge/node_modules/fibers_node_v8
> node build.js

Cached binary found at /cache/_cacache/node-sass/4.14.1/linux-x64-64_binding.node

> node-sass@4.14.1 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/node-sass
> node scripts/build.js

ignore install

> fibers@4.0.3 install /src/repo/client/data-bridge/node_modules/fibers
> node build.js || nodejs build.js

Binary found at /src/repo/view/lib/wikibase-tainted-ref/node_modules/node-sass/vendor/linux-x64-64/binding.node
Testing binary
`linux-x64-64-glibc` exists; testing
Binary is fine

> fsevents@1.2.9 install /src/repo/view/lib/wikibase-tainted-ref/node_modules/fsevents
> node install

Binary is fine; exiting

> ejs@3.1.3 postinstall /src/repo/client/data-bridge/node_modules/@wdio/cli/node_modules/ejs
> node --harmony ./postinstall.js


> fibers@4.0.3 install /src/repo/view/lib/wikibase-tainted-ref/node_modules/fibers
> node build.js || nodejs build.js

Thank you for installing EJS: built with the Jake JavaScript build tool (https://jakejs.com/)


> fsevents@1.2.13 install /src/repo/client/data-bridge/node_modules/fsevents
> node install.js

`linux-x64-64-glibc` exists; testing

Skipping 'fsevents' build as platform linux is not supported
Binary is fine; exiting

> fibers_node_v8@3.1.5 preinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/fibers_node_v8
> node preinstall.js


> ejs@2.7.4 postinstall /src/repo/client/data-bridge/node_modules/ejs
> node ./postinstall.js

Thank you for installing EJS: built with the Jake JavaScript build tool (https://jakejs.com/)


> fibers_node_v8@3.1.5 install /src/repo/view/lib/wikibase-tainted-ref/node_modules/fibers_node_v8
> node build.js


> core-js@2.6.11 postinstall /src/repo/client/data-bridge/node_modules/babel-runtime/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

ignore install

> ejs@3.1.3 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@wdio/cli/node_modules/ejs
> node --harmony ./postinstall.js


> deasync@0.1.20 install /src/repo/client/data-bridge/node_modules/deasync
> node ./build.js

Thank you for installing EJS: built with the Jake JavaScript build tool (https://jakejs.com/)

`linux-x64-node-10` exists; testing

> ejs@2.7.4 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/ejs
> node ./postinstall.js

Thank you for installing EJS: built with the Jake JavaScript build tool (https://jakejs.com/)

Binary is fine; exiting

> yorkie@2.0.0 install /src/repo/client/data-bridge/node_modules/yorkie
> node bin/install.js


> deasync@0.1.20 install /src/repo/view/lib/wikibase-tainted-ref/node_modules/deasync
> node ./build.js

setting up Git hooks
can't find .git directory, skipping Git hooks installation
`linux-x64-node-10` exists; testing
Binary is fine; exiting

> core-js-pure@3.9.1 postinstall /src/repo/client/data-bridge/node_modules/core-js-pure
> node -e "try{require('./postinstall')}catch(e){}"


> yorkie@2.0.0 install /src/repo/view/lib/wikibase-tainted-ref/node_modules/yorkie
> node bin/install.js

setting up Git hooks
can't find .git directory, skipping Git hooks installation

> data-bridge@0.1.0 prepare /src/repo/client/data-bridge
> node build/wikimedia-ui-base.js


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/api/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/theming/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

added 3666 packages in 467.78s

> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/client-logger/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/router/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/core-events/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/channels/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/addons/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/vue/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/lazy-universal-dotenv/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> ejs@2.7.4 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/core/node_modules/ejs
> node ./postinstall.js

Thank you for installing EJS: built with the Jake JavaScript build tool (https://jakejs.com/)


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/core/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/simplebar/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/components/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js-pure@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/core-js-pure
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/ui/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/node-logger/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/channel-postmessage/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/client-api/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/addon-links/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/addon-actions/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/addon-a11y/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> tainted-ref@0.1.0 prepare /src/repo/view/lib/wikibase-tainted-ref
> node build/wikimedia-ui-base.js

added 3262 packages in 480.118s
npm WARN eslint-plugin-vue@6.2.2 requires a peer of eslint@^5.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN wdio-wikibase@4.0.1 requires a peer of mwbot@^1.0.10 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.3.2 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

added 3 packages from 6 contributors, removed 97 packages, updated 4 packages and audited 1283 packages in 605.444s

129 packages are looking for funding
  run `npm fund` for details

found 7 moderate severity vulnerabilities
  run `npm audit fix` to fix them, or `npm audit` for details

$ package-lock-lint package-lock.json
0 issues found in: package-lock.json

$ npm ci
npm WARN prepare removing existing node_modules/ before installation

> fibers@4.0.3 install /src/repo/node_modules/fibers
> node build.js || nodejs build.js

`linux-x64-64-glibc` exists; testing
Binary is fine; exiting

> Wikibase@0.1.0 postinstall /src/repo
> npm-run-all -p install:*


> Wikibase@0.1.0 install:tainted-ref /src/repo
> npm --prefix view/lib/wikibase-tainted-ref ci


> Wikibase@0.1.0 install:bridge /src/repo
> npm --prefix client/data-bridge ci

npm WARN prepare removing existing node_modules/ before installation
npm WARN prepare removing existing node_modules/ before installation

> core-js@3.6.5 postinstall /src/repo/client/data-bridge/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library!

The project needs your help! Please consider supporting of core-js on Open Collective or Patreon: 
> https://opencollective.com/core-js 
> https://www.patreon.com/zloirock 

Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -)


> node-sass@4.14.1 install /src/repo/client/data-bridge/node_modules/node-sass
> node scripts/install.js

Cached binary found at /cache/_cacache/node-sass/4.14.1/linux-x64-64_binding.node

> node-sass@4.14.1 postinstall /src/repo/client/data-bridge/node_modules/node-sass
> node scripts/build.js

Binary found at /src/repo/client/data-bridge/node_modules/node-sass/vendor/linux-x64-64/binding.node
Testing binary
Binary is fine

> fibers_node_v8@3.1.5 preinstall /src/repo/client/data-bridge/node_modules/fibers_node_v8
> node preinstall.js


> fibers_node_v8@3.1.5 install /src/repo/client/data-bridge/node_modules/fibers_node_v8
> node build.js

ignore install

> fibers@4.0.3 install /src/repo/client/data-bridge/node_modules/fibers
> node build.js || nodejs build.js

`linux-x64-64-glibc` exists; testing
Binary is fine; exiting

> ejs@3.1.3 postinstall /src/repo/client/data-bridge/node_modules/@wdio/cli/node_modules/ejs
> node --harmony ./postinstall.js

Thank you for installing EJS: built with the Jake JavaScript build tool (https://jakejs.com/)


> fsevents@1.2.13 install /src/repo/client/data-bridge/node_modules/fsevents
> node install.js


Skipping 'fsevents' build as platform linux is not supported

> ejs@2.7.4 postinstall /src/repo/client/data-bridge/node_modules/ejs
> node ./postinstall.js

Thank you for installing EJS: built with the Jake JavaScript build tool (https://jakejs.com/)


> core-js@2.6.11 postinstall /src/repo/client/data-bridge/node_modules/babel-runtime/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> deasync@0.1.20 install /src/repo/client/data-bridge/node_modules/deasync
> node ./build.js

`linux-x64-node-10` exists; testing
Binary is fine; exiting

> yorkie@2.0.0 install /src/repo/client/data-bridge/node_modules/yorkie
> node bin/install.js


> core-js@2.6.11 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"

setting up Git hooks
can't find .git directory, skipping Git hooks installation

> core-js-pure@3.9.1 postinstall /src/repo/client/data-bridge/node_modules/core-js-pure
> node -e "try{require('./postinstall')}catch(e){}"


> node-sass@4.14.1 install /src/repo/view/lib/wikibase-tainted-ref/node_modules/node-sass
> node scripts/install.js

Cached binary found at /cache/_cacache/node-sass/4.14.1/linux-x64-64_binding.node

> node-sass@4.14.1 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/node-sass
> node scripts/build.js


> data-bridge@0.1.0 prepare /src/repo/client/data-bridge
> node build/wikimedia-ui-base.js

Binary found at /src/repo/view/lib/wikibase-tainted-ref/node_modules/node-sass/vendor/linux-x64-64/binding.node
Testing binary
Binary is fine
added 3666 packages in 454.522s

> fsevents@1.2.9 install /src/repo/view/lib/wikibase-tainted-ref/node_modules/fsevents
> node install


> fibers@4.0.3 install /src/repo/view/lib/wikibase-tainted-ref/node_modules/fibers
> node build.js || nodejs build.js

`linux-x64-64-glibc` exists; testing
Binary is fine; exiting

> fibers_node_v8@3.1.5 preinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/fibers_node_v8
> node preinstall.js


> fibers_node_v8@3.1.5 install /src/repo/view/lib/wikibase-tainted-ref/node_modules/fibers_node_v8
> node build.js

ignore install

> ejs@3.1.3 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@wdio/cli/node_modules/ejs
> node --harmony ./postinstall.js

Thank you for installing EJS: built with the Jake JavaScript build tool (https://jakejs.com/)


> ejs@2.7.4 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/ejs
> node ./postinstall.js

Thank you for installing EJS: built with the Jake JavaScript build tool (https://jakejs.com/)


> deasync@0.1.20 install /src/repo/view/lib/wikibase-tainted-ref/node_modules/deasync
> node ./build.js

`linux-x64-node-10` exists; testing
Binary is fine; exiting

> yorkie@2.0.0 install /src/repo/view/lib/wikibase-tainted-ref/node_modules/yorkie
> node bin/install.js

setting up Git hooks
can't find .git directory, skipping Git hooks installation

> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/api/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/theming/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/client-logger/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/router/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/core-events/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/channels/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/addons/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/vue/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/lazy-universal-dotenv/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> ejs@2.7.4 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/core/node_modules/ejs
> node ./postinstall.js

Thank you for installing EJS: built with the Jake JavaScript build tool (https://jakejs.com/)


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/core/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/simplebar/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/components/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js-pure@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/core-js-pure
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/ui/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/node-logger/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/channel-postmessage/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/client-api/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/addon-links/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/addon-actions/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@3.6.5 postinstall /src/repo/view/lib/wikibase-tainted-ref/node_modules/@storybook/addon-a11y/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> tainted-ref@0.1.0 prepare /src/repo/view/lib/wikibase-tainted-ref
> node build/wikimedia-ui-base.js

added 3262 packages in 474.987s
added 1281 packages in 497.963s

$ npm test
Source code is licensed under the AGPL.