mediawiki/skins/Cosmos: REL1_40 (log #1332587)

sourcepatches

This run took 31 seconds.

From b07d428c56f4d607a280bbf559461753bab3cf86 Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Thu, 16 May 2024 18:28:29 +0000
Subject: [PATCH] [DNM] there are no updates

Change-Id: I9de7050a4b056e1484366ad0119c8935a88df5a6
---
 package-lock.json | 15 ++++++++++-----
 1 file changed, 10 insertions(+), 5 deletions(-)

diff --git a/package-lock.json b/package-lock.json
index c8cf940..d38ea2b 100644
--- a/package-lock.json
+++ b/package-lock.json
@@ -4001,7 +4001,8 @@
 			"version": "5.3.2",
 			"resolved": "https://registry.npmjs.org/acorn-jsx/-/acorn-jsx-5.3.2.tgz",
 			"integrity": "sha512-rq9s+JNhf0IChjtDXxllJ7g41oZk5SlXtp0LHwyA5cejwn7vKmKp4pPri6YEePv2PU65sAsegbXtIinmDFDXgQ==",
-			"dev": true
+			"dev": true,
+			"requires": {}
 		},
 		"ajv": {
 			"version": "6.12.6",
@@ -4628,7 +4629,8 @@
 			"version": "2.7.0",
 			"resolved": "https://registry.npmjs.org/eslint-plugin-no-jquery/-/eslint-plugin-no-jquery-2.7.0.tgz",
 			"integrity": "sha512-Aeg7dA6GTH1AcWLlBtWNzOU9efK5KpNi7b0EhBO0o0M+awyzguUUo8gF6hXGjQ9n5h8/uRtYv9zOqQkeC5CG0w==",
-			"dev": true
+			"dev": true,
+			"requires": {}
 		},
 		"eslint-plugin-node": {
 			"version": "11.1.0",
@@ -5709,7 +5711,8 @@
 			"version": "6.0.0",
 			"resolved": "https://registry.npmjs.org/postcss-less/-/postcss-less-6.0.0.tgz",
 			"integrity": "sha512-FPX16mQLyEjLzEuuJtxA8X3ejDLNGGEG503d2YGZR5Ask1SpDN8KmZUMpzCvyalWRywAn1n1VOA5dcqfCLo5rg==",
-			"dev": true
+			"dev": true,
+			"requires": {}
 		},
 		"postcss-media-query-parser": {
 			"version": "0.2.3",
@@ -5727,7 +5730,8 @@
 			"version": "6.0.0",
 			"resolved": "https://registry.npmjs.org/postcss-safe-parser/-/postcss-safe-parser-6.0.0.tgz",
 			"integrity": "sha512-FARHN8pwH+WiS2OPCxJI8FuRJpTVnn6ZNFiqAM2aeW2LwTHWWmWgIyKC6cUo0L8aeKiF/14MNvnpls6R2PBeMQ==",
-			"dev": true
+			"dev": true,
+			"requires": {}
 		},
 		"postcss-selector-parser": {
 			"version": "6.0.11",
@@ -6252,7 +6256,8 @@
 			"version": "7.0.0",
 			"resolved": "https://registry.npmjs.org/stylelint-config-recommended/-/stylelint-config-recommended-7.0.0.tgz",
 			"integrity": "sha512-yGn84Bf/q41J4luis1AZ95gj0EQwRX8lWmGmBwkwBNSkpGSpl66XcPTulxGa/Z91aPoNGuIGBmFkcM1MejMo9Q==",
-			"dev": true
+			"dev": true,
+			"requires": {}
 		},
 		"stylelint-config-wikimedia": {
 			"version": "0.13.1",
-- 
2.39.2

$ date
--- stdout ---
Thu May 16 18:28:06 UTC 2024

--- end ---
$ git clone file:///srv/git/mediawiki-skins-Cosmos.git repo --depth=1 -b REL1_40
--- stderr ---
Cloning into 'repo'...
--- stdout ---

--- end ---
$ git config user.name libraryupgrader
--- stdout ---

--- end ---
$ git config user.email tools.libraryupgrader@tools.wmflabs.org
--- stdout ---

--- end ---
$ git submodule update --init
--- stdout ---

--- end ---
$ grr init
--- stdout ---
Installed commit-msg hook.

--- end ---
$ git show-ref refs/heads/REL1_40
--- stdout ---
2d9f489a8863343057e2455ab1e1e1f7ed15aefe refs/heads/REL1_40

--- end ---
$ /usr/bin/npm audit --json
--- stdout ---
{
  "auditReportVersion": 2,
  "vulnerabilities": {
    "postcss": {
      "name": "postcss",
      "severity": "moderate",
      "isDirect": false,
      "via": [
        {
          "source": 1094544,
          "name": "postcss",
          "dependency": "postcss",
          "title": "PostCSS line return parsing error",
          "url": "https://github.com/advisories/GHSA-7fh5-64p2-3v2j",
          "severity": "moderate",
          "cwe": [
            "CWE-74",
            "CWE-144"
          ],
          "cvss": {
            "score": 5.3,
            "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N"
          },
          "range": "<8.4.31"
        }
      ],
      "effects": [
        "postcss-sorting",
        "stylelint-order"
      ],
      "range": "<8.4.31",
      "nodes": [
        "node_modules/postcss-sorting/node_modules/postcss",
        "node_modules/stylelint-order/node_modules/postcss"
      ],
      "fixAvailable": {
        "name": "stylelint-config-idiomatic-order",
        "version": "10.0.0",
        "isSemVerMajor": true
      }
    },
    "postcss-sorting": {
      "name": "postcss-sorting",
      "severity": "moderate",
      "isDirect": false,
      "via": [
        "postcss"
      ],
      "effects": [
        "stylelint-order"
      ],
      "range": "<=5.0.1",
      "nodes": [
        "node_modules/postcss-sorting"
      ],
      "fixAvailable": {
        "name": "stylelint-config-idiomatic-order",
        "version": "10.0.0",
        "isSemVerMajor": true
      }
    },
    "stylelint-config-idiomatic-order": {
      "name": "stylelint-config-idiomatic-order",
      "severity": "moderate",
      "isDirect": true,
      "via": [
        "stylelint-order"
      ],
      "effects": [],
      "range": "5.0.0 - 8.1.0",
      "nodes": [
        "node_modules/stylelint-config-idiomatic-order"
      ],
      "fixAvailable": {
        "name": "stylelint-config-idiomatic-order",
        "version": "10.0.0",
        "isSemVerMajor": true
      }
    },
    "stylelint-order": {
      "name": "stylelint-order",
      "severity": "moderate",
      "isDirect": false,
      "via": [
        "postcss",
        "postcss-sorting"
      ],
      "effects": [
        "stylelint-config-idiomatic-order"
      ],
      "range": "<=4.1.0",
      "nodes": [
        "node_modules/stylelint-order"
      ],
      "fixAvailable": {
        "name": "stylelint-config-idiomatic-order",
        "version": "10.0.0",
        "isSemVerMajor": true
      }
    }
  },
  "metadata": {
    "vulnerabilities": {
      "info": 0,
      "low": 0,
      "moderate": 4,
      "high": 0,
      "critical": 0,
      "total": 4
    },
    "dependencies": {
      "prod": 1,
      "dev": 329,
      "optional": 0,
      "peer": 0,
      "peerOptional": 0,
      "total": 329
    }
  }
}

--- end ---
$ /usr/bin/composer install
--- stderr ---
No composer.lock file present. Updating dependencies to latest instead of installing from lock file. See https://getcomposer.org/install for more information.
Loading composer repositories with package information
Updating dependencies
Lock file operations: 37 installs, 0 updates, 0 removals
  - Locking composer/installers (v2.2.0)
  - Locking composer/pcre (3.1.3)
  - Locking composer/semver (3.3.2)
  - Locking composer/spdx-licenses (1.5.8)
  - Locking composer/xdebug-handler (3.0.5)
  - Locking doctrine/deprecations (1.1.3)
  - Locking felixfbecker/advanced-json-rpc (v3.2.1)
  - Locking mediawiki/mediawiki-codesniffer (v40.0.1)
  - Locking mediawiki/mediawiki-phan-config (0.12.0)
  - Locking mediawiki/minus-x (1.1.1)
  - Locking mediawiki/phan-taint-check-plugin (4.0.0)
  - Locking microsoft/tolerant-php-parser (v0.1.1)
  - Locking netresearch/jsonmapper (v4.4.1)
  - Locking phan/phan (5.4.1)
  - Locking php-parallel-lint/php-console-color (v1.0.1)
  - Locking php-parallel-lint/php-console-highlighter (v1.0.0)
  - Locking php-parallel-lint/php-parallel-lint (v1.3.2)
  - Locking phpdocumentor/reflection-common (2.2.0)
  - Locking phpdocumentor/reflection-docblock (5.4.0)
  - Locking phpdocumentor/type-resolver (1.8.2)
  - Locking phpstan/phpdoc-parser (1.29.0)
  - Locking psr/container (2.0.2)
  - Locking psr/log (2.0.0)
  - Locking sabre/event (5.1.4)
  - Locking squizlabs/php_codesniffer (3.7.1)
  - Locking symfony/console (v5.4.39)
  - Locking symfony/deprecation-contracts (v3.5.0)
  - Locking symfony/polyfill-ctype (v1.29.0)
  - Locking symfony/polyfill-intl-grapheme (v1.29.0)
  - Locking symfony/polyfill-intl-normalizer (v1.29.0)
  - Locking symfony/polyfill-mbstring (v1.29.0)
  - Locking symfony/polyfill-php73 (v1.29.0)
  - Locking symfony/polyfill-php80 (v1.29.0)
  - Locking symfony/service-contracts (v3.5.0)
  - Locking symfony/string (v6.4.7)
  - Locking tysonandre/var_representation_polyfill (0.1.3)
  - Locking webmozart/assert (1.11.0)
Writing lock file
Installing dependencies from lock file (including require-dev)
Package operations: 37 installs, 0 updates, 0 removals
    0 [>---------------------------]    0 [->--------------------------]
  - Installing composer/installers (v2.2.0): Extracting archive
  - Installing composer/pcre (3.1.3): Extracting archive
  - Installing symfony/polyfill-php80 (v1.29.0): Extracting archive
  - Installing squizlabs/php_codesniffer (3.7.1): Extracting archive
  - Installing symfony/polyfill-mbstring (v1.29.0): Extracting archive
  - Installing composer/spdx-licenses (1.5.8): Extracting archive
  - Installing composer/semver (3.3.2): Extracting archive
  - Installing mediawiki/mediawiki-codesniffer (v40.0.1): Extracting archive
  - Installing tysonandre/var_representation_polyfill (0.1.3): Extracting archive
  - Installing symfony/polyfill-intl-normalizer (v1.29.0): Extracting archive
  - Installing symfony/polyfill-intl-grapheme (v1.29.0): Extracting archive
  - Installing symfony/polyfill-ctype (v1.29.0): Extracting archive
  - Installing symfony/string (v6.4.7): Extracting archive
  - Installing symfony/deprecation-contracts (v3.5.0): Extracting archive
  - Installing psr/container (2.0.2): Extracting archive
  - Installing symfony/service-contracts (v3.5.0): Extracting archive
  - Installing symfony/polyfill-php73 (v1.29.0): Extracting archive
  - Installing symfony/console (v5.4.39): Extracting archive
  - Installing sabre/event (5.1.4): Extracting archive
  - Installing netresearch/jsonmapper (v4.4.1): Extracting archive
  - Installing microsoft/tolerant-php-parser (v0.1.1): Extracting archive
  - Installing webmozart/assert (1.11.0): Extracting archive
  - Installing phpstan/phpdoc-parser (1.29.0): Extracting archive
  - Installing phpdocumentor/reflection-common (2.2.0): Extracting archive
  - Installing doctrine/deprecations (1.1.3): Extracting archive
  - Installing phpdocumentor/type-resolver (1.8.2): Extracting archive
  - Installing phpdocumentor/reflection-docblock (5.4.0): Extracting archive
  - Installing felixfbecker/advanced-json-rpc (v3.2.1): Extracting archive
  - Installing psr/log (2.0.0): Extracting archive
  - Installing composer/xdebug-handler (3.0.5): Extracting archive
  - Installing phan/phan (5.4.1): Extracting archive
  - Installing mediawiki/phan-taint-check-plugin (4.0.0): Extracting archive
  - Installing mediawiki/mediawiki-phan-config (0.12.0): Extracting archive
  - Installing mediawiki/minus-x (1.1.1): Extracting archive
  - Installing php-parallel-lint/php-console-color (v1.0.1): Extracting archive
  - Installing php-parallel-lint/php-console-highlighter (v1.0.0): Extracting archive
  - Installing php-parallel-lint/php-parallel-lint (v1.3.2): Extracting archive
  0/36 [>---------------------------]   0%
 20/36 [===============>------------]  55%
 35/36 [===========================>]  97%
 36/36 [============================] 100%
3 package suggestions were added by new dependencies, use `composer suggest` to see details.
Generating autoload files
16 packages you are using are looking for funding.
Use the `composer fund` command to find out more!
--- stdout ---

--- end ---
$ /usr/bin/npm audit --json
--- stdout ---
{
  "auditReportVersion": 2,
  "vulnerabilities": {
    "postcss": {
      "name": "postcss",
      "severity": "moderate",
      "isDirect": false,
      "via": [
        {
          "source": 1094544,
          "name": "postcss",
          "dependency": "postcss",
          "title": "PostCSS line return parsing error",
          "url": "https://github.com/advisories/GHSA-7fh5-64p2-3v2j",
          "severity": "moderate",
          "cwe": [
            "CWE-74",
            "CWE-144"
          ],
          "cvss": {
            "score": 5.3,
            "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N"
          },
          "range": "<8.4.31"
        }
      ],
      "effects": [
        "postcss-sorting",
        "stylelint-order"
      ],
      "range": "<8.4.31",
      "nodes": [
        "node_modules/postcss-sorting/node_modules/postcss",
        "node_modules/stylelint-order/node_modules/postcss"
      ],
      "fixAvailable": {
        "name": "stylelint-config-idiomatic-order",
        "version": "10.0.0",
        "isSemVerMajor": true
      }
    },
    "postcss-sorting": {
      "name": "postcss-sorting",
      "severity": "moderate",
      "isDirect": false,
      "via": [
        "postcss"
      ],
      "effects": [
        "stylelint-order"
      ],
      "range": "<=5.0.1",
      "nodes": [
        "node_modules/postcss-sorting"
      ],
      "fixAvailable": {
        "name": "stylelint-config-idiomatic-order",
        "version": "10.0.0",
        "isSemVerMajor": true
      }
    },
    "stylelint-config-idiomatic-order": {
      "name": "stylelint-config-idiomatic-order",
      "severity": "moderate",
      "isDirect": true,
      "via": [
        "stylelint-order"
      ],
      "effects": [],
      "range": "5.0.0 - 8.1.0",
      "nodes": [
        "node_modules/stylelint-config-idiomatic-order"
      ],
      "fixAvailable": {
        "name": "stylelint-config-idiomatic-order",
        "version": "10.0.0",
        "isSemVerMajor": true
      }
    },
    "stylelint-order": {
      "name": "stylelint-order",
      "severity": "moderate",
      "isDirect": false,
      "via": [
        "postcss",
        "postcss-sorting"
      ],
      "effects": [
        "stylelint-config-idiomatic-order"
      ],
      "range": "<=4.1.0",
      "nodes": [
        "node_modules/stylelint-order"
      ],
      "fixAvailable": {
        "name": "stylelint-config-idiomatic-order",
        "version": "10.0.0",
        "isSemVerMajor": true
      }
    }
  },
  "metadata": {
    "vulnerabilities": {
      "info": 0,
      "low": 0,
      "moderate": 4,
      "high": 0,
      "critical": 0,
      "total": 4
    },
    "dependencies": {
      "prod": 1,
      "dev": 329,
      "optional": 0,
      "peer": 0,
      "peerOptional": 0,
      "total": 329
    }
  }
}

--- end ---
Attempting to npm audit fix
$ /usr/bin/npm audit fix --dry-run --only=dev --json
--- stderr ---
npm WARN invalid config only="dev" set in command line options
npm WARN invalid config Must be one of: null, prod, production
npm WARN EBADENGINE Unsupported engine {
npm WARN EBADENGINE   package: '@es-joy/jsdoccomment@0.22.2',
npm WARN EBADENGINE   required: { node: '^12 || ^14 || ^16 || ^17' },
npm WARN EBADENGINE   current: { node: 'v18.19.0', npm: '9.2.0' }
npm WARN EBADENGINE }
npm WARN EBADENGINE Unsupported engine {
npm WARN EBADENGINE   package: 'eslint-plugin-jsdoc@38.1.6',
npm WARN EBADENGINE   required: { node: '^12 || ^14 || ^16 || ^17' },
npm WARN EBADENGINE   current: { node: 'v18.19.0', npm: '9.2.0' }
npm WARN EBADENGINE }
--- stdout ---
{
  "added": 329,
  "removed": 0,
  "changed": 0,
  "audited": 330,
  "funding": 63,
  "audit": {
    "auditReportVersion": 2,
    "vulnerabilities": {
      "postcss": {
        "name": "postcss",
        "severity": "moderate",
        "isDirect": false,
        "via": [
          {
            "source": 1094544,
            "name": "postcss",
            "dependency": "postcss",
            "title": "PostCSS line return parsing error",
            "url": "https://github.com/advisories/GHSA-7fh5-64p2-3v2j",
            "severity": "moderate",
            "cwe": [
              "CWE-74",
              "CWE-144"
            ],
            "cvss": {
              "score": 5.3,
              "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N"
            },
            "range": "<8.4.31"
          }
        ],
        "effects": [
          "postcss-sorting",
          "stylelint-order"
        ],
        "range": "<8.4.31",
        "nodes": [
          "node_modules/postcss-sorting/node_modules/postcss",
          "node_modules/stylelint-order/node_modules/postcss"
        ],
        "fixAvailable": {
          "name": "stylelint-config-idiomatic-order",
          "version": "10.0.0",
          "isSemVerMajor": true
        }
      },
      "postcss-sorting": {
        "name": "postcss-sorting",
        "severity": "moderate",
        "isDirect": false,
        "via": [
          "postcss"
        ],
        "effects": [
          "stylelint-order"
        ],
        "range": "<=5.0.1",
        "nodes": [
          "node_modules/postcss-sorting"
        ],
        "fixAvailable": {
          "name": "stylelint-config-idiomatic-order",
          "version": "10.0.0",
          "isSemVerMajor": true
        }
      },
      "stylelint-config-idiomatic-order": {
        "name": "stylelint-config-idiomatic-order",
        "severity": "moderate",
        "isDirect": true,
        "via": [
          "stylelint-order"
        ],
        "effects": [],
        "range": "5.0.0 - 8.1.0",
        "nodes": [
          "node_modules/stylelint-config-idiomatic-order"
        ],
        "fixAvailable": {
          "name": "stylelint-config-idiomatic-order",
          "version": "10.0.0",
          "isSemVerMajor": true
        }
      },
      "stylelint-order": {
        "name": "stylelint-order",
        "severity": "moderate",
        "isDirect": false,
        "via": [
          "postcss",
          "postcss-sorting"
        ],
        "effects": [
          "stylelint-config-idiomatic-order"
        ],
        "range": "<=4.1.0",
        "nodes": [
          "node_modules/stylelint-order"
        ],
        "fixAvailable": {
          "name": "stylelint-config-idiomatic-order",
          "version": "10.0.0",
          "isSemVerMajor": true
        }
      }
    },
    "metadata": {
      "vulnerabilities": {
        "info": 0,
        "low": 0,
        "moderate": 4,
        "high": 0,
        "critical": 0,
        "total": 4
      },
      "dependencies": {
        "prod": 1,
        "dev": 329,
        "optional": 0,
        "peer": 0,
        "peerOptional": 0,
        "total": 329
      }
    }
  }
}

--- end ---
{"added": 329, "removed": 0, "changed": 0, "audited": 330, "funding": 63, "audit": {"auditReportVersion": 2, "vulnerabilities": {"postcss": {"name": "postcss", "severity": "moderate", "isDirect": false, "via": [{"source": 1094544, "name": "postcss", "dependency": "postcss", "title": "PostCSS line return parsing error", "url": "https://github.com/advisories/GHSA-7fh5-64p2-3v2j", "severity": "moderate", "cwe": ["CWE-74", "CWE-144"], "cvss": {"score": 5.3, "vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N"}, "range": "<8.4.31"}], "effects": ["postcss-sorting", "stylelint-order"], "range": "<8.4.31", "nodes": ["node_modules/postcss-sorting/node_modules/postcss", "node_modules/stylelint-order/node_modules/postcss"], "fixAvailable": {"name": "stylelint-config-idiomatic-order", "version": "10.0.0", "isSemVerMajor": true}}, "postcss-sorting": {"name": "postcss-sorting", "severity": "moderate", "isDirect": false, "via": ["postcss"], "effects": ["stylelint-order"], "range": "<=5.0.1", "nodes": ["node_modules/postcss-sorting"], "fixAvailable": {"name": "stylelint-config-idiomatic-order", "version": "10.0.0", "isSemVerMajor": true}}, "stylelint-config-idiomatic-order": {"name": "stylelint-config-idiomatic-order", "severity": "moderate", "isDirect": true, "via": ["stylelint-order"], "effects": [], "range": "5.0.0 - 8.1.0", "nodes": ["node_modules/stylelint-config-idiomatic-order"], "fixAvailable": {"name": "stylelint-config-idiomatic-order", "version": "10.0.0", "isSemVerMajor": true}}, "stylelint-order": {"name": "stylelint-order", "severity": "moderate", "isDirect": false, "via": ["postcss", "postcss-sorting"], "effects": ["stylelint-config-idiomatic-order"], "range": "<=4.1.0", "nodes": ["node_modules/stylelint-order"], "fixAvailable": {"name": "stylelint-config-idiomatic-order", "version": "10.0.0", "isSemVerMajor": true}}}, "metadata": {"vulnerabilities": {"info": 0, "low": 0, "moderate": 4, "high": 0, "critical": 0, "total": 4}, "dependencies": {"prod": 1, "dev": 329, "optional": 0, "peer": 0, "peerOptional": 0, "total": 329}}}}
$ /usr/bin/npm audit fix --only=dev
--- stderr ---
npm WARN invalid config only="dev" set in command line options
npm WARN invalid config Must be one of: null, prod, production
npm WARN EBADENGINE Unsupported engine {
npm WARN EBADENGINE   package: '@es-joy/jsdoccomment@0.22.2',
npm WARN EBADENGINE   required: { node: '^12 || ^14 || ^16 || ^17' },
npm WARN EBADENGINE   current: { node: 'v18.19.0', npm: '9.2.0' }
npm WARN EBADENGINE }
npm WARN EBADENGINE Unsupported engine {
npm WARN EBADENGINE   package: 'eslint-plugin-jsdoc@38.1.6',
npm WARN EBADENGINE   required: { node: '^12 || ^14 || ^16 || ^17' },
npm WARN EBADENGINE   current: { node: 'v18.19.0', npm: '9.2.0' }
npm WARN EBADENGINE }
--- stdout ---

added 329 packages, and audited 330 packages in 3s

63 packages are looking for funding
  run `npm fund` for details

# npm audit report

postcss  <8.4.31
Severity: moderate
PostCSS line return parsing error - https://github.com/advisories/GHSA-7fh5-64p2-3v2j
fix available via `npm audit fix --force`
Will install stylelint-config-idiomatic-order@10.0.0, which is a breaking change
node_modules/postcss-sorting/node_modules/postcss
node_modules/stylelint-order/node_modules/postcss
  postcss-sorting  <=5.0.1
  Depends on vulnerable versions of postcss
  node_modules/postcss-sorting
    stylelint-order  <=4.1.0
    Depends on vulnerable versions of postcss
    Depends on vulnerable versions of postcss-sorting
    node_modules/stylelint-order
      stylelint-config-idiomatic-order  5.0.0 - 8.1.0
      Depends on vulnerable versions of stylelint-order
      node_modules/stylelint-config-idiomatic-order

4 moderate severity vulnerabilities

To address all issues (including breaking changes), run:
  npm audit fix --force

--- end ---
$ package-lock-lint package-lock.json
--- stdout ---
Checking package-lock.json

--- end ---
Verifying that tests still pass
$ /usr/bin/npm ci
--- stderr ---
npm WARN EBADENGINE Unsupported engine {
npm WARN EBADENGINE   package: '@es-joy/jsdoccomment@0.22.2',
npm WARN EBADENGINE   required: { node: '^12 || ^14 || ^16 || ^17' },
npm WARN EBADENGINE   current: { node: 'v18.19.0', npm: '9.2.0' }
npm WARN EBADENGINE }
npm WARN EBADENGINE Unsupported engine {
npm WARN EBADENGINE   package: 'eslint-plugin-jsdoc@38.1.6',
npm WARN EBADENGINE   required: { node: '^12 || ^14 || ^16 || ^17' },
npm WARN EBADENGINE   current: { node: 'v18.19.0', npm: '9.2.0' }
npm WARN EBADENGINE }
--- stdout ---

added 329 packages, and audited 330 packages in 3s

63 packages are looking for funding
  run `npm fund` for details

4 moderate severity vulnerabilities

To address all issues (including breaking changes), run:
  npm audit fix --force

Run `npm audit` for details.

--- end ---
$ /usr/bin/npm test
--- stdout ---

> test
> npm -s run lint


/src/repo/resources/skins.cosmos.search/fetch.js
  28:2  warning  Unused eslint-disable directive (no problems were reported from 'compat/compat')

✖ 1 problem (0 errors, 1 warning)
  0 errors and 1 warning potentially fixable with the `--fix` option.


resources/skinStyles/ext.echo.styles.badge.less
 49:6  ⚠  Unexpected browser feature "css-initial-value" is not supported by IE 11  plugin/no-unsupported-browser-features

resources/skins.cosmos.rail/rail.less
 136:3  ⚠  Unexpected browser feature "css-sticky" is not supported by IE 11  plugin/no-unsupported-browser-features
 137:3  ⚠  Unexpected browser feature "css-sticky" is not supported by IE 11  plugin/no-unsupported-browser-features

resources/skins.cosmos.styles/common.less
  163:2  ⚠  Unexpected browser feature "css-appearance" is not supported by IE 11                                                                                                                                                                                                                                      plugin/no-unsupported-browser-features
  199:3  ⚠  Unexpected browser feature "css-unset-value" is not supported by IE 11, Safari on iOS 9.0-9.2                                                                                                                                                                                                              plugin/no-unsupported-browser-features
  522:3  ⚠  Unexpected browser feature "css-filters" is not supported by IE 11                                                                                                                                                                                                                                         plugin/no-unsupported-browser-features
  593:2  ⚠  Unexpected browser feature "css-appearance" is not supported by IE 11                                                                                                                                                                                                                                      plugin/no-unsupported-browser-features
 1108:2  ⚠  Unexpected browser feature "css-resize" is not supported by IE 11, Safari on iOS 9.0-9.2,9.3,10.0-10.2,10.3,11.0-11.2,11.3-11.4,12.0-12.1,12.2-12.5,13.0-13.1,13.2,13.3,13.4-13.7,14.0-14.4,14.5-14.8,15.0-15.1,15.2-15.3,15.4,15.5,15.6-15.8,16.0,16.1,16.2,16.3,16.4,16.5,16.6-16.7,17.0,17.1,17.2,17.3  plugin/no-unsupported-browser-features
 2130:2  ⚠  Unexpected browser feature "intrinsic-width" is not supported by IE 11                                                                                                                                                                                                                                     plugin/no-unsupported-browser-features
 2185:4  ⚠  Unexpected browser feature "css-unset-value" is not supported by IE 11, Safari on iOS 9.0-9.2                                                                                                                                                                                                              plugin/no-unsupported-browser-features
 2250:2  ⚠  Unexpected browser feature "css-sticky" is not supported by IE 11                                                                                                                                                                                                                                          plugin/no-unsupported-browser-features
 2255:2  ⚠  Unexpected browser feature "intrinsic-width" is not supported by IE 11                                                                                                                                                                                                                                     plugin/no-unsupported-browser-features
 2319:4  ⚠  Unexpected browser feature "css-initial-value" is not supported by IE 11                                                                                                                                                                                                                                   plugin/no-unsupported-browser-features
 2397:2  ⚠  Unexpected browser feature "css-initial-value" is not supported by IE 11                                                                                                                                                                                                                                   plugin/no-unsupported-browser-features
 2543:2  ⚠  Unexpected browser feature "css-initial-value" is not supported by IE 11                                                                                                                                                                                                                                   plugin/no-unsupported-browser-features
 2601:2  ⚠  Unexpected browser feature "css-unset-value" is not supported by IE 11, Safari on iOS 9.0-9.2                                                                                                                                                                                                              plugin/no-unsupported-browser-features

resources/skins.cosmos.styles/mobile.less
 16:2  ⚠  Unexpected browser feature "css-unset-value" is not supported by IE 11, Safari on iOS 9.0-9.2  plugin/no-unsupported-browser-features

resources/extensions/PortableInfobox/PortableInfoboxDefaultTheme.less
 320:3  ⚠  Unexpected browser feature "css-initial-value" is not supported by IE 11  plugin/no-unsupported-browser-features
 323:3  ⚠  Unexpected browser feature "css-initial-value" is not supported by IE 11  plugin/no-unsupported-browser-features

resources/extensions/PortableInfobox/PortableInfoboxEuropaTheme.less
 203:3  ⚠  Unexpected browser feature "css-initial-value" is not supported by IE 11  plugin/no-unsupported-browser-features
 206:3  ⚠  Unexpected browser feature "css-initial-value" is not supported by IE 11  plugin/no-unsupported-browser-features

resources/extensions/SocialProfile/profileavatar.less
 11:2  ⚠  Unexpected browser feature "object-fit" is not supported by IE 11  plugin/no-unsupported-browser-features

resources/extensions/SocialProfile/profiletabs.less
 29:2  ⚠  Unexpected browser feature "css-unset-value" is not supported by IE 11, Safari on iOS 9.0-9.2  plugin/no-unsupported-browser-features

Checked 1 message directory.

--- end ---
$ package-lock-lint package-lock.json
--- stdout ---
Checking package-lock.json

--- end ---
[DNM] there are no updates
$ git add .
--- stdout ---

--- end ---
$ git commit -F /tmp/tmp9qem_f4t
--- stdout ---
[REL1_40 b07d428] [DNM] there are no updates
 1 file changed, 10 insertions(+), 5 deletions(-)

--- end ---
$ git format-patch HEAD~1 --stdout
--- stdout ---
From b07d428c56f4d607a280bbf559461753bab3cf86 Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Thu, 16 May 2024 18:28:29 +0000
Subject: [PATCH] [DNM] there are no updates

Change-Id: I9de7050a4b056e1484366ad0119c8935a88df5a6
---
 package-lock.json | 15 ++++++++++-----
 1 file changed, 10 insertions(+), 5 deletions(-)

diff --git a/package-lock.json b/package-lock.json
index c8cf940..d38ea2b 100644
--- a/package-lock.json
+++ b/package-lock.json
@@ -4001,7 +4001,8 @@
 			"version": "5.3.2",
 			"resolved": "https://registry.npmjs.org/acorn-jsx/-/acorn-jsx-5.3.2.tgz",
 			"integrity": "sha512-rq9s+JNhf0IChjtDXxllJ7g41oZk5SlXtp0LHwyA5cejwn7vKmKp4pPri6YEePv2PU65sAsegbXtIinmDFDXgQ==",
-			"dev": true
+			"dev": true,
+			"requires": {}
 		},
 		"ajv": {
 			"version": "6.12.6",
@@ -4628,7 +4629,8 @@
 			"version": "2.7.0",
 			"resolved": "https://registry.npmjs.org/eslint-plugin-no-jquery/-/eslint-plugin-no-jquery-2.7.0.tgz",
 			"integrity": "sha512-Aeg7dA6GTH1AcWLlBtWNzOU9efK5KpNi7b0EhBO0o0M+awyzguUUo8gF6hXGjQ9n5h8/uRtYv9zOqQkeC5CG0w==",
-			"dev": true
+			"dev": true,
+			"requires": {}
 		},
 		"eslint-plugin-node": {
 			"version": "11.1.0",
@@ -5709,7 +5711,8 @@
 			"version": "6.0.0",
 			"resolved": "https://registry.npmjs.org/postcss-less/-/postcss-less-6.0.0.tgz",
 			"integrity": "sha512-FPX16mQLyEjLzEuuJtxA8X3ejDLNGGEG503d2YGZR5Ask1SpDN8KmZUMpzCvyalWRywAn1n1VOA5dcqfCLo5rg==",
-			"dev": true
+			"dev": true,
+			"requires": {}
 		},
 		"postcss-media-query-parser": {
 			"version": "0.2.3",
@@ -5727,7 +5730,8 @@
 			"version": "6.0.0",
 			"resolved": "https://registry.npmjs.org/postcss-safe-parser/-/postcss-safe-parser-6.0.0.tgz",
 			"integrity": "sha512-FARHN8pwH+WiS2OPCxJI8FuRJpTVnn6ZNFiqAM2aeW2LwTHWWmWgIyKC6cUo0L8aeKiF/14MNvnpls6R2PBeMQ==",
-			"dev": true
+			"dev": true,
+			"requires": {}
 		},
 		"postcss-selector-parser": {
 			"version": "6.0.11",
@@ -6252,7 +6256,8 @@
 			"version": "7.0.0",
 			"resolved": "https://registry.npmjs.org/stylelint-config-recommended/-/stylelint-config-recommended-7.0.0.tgz",
 			"integrity": "sha512-yGn84Bf/q41J4luis1AZ95gj0EQwRX8lWmGmBwkwBNSkpGSpl66XcPTulxGa/Z91aPoNGuIGBmFkcM1MejMo9Q==",
-			"dev": true
+			"dev": true,
+			"requires": {}
 		},
 		"stylelint-config-wikimedia": {
 			"version": "0.13.1",
-- 
2.39.2


--- end ---
Source code is licensed under the AGPL.