mediawiki/extensions/DocBookExport: master (log #108698)

sourcepatches
From 9cfc274f1edf0dff59e382e08778955d62c7d6e3 Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Thu, 11 Feb 2021 15:57:36 +0000
Subject: [PATCH] build: Updating mediawiki/minus-x to 1.1.1

Change-Id: Idd03eaf97160024dc90aa6d2822d280ba8fcac7b
---
 composer.json | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/composer.json b/composer.json
index 68d35c5..37633f9 100644
--- a/composer.json
+++ b/composer.json
@@ -1,6 +1,6 @@
 {
 	"require-dev": {
-		"mediawiki/minus-x": "1.1.0",
+		"mediawiki/minus-x": "1.1.1",
 		"mpdf/mpdf": "^8.0",
 		"php-parallel-lint/php-console-highlighter": "0.5.0",
 		"php-parallel-lint/php-parallel-lint": "1.2.0"
-- 
2.20.1

$ date
Thu Feb 11 15:57:14 UTC 2021

$ git clone file:///srv/git/mediawiki-extensions-DocBookExport.git repo --depth=1 -b master
Cloning into 'repo'...

$ git config user.name libraryupgrader

$ git config user.email tools.libraryupgrader@tools.wmflabs.org

$ git submodule update --init

$ grr init
Installed commit-msg hook.

$ git show-ref refs/heads/master
3fb386462cfb8044599abf7c16f0ed79dace3cfb refs/heads/master

$ composer install
Loading composer repositories with package information
Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2.0 is now available and you should upgrade. See https://getcomposer.org/2
Updating dependencies (including require-dev)
Package operations: 19 installs, 0 updates, 0 removals
  - Installing symfony/polyfill-php80 (v1.22.0): Loading from cache
  - Installing symfony/polyfill-mbstring (v1.22.0): Loading from cache
  - Installing symfony/polyfill-intl-normalizer (v1.22.0): Loading from cache
  - Installing symfony/polyfill-intl-grapheme (v1.22.0): Loading from cache
  - Installing symfony/polyfill-ctype (v1.22.0): Loading from cache
  - Installing symfony/string (v5.2.3): Loading from cache
  - Installing psr/container (1.0.0): Loading from cache
  - Installing symfony/service-contracts (v2.2.0): Loading from cache
  - Installing symfony/polyfill-php73 (v1.22.0): Loading from cache
  - Installing symfony/console (v5.2.3): Loading from cache
  - Installing mediawiki/minus-x (1.1.0): Loading from cache
  - Installing php-parallel-lint/php-console-color (v0.3): Loading from cache
  - Installing php-parallel-lint/php-console-highlighter (v0.5): Loading from cache
  - Installing php-parallel-lint/php-parallel-lint (v1.2.0): Loading from cache
  - Installing myclabs/deep-copy (1.10.2): Loading from cache
  - Installing paragonie/random_compat (v9.99.100): Loading from cache
  - Installing setasign/fpdi (v2.3.6): Downloading (connecting...)Downloading (0%)           Downloading (10%)Downloading (20%)Downloading (30%)Downloading (35%)Downloading (45%)Downloading (55%)Downloading (60%)Downloading (70%)Downloading (85%)Downloading (95%)Downloading (100%)
  - Installing psr/log (1.1.3): Loading from cache
  - Installing mpdf/mpdf (v8.0.10): Downloading (connecting...)Downloading (0%)           Downloading (5%)Downloading (10%)Downloading (15%)Downloading (20%)Downloading (25%)Downloading (30%)Downloading (35%)Downloading (40%)Downloading (45%)Downloading (50%)Downloading (55%)Downloading (60%)Downloading (65%)Downloading (70%)Downloading (75%)Downloading (80%)Downloading (85%)Downloading (90%)Downloading (95%)Downloading (100%)
symfony/service-contracts suggests installing symfony/service-implementation
symfony/console suggests installing symfony/event-dispatcher
symfony/console suggests installing symfony/lock
symfony/console suggests installing symfony/process
paragonie/random_compat suggests installing ext-libsodium (Provides a modern crypto API that can be used to generate random bytes.)
setasign/fpdi suggests installing setasign/fpdf (FPDI will extend this class but as it is also possible to use TCPDF or tFPDF as an alternative. There's no fixed dependency configured.)
mpdf/mpdf suggests installing ext-bcmath (Needed for generation of some types of barcodes)
Writing lock file
Generating autoload files
12 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

Upgrading c:mediawiki/minus-x from 1.1.0 -> 1.1.1
$ composer update
Loading composer repositories with package information
Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2.0 is now available and you should upgrade. See https://getcomposer.org/2
Updating dependencies (including require-dev)
Package operations: 0 installs, 1 update, 0 removals
  - Updating mediawiki/minus-x (1.1.0 => 1.1.1): Loading from cache
Writing lock file
Generating autoload files
12 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

$ composer install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Nothing to install or update
Generating autoload files
12 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

$ composer test
> parallel-lint . --exclude vendor --exclude node_modules
PHP 7.3.19 | 10 parallel jobs
....                                                         4/4 (100 %)


Checked 4 files in 0.1 seconds
No syntax error found
> minus-x check .
MinusX
======
Processing /src/repo...
..........................................
All good!

$ git add .

$ git commit -F /tmp/tmp0kmea8lg
[master 9cfc274] build: Updating mediawiki/minus-x to 1.1.1
 1 file changed, 1 insertion(+), 1 deletion(-)

$ git format-patch HEAD~1 --stdout
From 9cfc274f1edf0dff59e382e08778955d62c7d6e3 Mon Sep 17 00:00:00 2001
From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Date: Thu, 11 Feb 2021 15:57:36 +0000
Subject: [PATCH] build: Updating mediawiki/minus-x to 1.1.1

Change-Id: Idd03eaf97160024dc90aa6d2822d280ba8fcac7b
---
 composer.json | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/composer.json b/composer.json
index 68d35c5..37633f9 100644
--- a/composer.json
+++ b/composer.json
@@ -1,6 +1,6 @@
 {
 	"require-dev": {
-		"mediawiki/minus-x": "1.1.0",
+		"mediawiki/minus-x": "1.1.1",
 		"mpdf/mpdf": "^8.0",
 		"php-parallel-lint/php-console-highlighter": "0.5.0",
 		"php-parallel-lint/php-parallel-lint": "1.2.0"
-- 
2.20.1

Source code is licensed under the AGPL.